Showing results for 
Search instead for 
Did you mean: 

All peripherals stop working except mouse pad - Strix SCAR 17

Level 7


I have a Asus ROG Strix SCAR 17 SE 2022 - G733CX.

Every so often while playing a game, I will lose "control" over the laptop. The game continues running normally, but I can't control anything.

Today, I tested and found out more:

  • All USB components stop responding - Logitech Mouse, Logitech Keyboard, Corsair Headset - if I unplug and plug back in, the items are NOT recognized
  • The built-in keyboard stops working including Num Lock, Caps Lock, CTRL+SHIFT+ESC, ALT+TAB (meaning I can't exit the game or ALT+TAB out of it)
  • The built-in mouse track pad (can't remember the right term) is still working
  • Sound is still working
  • The game is still running, and using the mouse track pad allows partial interaction with the game
  • When pulling the security dongle and re-inserting it, I hear the sound, but the usual keyboard animation does not happen
  • My keyboard lighting is set to static red, and that stays the same
  • The power button still works and tries to put the computer into some kind of sleep mode - using the keyboard does not wake up the laptop, but the mouse track pad does

Has anyone else experienced this?

Any solution for this?



Customer Service Agent

Hi @semmelbroesel ,


I would like to confirm with you whether your BIOS has been updated to the latest version 316.

Could you please try removing and then reinstalling ASUS System Control Interface v3 V3.1.17 to see if there is any improvement? Thank you.

Due to the ongoing regional holidays, my responses may be slightly delayed.
Thank you in advance for your patience.‌‌‌‌

Thanks for the suggestions.

I will try both parts when I have a chance and report here.


Level 7

Short version:

I now have BIOS 316 and the ASUS System Control Interface installed - I have no way of telling if they were already installed before or not.


Well, the process was a bit confusing - MyAsus did not show any updates, and when I searched for installed BIOS updates, it said 313 under LATEST. I tried installing 316 repeatedly, but nothing seemed to happen. I eventually entered the BIOS manually to find that I already WAS on 316.

So in MyAsus, under LATEST, I need to UNCHECK the "Show the latest version updates available" to show that 316 IS installed. Not very intuitive...

Then I downloaded the ASUS System Control Interface link and started searching for an app with that name. I couldn't find one - not in the Start Menu, not in the Add/Remove Programs interface.

I installed the app, and it still is not showing up anywhere, so I can only assume that it worked - I have no way of knowing if the app was previously installed or not.

If you have instructions on how to uninstall this app to be certain, please let me know.

I'll keep observing to see if the issue still persists.

Customer Service Agent

Hi @semmelbroesel ,


Please open Device Manager and locate "ASUS System Control Interface V3" (you can refer to the diagram below). Right-click on "ASUS System Control Interface V3" and choose "Uninstall." Afterward, install the latest version. You can verify your version using the method shown in the image below or refer to this link for instructions on confirming the version. 

We hope this information is helpful, and please continue to monitor whether the issue has been resolved. Thank you.

Due to the ongoing regional holidays, my responses may be slightly delayed.
Thank you in advance for your patience.‌‌‌‌

Oh, it's a DRIVER, not an application... Now it makes sense.

Thanks, I'll try this when I have a chance and report back here.