Showing results for 
Search instead for 
Did you mean: 

Wi-Fi Connectivity Issue: 5GHz Band Not Accessible on ET12 Node After BE98 Integration

Level 7

Hello everyone,

I hope this is the appropriate platform for my inquiry. I recently received my new BE98 router, and yesterday, I configured it as my primary router. Previously, I had a setup with 2x ET12 units, where one acted as a router, and the other served as an AiMesh node connected via wired backhaul.

This morning, I set up the BE98 as my main router from scratch and added one of the ET12 units as a node downstairs, also using a wired backhaul. However, I'm encountering an issue where I cannot connect to the 5GHz band on my ET12 node downstairs. While it worked seamlessly in conjunction with the 2x ET12 setup, now, with the BE98 and 1x ET12 combination, I can access the 5GHz band with my iPhone 14 Pro when connected to the main router (BE98), but when I'm downstairs connected to the node, it only connects via 2.4GHz. Has anyone else faced this issue?

P.S. The 2.4GHz, 5GHz, and 6GHz radios are activated and operational on the node's settings page through the web GUI. I performed a clean, fresh install after resetting my ET12 node before integrating it into my AiMesh system.


I truly appreciate any help


Level 13

I am not sure what is happening, but since the ET12 units only have one 5 GHz radio and the BE98 has two, perhaps you could try turning off the 5G-2 radio (at least one or the other) on the BE98, just to see what happens.   

You can do that in the Wireless section, Professional tab.

Maximus Z790 Hero,
Intel i9-13900k
Intel BE200

Hey and thanks for the reply.

I thought about that before posting, I turned off one of the 5 GHZ radio, with no success 😕

Level 15

Is “WiFi 7” Enabled?  (This causes a mess on the BE98 Pro beta BIOS).  Check that it is only AES, not AES+GCMP256?

Thanks for the help!

I am using the ordinary BE98 router and not the PRO model.

It is set to AES only as default.


So I double checked again, and it seems as it uses AES+GCMP256.


I disabled Wfi7 and  set to AES only.


Problem still exist :S

That may be the problem because AiMesh tries to enforce the highest security/benefit across all nodes, but the ET12 does not support WiFi 7.  Since the iPhone 14 does not support WiFi 7, at least with me, soon after having that AES+GCMP256 will eventually drop maybe half your WiFi clients.

Try to find the “WiFi 7” toggle.  It may be under the Wireless - Professional tab.  Then toggle it OFF.  Afterwards check that security changes back to AES (only).  I hope everything returns to normal and your ET 12 functions properly as a node.

I did it, and still no success. The wifi7 is disabled and network security set to AES.


I managed to connect to the 6Ghz band on ET12 with my wife’s iPhone pro 15 but my iPhone 14 pro still stuck on 2.4Ghz even if I stand literally a meter away.


I tried to reboot the node as well, no success 

There may be another setting, if you haven't tried.  On the AiMesh section - System Settings, there is a Backhaul slide button you might turn on.

Maximus Z790 Hero,
Intel i9-13900k
Intel BE200

Indeed, I toggled it on to wired backhaul which turned my 2nd 5Ghz network available for clients.