cancel
Showing results for 
Search instead for 
Did you mean: 

RT-AX56U high CPU and high RAM leading to stop routing after a few mins since May 17

titou10
Level 8

I have the same problem as described here: https://rog-forum.asus.com/t5/gaming-routers/rt-ax89x-going-out-of-memory-every-10-minutes-asd-proce...

This is not specific to RT-AX89X, it happens also on RT-A56U !!
I have the same kind of problem since this morning (May 17) with my RT-AX56U. After a few mins, internet traffic get slower and slower until it blocks totally. CPU is very high and memory is about 90% of total RAM. The only solution is to unplug/replug the router
ssh-ing to the router and then issuing "kill -SIGSTOP $(ps | grep '[a]sd$' | awk '{print $1}')" make the router back to normal: CPU ~10% and RAM ~60%
I don't know if there is a new firmware (beta or not) for the RT-AX56U to fix the problem
Firmware is 3.0.0.4.386_49380-gb9aceaf (the latest one)

7,730 Views
13 REPLIES 13

titou10
Level 8

it seems firmware 3.0.0.4.386_51665-g8072e52 on the RT-AX56U solved the problem

Yeah!

Alvez_ROG
Customer Service Agent

Hello All

I'm sorry that you have encountered such a problem, please refer to the following steps to try to troubleshoot.

How to erase all data and recover previous setups?

If you are considering initializing the settings of your ASUS router, but still like to keep your previous setups after resetting. Please follow the steps below.

Please login to ASUS Web GUI to complete all the setups.

[Wireless Router] How to enter the router setting page(Web GUI) (ASUSWRT) ?

Step 1: Export Config File

1-1. Go to: Administration > Restore/Save/Upload Setting.

網通問題1.jpg

1.2. Click “Save setting” to download your current config file.

網通問題2.jpg

*The config file should be like this.

網通問題3.jpg

Step 2: Restore To Factory Settings

2-1. Go to: Administration > Restore/Save/Upload Setting.

2-2. Check the box of “Initialize all the settings, and clear all the data log for AiProtection, Traffic Analyzer, and Web History”.

And Press “Restore” to restore your router to the initial factory setting.

網通問題4.jpg

Step 3: Import the config file 

3-1. Click “Advanced Settings” on the welcome page.

網通問題5.jpg

3-2. Upload the config file you just downloaded.

網通問題6.jpg

Notice: Router will automatically reconnect after the config file is uploaded. Please reenter to ASUS Web GUI if you need any further setups. 

Note: You could also press “Create A New Network" and follow the QIS process to create a new network.

Hi Alvez, you are tad late on the party. The fix was to use new firmware 3.0.0.4.386_51665-g8072e52 on the RT-AX56U solved the problem. At least on the aforementioned model. There must have been some time related bug in the previous firmware since it all started at the same time around the globe. Happily automatic firmware update fixed the issue without me even noticing it. I just had an while true; do killall asd;sleep 360; done in terminal restarting the offending software every 6 minutes. 

gdtrfb55
Level 7

Same issue here, but on an RT-AC65 (operating as an AP). System log confirms that the asd process is the culprit. Like a previous user stated with respect to their device, downgrading the firmware is not really an option because of intervening security fixes, etc.

UPDATE: As mentioned in the other big thread on this issue, ssh’ing into the router, deleting (the presumably corrupted) /jffs/asd/chknvram* file, and rebooting appears to have solved the issue for me. YMMV.