Showing results for 
Search instead for 
Did you mean: 

RT-AX56U high CPU and high RAM leading to stop routing after a few mins since May 17

Level 8

I have the same problem as described here:

This is not specific to RT-AX89X, it happens also on RT-A56U !!
I have the same kind of problem since this morning (May 17) with my RT-AX56U. After a few mins, internet traffic get slower and slower until it blocks totally. CPU is very high and memory is about 90% of total RAM. The only solution is to unplug/replug the router
ssh-ing to the router and then issuing "kill -SIGSTOP $(ps | grep '[a]sd$' | awk '{print $1}')" make the router back to normal: CPU ~10% and RAM ~60%
I don't know if there is a new firmware (beta or not) for the RT-AX56U to fix the problem
Firmware is (the latest one)


Level 7

I'm having the same issue. Enabling SSH, then in the terminal running `ssh`, entering your admin password to log in, then using the command `kill -SIGSTOP $(ps | grep '[a]sd$' | awk '{print $1}')` stopped the CPU spike, but did not release the memory that leaked. So I just do the above procedure right after power-cycling the router for maximum memory availability (64%).

Some people had luck with installing an older firmware and doing an NVRAM clear (holding the WPS button while turning it on, but that erases all config so better to back up the config before). But I don't want to go back to the previous firmware since it's from 2021 and missing a lot of security patches. I wonder if just clearing the NVRAM would do the trick, has anyone tried? Also, RT-AX56U seems to be supported by ASUSWRT-MERLIN so that may also fix the issue (together with NVRAM reset). Also, someone said it might be the malware protection, and it can be turned off, maybe that helps too. Haven't tried.

I am also having issues with RT-AX56U. asd process seems to consume a lot of resources and router becomes quite fast unresponsive. killall asd via ssh connection alleviates the problem but it soon returns. I wonder if Home | Asuswrt-Merlin firmware help with this issue? Problems started sometime during last night (night from 17th to 18th of May) here in Finland. System log does not really help.

Level 8

From this morning, 18 of May, I have the same problem on my RT-AX56U. I have 2 of them in Mesh. My TV on cable works, but the Wi-Fi stops constantly. I'm at work, and my wife is home office and it is complaining a lot 😀... not funny, though I can fix it when I go back home.... my firmware is the latest version ->

Screenshot_20230518-101854_ASUS Router.jpg

Level 7

Same problem here, since yesterday evening (17th May) my router has some issues.

I wonder how this could happen since I have autoupdates disabled, yet I see that my router was updated yesterday. Also this FW version is from 2022, but it's May 2023? WTF Asus.

Level 7

Good news everyone,
There is a new firmware for download for RT-AX56U

Send screenshot from the support page of AX56U and send a link with the file. I do not see anything (I based in EU->BG). Still it is firmware from 2022...Screenshot 2023-05-18 141326.png

It’s not available for direct download, but if you check for updates in router’s GUI, it will find new version.

Level 8


Is there already any feedback from the new version from someone? I mean, is it working or it is a try of fixing the issue. Hope it gets better and do not brake other things 🙂

Level 8

The RT-AX56U has a new firmware to download and hopefully will solve the problem.

It is not (yet?) visible from the ASUS site but can be downloaded direclty from the router