Showing results for 
Search instead for 
Did you mean: 

Asus RT-AC88U AC3100 Firmware update & not responding after.

Level 7

Hi All,

This is driving me up the wall as I've followed every possible method that Asus has provided to get this Router Going again.

I've got an ASUS RT-AC88U AC3100

I had it working fine and seemed to have been responding fine. In the Asus App on my app i noticed that there was a firmware update available for the router. so naturally I assumed right this sounds about right lets get this done it's a legitimate update from Asus no harm done here.

Well I was wrong there 🙄 as soon as the app began doing the firmware update I let it go and just walked away figured give the router some time to do it's thing. come back 2 hours later and find the router pretty much a paper weight. 

all i see on the LED Indicator area is a really Dim light for the power status, A bright light for the ISP/WAN LED Indicator which is solid no flash. a slightly Dimmer Light on the Ethernet Indicator & same as the Power status a really dim light for the USB 2.0 & WPS

And yes I've tried all these magical reset procedures that are scattered online, I've Tried everything the web had to offer apart from physically opening up the Router which I definitely do not want to go down that path.

I Am aware of the rescue mode that Asus offers as well but unfortunately I can't get it out of that bricked state it seems to be in.




Level 13

Official hard reset instructions:

1. Turn the router off.
2. Press and hold the "WPS" button and turn the router on.
3. Power light is on (keep holding the WPS button).
4. Release the WPS button after the power LED light starts flashing.
5. Power light stops flashing and the router will automatically reboot.

There’s a video there.  The pinhole Reset button required two consecutive presses with a paper clip to get my AXE16000 to hard reset (via that method).

I hope it’s something simple that you missed…. 

Unfortunately I tried all the instructions online from the official site and whatever else I could research but nothing help.


I think what's sad though the thing has never been used I took it out of the box performed the firmware update and it bricked it. And when I reached out to Asus. All they cared about is how many different ways they can charge me to look at it. Because it's out of warranty. $60 for inspection. Plus I cover all freight and on-top of that all additional components. I mean I know it's most likely a corrupt bootloader and they'll open it up and reflash it and put it back together. And make up some crazy story about additional parts and I'd get charged the cost of a new router. Asus should be taking some responsibility for the fact that the firmware they provided isnt very stable to begin with causing these routers to brick.


Would be nice if they were going to help out a little.

Bottom line did you try leaving the power switch ON but disconnect everything from it and let it sit for a while?

They’ve been really helpful to me while in warranty so it’s a bummer this has sat new unopened until out of warranty?

Anyways trying to get a better picture so I can compare with what I found Googling…

Just these past couple of days (maybe 3) there was an issue that basically (temporarily) bricked some model ASUS routers/repeaters.  In my setup (AXE16000 router, nodes AXE11000, RT-AX86U, RT-AC68U, RP-AX58, and RP-AX56) this appeared to brick my RP-AX56.  I unplugged it from the wall (no power switch), disconnected the Ethernet cable, and let it sit overnight.  The next morning I was able to re-add it as a node even though it was blinking like I had failed to add it).

Yeah, so what I've done is left it powered down over the weekend..(Unplugged it from power)... MAYBE if i power it up today I might have a chance at getting this thing to come alive again. In my history with this stuff and seeing what it's doing I Highly doubt it because when i tried a very similar method few days ago where i left the power out of it for a few hours when I would power it up, the router returned to that bricked state that I initially referred to but Oddly enough (I timed this) about 40 minutes later when it was plugged in and powered up those same WAN & Ethernet Lights began flashing rapidly and then about 15-20 minutes later the whole router just shut itself off.

I know you’re aware of Rescue Mode.  I (thankfully) haven’t had to resort to it when I nearly bricked my AXE16000 with a beta firmware.  I have just recently been made aware of it so I apologize for beating a dead horse (so to speak).

Step 3-3 what does the power light show when you try?

Nah that's fine guess you're trying to help to see what we can do to get it going again. Unfortunately that Power Light does nothing. status won't change no matter how long i press the reset button or WPS or both just for the sake of trying lol.