Showing results for 
Search instead for 
Did you mean: 

Asus AiMesh Node (RP-AX56) - Keeps disconnecting

Level 10

AiMesh Router: RT-AX89X (Firmware: (Product Link:
AiMesh Node: RP-AX56 (Firmware: (Product Link:

Issue: Bought the RP-AX56 to expend my network, used WPS to quick connect to the node/ router. Worked great for two months. Today my routed needed to be rebooted. Noticed my node light blinking blue like if I actived the WPS button on the node but it wasn't connecting to the router, so I tapped the WPS button on my router and waited 5 min, Node didn't connect. Unplugged/ plugged back in the Node. Went from white light to blinking blue. Tapped the WPS button on the router, node light turns green. Hazzah. On or about 20 min later node disconnects and blinks blue again like it want's to connect to the router. Tap WPS button on Router. Node doesn't connect. Only time the node will connect back to the Router is if I unplug and plug back in the Node. Again it only lasts for 20-30min before it just disconnects.

Problem solving: I tried to factory reset the Node, no luck there. Tried a different power cable, that wasn't the issue. I have the late firmware for both the Node and the Router. Googled terms "ASUS RP-AX56 keeps disconnecting" and "ASUS AiMesh node keeps disconnecting" no such luck on this particular use case. Any clue what it could be?


(As background I usually have plenty of time to try different debugging).  What happens if you unplug the uplinked one, add the nonfunctional one, then plug the working one back in?

Sorry been a few days and various tests. Neither are nonfunctional, but can't get both working at the same time (well at least not for any reasonable length of time). One will always get disconnected after a random amount of time, but it could be either node, there is no consistency. The other one will remain connected. There is no real log information showing in the GUI. Haven't bothered to telnet or SSH in and look at any other debug info.

Also both are connected by 1Gbps Ethernet back-haul. Not using WiFi for AiMesh setup. No consistency on reconnect either. Sometimes I can just pull the Ethernet cable for 30 seconds on disconnected node and then reconnect the cable and after a minute or so it reconnects to mesh. Other times this doesn't work and need to power cycle the node. Removing and re-adding nodes doesn't change this bug. Eventually after a re-add of a node the behavior returns within usually within 24 hours.

In simple terms I can remove both nodes and re-add both nodes and both will work for a random amount of time. Sometimes minutes, other times hours (maybe a day). Eventually one will just randomly disconnect from the mesh. Wiring is all ok, cable test ok, connecting laptop to ports and running LAN test software to check for dropped packets or other failures shows no issue, so not a back-haul cabling problem.

Still think it is buggy RT-AX86U 388 firmware incompatibility with node firmware. Might roll back to the 21709 version at some point if I get time and it annoys me too much. Otherwise will just powercycle where required. As I have good coverage with only one node it is not critical in my situation just annoying until Asus hopefully fix issue.

I have one RP-AX56 and RP-AX58 similarly setup with Ethernet backhaul.  (I’m afraid I forgot if I already mentioned this in this thread).  They are physically near enough to other nodes, RT-AX86U and RT-AC68U respectively, that they could WiFi backhaul if something is wrong with the Ethernet.  I leave all backhaul settings Auto.

Since it’s a challenge reaching the RP-AX56 sometimes I have left it dropped hoping it will find its way back.  After a few hours if I still find it disconnected I will unplug it and plug it back in, (ethernet cord still plugged in if that matters, I don’t believe so as there’s no PoE).  I would not advise forcing Ethernet backhaul as I am not confident the implementation is without bugs, meaning I have had nodes drop and never come back, (hence the all Auto approach).  I would not hard reset it and re-add, as this cycle of searching for the best backhaul option seems to start over again.  When I had a power outage the first advice I got here was did you try powering down the node and powering it back on.  That tends to work most of the time.  During the first x amount of time I suspect the node is testing among backhaul options and finding the best option…

If there’s any way to reverse download the firmware from the RP to a file I am happy to do it so people have access to the  Maybe someone knows?

Also about the time many ASUS users lost use of their equipment there was some sort of hidden update that needed repairing, which I suspect they solved in one day as I can’t forget the next morning (Thursday) I was able to add my RP-AX56 as a node and everything has been good.  I have AiProtection always on (currently my main router is an AXE16000) and it always warns me that I have Enable access from WAN ON.  I am able to check on my network via the ASUS Router Ap while away.  Is this a prerequisite to getting the fix?

My problems only resolved after a factory reset of my router as well as my repeater. My system has been solid for several days after doing so. Somewhere earlier on this thread, a moderator outlined the process using the web gui.

All done previously. There is definitely a bug in firmware and I am pointing most likely to latest router firmware, but given I still do not seem to get "2" version of node firmware being available it could be that the node firmware has incompatibility.

Level 7

Thanks for the feedback it is greatly appreciated. I guess I will do a factory reset of my RP-AX56 using a pin to press the reset button on the extender for 5 seconds and then reconnect the extender as a new node to my Asus RT-AX86u router with the Asus app on my Android phone. My Asus RT-AX86u router doesn't seem affected by the issue and all my other devices connected to the router once I took the extender offline.

I will have to wait till the weekend when I have the house to my self, hopefully it will work the first time...

The reset that finally worked for me was to hold down the wpa button while plugging in the RT-AX56 and releasing the button only after the indicator light went back out. Though I had reset it previously with the paper clip reset. It only became re-discoverable with the wpa factory reset method.

The same for me. Onew ould think that resetting using the reset button that is actually named reset would work, but no....

Level 7

I'm having the same issue. Seems like nothing works properly nowadays... even this page for some reason i cant scroll up to read it properly. My RP-AX56 keeps going back to flickering blue... doesnt matter if i press wps or i try to reset.. seems the only thing that works is to unplug it... Also makes no sense that the asus software doesnt keep track of the rp-ax56 just because its not connecting properly... feels like i dont have any other asus device besides the router... This is driving me crazy... please help... just for once i want something that works properly

Level 7

Seems I should use the hard factory reset method then, using the WPS button on my RP-AX56, and not the soft method using the pin.

The hard factory reset method as described here:

I translated the steps to match the fact that it is a repeater without a power button and not a router.

1. Unplug the repeater.
2. Press and hold the "WPS" button and plug the repeater in to the power outlet again.
3. Power light is on (keep holding the WPS button).
4. Release the WPS button after the power light is off.
5. Reboot the repeater by unplugging it and then plugging it into the power outlet again.

6. Add as a new node with your prefered method (in my case Android Asus App).