Showing results for 
Search instead for 
Did you mean: 

Asus AiMesh Node (RP-AX56) - Keeps disconnecting

Level 10

AiMesh Router: RT-AX89X (Firmware: (Product Link:
AiMesh Node: RP-AX56 (Firmware: (Product Link:

Issue: Bought the RP-AX56 to expend my network, used WPS to quick connect to the node/ router. Worked great for two months. Today my routed needed to be rebooted. Noticed my node light blinking blue like if I actived the WPS button on the node but it wasn't connecting to the router, so I tapped the WPS button on my router and waited 5 min, Node didn't connect. Unplugged/ plugged back in the Node. Went from white light to blinking blue. Tapped the WPS button on the router, node light turns green. Hazzah. On or about 20 min later node disconnects and blinks blue again like it want's to connect to the router. Tap WPS button on Router. Node doesn't connect. Only time the node will connect back to the Router is if I unplug and plug back in the Node. Again it only lasts for 20-30min before it just disconnects.

Problem solving: I tried to factory reset the Node, no luck there. Tried a different power cable, that wasn't the issue. I have the late firmware for both the Node and the Router. Googled terms "ASUS RP-AX56 keeps disconnecting" and "ASUS AiMesh node keeps disconnecting" no such luck on this particular use case. Any clue what it could be?


I spent a few hours and got the repeater reconnected to router via multiple resets. At that point I managed to reflash the firmware on the repeater with the version on Asus website. Appears to be holding steady now.

Level 10

Yep did the same with the AiMesh Node: RP-AX56 (Firmware: (Product Link: Did two factory defaults and now the network is fully back up. What a ****** show ASUS, all the money in the world and couldn't do the basic. Can't wait for the day I can 3D print a router and use open source and never have to buy any more corporate ******. 

Level 7

So the solution is to factory reset the RP-AX56 and reconnect it to the router again as a new node?

Nothing else?

Can anyone confirm that this course of action has worked for them?

Confirming it has worked for me but your mileage may vary. For me it was broken without intervention. Suspicion is that a firmware update was automatically pushed to the repeater and subsequently has been removed from circulation… When I reflashed it apparently had a more recent bios than that currently indicated as most recent on the Asus download page.

I can confirm that after giving up on reestablishing uplink for the day, I disconnected it overnight, re-added it in the morning by hard reset and add in iOS app.  I then moved it back to my storage room.

If you use a desktop Google Chrome browser and opened the ASUS (networking) webpage a pop up apology letter showed up.  (Technically I think it was something on their end that bricked it, then fixed it, but strangely only my RP-AX56 was affected, not the other 5:  RP-AX58, RT-AC68U, RT-AX86U, AXE11000, AXE16000).

I ended up factory re-setting my router AND the RP-AX56 which, in the end, seems to have  worked, though that was not a painless process. I must have reset the repeater ten different times in four different ways, ending up at one point in rescue mode which is useless for somebody using a Mac. So I can confirm that at least part of the solution is a factory reset. Whether you need to also do that for your router, as I did,I do not know. My home network seems pretty solid now, though.

No joy. I have two RP-AX56 with RT-AX86U. Hard factory reset of RP-AX56 and the adding as new node works at first, then when I add second it disconnects the first one. Try re-adding first one and it disconnects second one. I can only get one RP-AX86 to stay connected at a time, better than some on the forum but still clearly issues. Just wondering if it is more a firmware update of the routers as from what I can see the RP-AX56 firmware has not been updated since 09/06/2021 but my routers latest firmware was updated recently version 15/05/2023 prior to that I was running version because all the other versions since that release had been unstable with various issues. Looks like this latest version may have an AIMesh connection issue with the RP-AX56, but everything else in the router seems stable.

Given the age of the firmware for the RP-AX56 maybe there is now incompatibilities between the 388 versions in the router and the RP series needs firmware updates to match. I haven't been able to find version for the RP-AX56 mentioned by others in this thread, I suspect it was pulled for various critical issues if it existed.


There are 3 ways to get to the user settings, web browser, iOS app, and Android app.  Each have a way to check for firmware updates.  (Sometimes one works and the other doesn’t).  But anyways check there for the one ending in “2”.  Yes it is a bummer that last firmware update listed is from 2021 which is 2 years ago roughly.

RP-AX56 is an AX repeater which should allow repeater, access point, bridge, or AiMesh node.  Since it is AX it should support firmware but it has not been released.

Both RPs worked prior to the latest BIOS for the RT-AX86U?

Neither web interface or Android app show availability of the "2" version of the firmware.

RPs both worked on the 21709 version of the router firmware. I could roll back, but the security fixes and relative stability of the latest firmware this round is more important than the one out of two nodes being disconnected.