Showing results for 
Search instead for 
Did you mean: 

Asus AiMesh Node (RP-AX56) - Keeps disconnecting

Level 10

AiMesh Router: RT-AX89X (Firmware: (Product Link:
AiMesh Node: RP-AX56 (Firmware: (Product Link:

Issue: Bought the RP-AX56 to expend my network, used WPS to quick connect to the node/ router. Worked great for two months. Today my routed needed to be rebooted. Noticed my node light blinking blue like if I actived the WPS button on the node but it wasn't connecting to the router, so I tapped the WPS button on my router and waited 5 min, Node didn't connect. Unplugged/ plugged back in the Node. Went from white light to blinking blue. Tapped the WPS button on the router, node light turns green. Hazzah. On or about 20 min later node disconnects and blinks blue again like it want's to connect to the router. Tap WPS button on Router. Node doesn't connect. Only time the node will connect back to the Router is if I unplug and plug back in the Node. Again it only lasts for 20-30min before it just disconnects.

Problem solving: I tried to factory reset the Node, no luck there. Tried a different power cable, that wasn't the issue. I have the late firmware for both the Node and the Router. Googled terms "ASUS RP-AX56 keeps disconnecting" and "ASUS AiMesh node keeps disconnecting" no such luck on this particular use case. Any clue what it could be?


Level 7

Hi all from Germany,

my setup is AI-Mesh with two RT-AX92U and one RP-AX56. This morning Internet was down. I had to restart all (routers and extenter) twice, I updated firmware on the two RT-AX92U to gain a stable internet connection back. However, though the two RT-AX92U seem to work nicely again, the RP-AX56 is having the same issue as described above.

I tried different attempts to fix it with no permanent success: Brought the AX56 close (1,5 m) to the main router -> no success; hardwired the AX56 to the main router -> success, seemed stable; changed settings to prefer 5Gz backhaul and restartet AX56 while hardwired -> seemed stable; brought it back to the assigned spot in the house -> started ok, not stable, however; disconnected all devices from AX56 -> seemed stable (but where is the beneft here) -> reconnected devices -> lost connection. While I was doing all this I din't permanently monitor the devices, so I might have missed something (don't nail me down on this description).

I added the RP-AX56 to the setup about 18 months ago an it had worked like a charm ever since up to today. I was wondering about a hardware failure, but after reading all these comments I am afraid that ASUS has a weird bug in the system, which won't be cleared by some restarts, resets, firmware updates or setting changes. ASUS technicians need to come into the game to solve this issue. I hope they are reading this forum as well.

Waiting together ...

Level 7

Same issue in Australia started 18 May 2023. I've been using the RP-AX56 with RT-AX86U for some time without any issues until now. Re powering the RP-AX56 will create a stable connection for a few minutes and then drop out to flashing blue.

Level 7

Exactly the same issue as described here as of today! Did an update get pushed without me asking/giving permission for it? Seems a little to odd that this is happening to so many people right now. And we are just the ones to find this forum.

Level 7

This link ( ) suggested by Piotrek in this thread ( ) lead to this site ( ), which gave me some insight:

The firmware 388 doesn't seem to be affected, which would explain, that my RT-AX92U were fine after the firmware upgrade - before I had 386 running.

Unfortunately, there is no non-386 formware for the RP AX56 available, not even Beta. So, even downgrading won't work. 😞

Level 7

Same issue from Canada. This seems like an Asus firmware bug affecting all owners of this device... do you believe this will be solved by Asus and pushed out? Or will there need to be action taken on our part to update, reset, etc.?

I suspect malicious attack.  Recently ASUS got bad rep by posting beta firmware and saying “it voids your warranty”.  (I suspect someone taking revenge).  I went to look at that BIOS and no such wording was there.  (I was curious as to the exact wording that people complained about to see if it was true/if I interpret it the same way).

How can a bug manifest itself at the exact same time for everyone?  This isn’t Y2K, which I lived through.  (I guess I could be wrong)…

Level 7

I followed ENGER's instructions ( ) and replaced the /jffs/asd/chknvram2020516 file with chknvram2020518. We'll see how long it is going to last - for ENGER it worked at least for 3 hours and 43 minutes, maybe even longer (no information available).


After finish (and automatic reboot) the new file chknvram2020518 should be in its place.

Writing this took me 20 min and the RP-AX56 is still up an running nicely.

Do it at your own risk - I am not a geek.

Customer Service Agent

Hello All

I'm sorry that you have encountered such a problem, please refer to the following steps to try to troubleshoot.

How to erase all data and recover previous setups?

If you are considering initializing the settings of your ASUS router, but still like to keep your previous setups after resetting. Please follow the steps below.

Please login to ASUS Web GUI to complete all the setups.

[Wireless Router] How to enter the router setting page(Web GUI) (ASUSWRT) ?

Step 1: Export Config File

1-1. Go to: Administration > Restore/Save/Upload Setting.


1.2. Click “Save setting” to download your current config file.


The config file should be like this.


Step 2: Restore To Factory Settings

2-1. Go to: Administration > Restore/Save/Upload Setting.

2-2. Check the box of “Initialize all the settings, and clear all the data log for AiProtection, Traffic Analyzer, and Web History”.

And Press “Restore” to restore your router to the initial factory setting.


Step 3: Import the config file 

3-1. Click “Advanced Settings” on the welcome page.


3-2. Upload the config file you just downloaded.


Notice: Router will automatically reconnect after the config file is uploaded. Please reenter to ASUS Web GUI if you need any further setups.

Note: You could also press “Create A New Network" and follow the QIS process to create a new network.


Ummmm yea, no. As much as I would love to go though all of that to have my system back before ASUS pushed that BAD update to your asd router security daemon. Please revert whatever was done so this stops being a time vampire!

This is a lot of steps which only wastes time. It does not fix the fact that the only available driver on your website for RP-AX56 now works only for five minutes at a time. Please fix the driver and notify all of us when we can download the fix.