cancel
Showing results for 
Search instead for 
Did you mean: 

XG-C100C v2 rev 3 Flawed Detection on Reboots & Cold Boots, Marvell Antigua AQC107

life_aquatic
Level 7
In July, I installed five XG-C100C V2 rev 3 into my work PCs.

All of them have intermittent (monthly maybe) problems with disappearing on reboot or cold boot. By disappearing I mean that they either no longer appear in device manager at all (not even with an exclamation point). This behavior is also mentioned in a post HERE

The only thing that will restore the function of the cards is draining the flea power from the systems when this happens. Doing this will return the card to “ASUS XG-C100C 10G PCI-E Network Adapter” in device manager.

Another way these cards cease functioning is they’ll regress to “Marvell Antigua Engineering Sample” in device manager with a driver loaded but the NIC doesn’t pass traffic. When this happens…again the only thing that will restore the function of the cards is draining the flea power from the systems and the cards will return to “ASUS XG-C100C 10G PCI-E Network Adapter” in device manager.

HERE is another person on Reddit with the exact same “engineering sample” problem with this ASUS card.

Perhaps the nature of both card detection problems is related.

All five of my PCs are running the latest driver 3.1.6.0 with fully updated Windows 10 Enterprise. The problem also occurred with Asus driver 3.0.20.0. All cards are running in Dell Workstations (Intel C610 chipset) with latest BIOS. I’ve tried all possible PCIe slots. PCIe gen 2 and PCIe gen 3. All the cards are ROM 1.0.1. The only way I was able to determine the ROM was by attempting to boot the NIC because the Marvell flash tool reports the FW as 0.0.0.

I have not disabled any of the advanced driver level power saving features of these cards.

Like this post HERE , I tried to see if the Marvell diag tool would read the firmware correctly and allow force flashing like other folks have done with rev 2 or earlier cards. Sadly, the diag tool just returns “no devices found even when using the K switch and selecting to install the driver. Selecting to install the driver just returns “no devices to install driver with.”

These same workstations haven’t had PCIe card detection issues with any other PCIe cards including the following (USB 3 controllers, USB C controllers, Realtek NICs, Intel NICs, Emulex NICs, Trendnet NICs)

This AQC107 is a popular chip sold under lots of brands (Syba, TRENDnet, Sonnet, TP-Link, etc). If anyone can confirm another brand's version of AQC107 doesn’t have this issue that would be awesome.
9,707 Views
16 REPLIES 16

Sn0wr_de
Level 7
I have the same issue for a ASUS XG-C100C V2 rev 3 , no firmware updates possible despite editing the xml file .

tried to do some more digging using the OEM109.inf file which is part of the driver package and which seems to be used as inf name (via detail property) :

my ASUS XG comes back with a vendor id of "1D6A" which is "Antigua" and a device id of "94C0 ". the device id 94 is a "AQC113CS" card and clearly not a Asus XG-C100C card with a AQC107 !??

PCI\VEN_1D6A&DEV_94C0&SUBSYS_88121043&REV_03


If we look in the OEM109.inf file we find that the "Marvell Antigua Eningeering Sample" description is used only when PCI vendor id equals [1D6A] (which is to no surprise "Aquantia corp") AND when Device ID = 00C0. So this means indeed that the card seems to hang whereas the driver assumes or receives a 00 device id . In other words the card is as good as dead imo and needs a power cycle reset. Now This can still be a driver induced failure .

It's also a bit odd imo that in the OEM109.inf there is no reference to rev_03 , I only find referrences to rev_02. and this for all vendors (PTT /Asus/Gigabyte/ASRock/Edimax/MSI/super micro/Caldigit/sonnet/OWC/Inxtron/Lenovo/HP/Synology/QNAP/DELL/ITI-Tek/Alied telesis/Buffalo) with the exception of the First 8 device ID of Antigua Brand which show no revision reference ...

we see there :

[Marvell.NTamd64.10.0]
; DisplayName Section DeviceID
; -----------------------------------------------------------------------------------------------
%AntiguaSample.DeviceDesc% = Antigua10G, PCI\VEN_1D6A&DEV_00C0
%AQtion-10G.DeviceDesc% = Antigua10G, PCI\VEN_1D6A&DEV_94C0 ; AQC113CS
%AQtion-5G.DeviceDesc% = Antigua5G, PCI\VEN_1D6A&DEV_93C0 ; AQC114CS
%AQtion-10G.DeviceDesc% = Antigua10G, PCI\VEN_1D6A&DEV_04C0 ; AQC113
%AQtion-10G.DeviceDesc% = Antigua10G, PCI\VEN_1D6A&DEV_14C0 ; AQC113C
%AQtion-2.5G.DeviceDesc% = Antigua2.5G, PCI\VEN_1D6A&DEV_12C0 ; AQC115C
%AQtion-10G.DeviceDesc% = Antigua10G, PCI\VEN_1D6A&DEV_34C0 ; AQC113CA
%AQtion-1G.DeviceDesc% = Antigua1G, PCI\VEN_1D6A&DEV_11C0 ; AQC116C
%Asus.XG.DeviceDesc% = Antigua10G, PCI\VEN_1D6A&DEV_94C0&SUBSYS_88121043 ; AQC113CS
%AQtion-10G.DeviceDesc% = Antigua10G, PCI\VEN_1D6A&DEV_14C0&SUBSYS_104E17AA&REV_02 ; AQC113C
%AQtion-10G.DeviceDesc% = Antigua10G, PCI\VEN_1D6A&DEV_14C0&SUBSYS_105617AA&REV_02 ; AQC113C
%AQtion-10GBASE-T.DeviceDesc% = Antigua10G, PCI\VEN_1D6A&DEV_14C0&SUBSYS_E0001458&REV_02 ; AQC113C
%AQtion-10G.DeviceDesc% = Antigua10G, PCI\VEN_1D6A&DEV_14C0&SUBSYS_D1131849&REV_02 ; AQC113CS

yes the ASus XG appears as a Antigua10G with that vendor and with that device id and with the exact sdid=8812 and svid=1043 but described as a AQC113CS

whilst under the ASUS list , indeed no hit ...the list ends with AQC112C seems almost like the AQC113CS was mistakenly moved to the Antigua header ??? or someone was pretty lazy and just though to adapt the description under antigua ? imo this is weird or at least messy ...and not a rev03 either and this could possibly be were our problems come from... and one would expect the firmware update to work out of the box ( Asus/marvell anybody home ?? )

; *** ASUS
%Asus.ROG.DeviceDesc% = Atlantic10G, PCI\VEN_1D6A&DEV_D107&SUBSYS_872E1043&REV_02
%Asus.ROG.DeviceDesc% = Atlantic10G, PCI\VEN_1D6A&DEV_07B1&SUBSYS_872E1043&REV_02
%Asus.XG.DeviceDesc% = Atlantic10G.Asus.XG, PCI\VEN_1D6A&DEV_D107&SUBSYS_87411043&REV_02
%Asus.XG.DeviceDesc% = Atlantic10G.Asus.XG, PCI\VEN_1D6A&DEV_07B1&SUBSYS_87411043&REV_02
%Asus.XG.DeviceDesc% = Atlantic10G.Asus.XG, PCI\VEN_1D6A&DEV_07B1&SUBSYS_87421043&REV_02
%AQtion-10G.DeviceDesc% = Atlantic10G.Asus.200F, PCI\VEN_1D6A&DEV_D107&SUBSYS_200F1043&REV_02
%AQtion-10G.DeviceDesc% = Atlantic10G.Asus.205F, PCI\VEN_1D6A&DEV_D107&SUBSYS_205F1043&REV_02
%AQtion-10G.DeviceDesc% = Atlantic10G.Asus.208F, PCI\VEN_1D6A&DEV_D107&SUBSYS_208F1043&REV_02
%Asus-10G.DeviceDesc% = Atlantic10G, PCI\VEN_1D6A&DEV_D107&SUBSYS_87571043&REV_02
%Asus-10G.DeviceDesc% = Atlantic10G, PCI\VEN_1D6A&DEV_07B1&SUBSYS_87571043&REV_02
%Asus-5G.DeviceDesc% = Atlantic5G, PCI\VEN_1D6A&DEV_D108&SUBSYS_875B1043&REV_02
%Asus-5G.DeviceDesc% = Atlantic5G, PCI\VEN_1D6A&DEV_08B1&SUBSYS_875B1043&REV_02
%Asus.AQC111C.DeviceDesc% = Atlantic5G, PCI\VEN_1D6A&DEV_11B1&SUBSYS_87721043&REV_02
%Asus.AQC112C.DeviceDesc% = Atlantic2.5G, PCI\VEN_1D6A&DEV_12B1&SUBSYS_87751043&REV_02

so Instead i went looking for a AQC113 rev3 driver and I found one issued by Dell ... but to no avail as it has the same results in the new OEM110.inf file ( so the same as above).

The Firmware updates will never work as long as there is no reference for a firmware image for the AQC113CS in the updatedata.XML file and as long as there is no corresponding clx firmware image file.
( for now there are only image references to be found for the AQC111 /AQC107 /AQC100 and none for the AQC113CS ... so no luck for all of us "REV3" owners as rev3 is a 113CS apparantly.)

any other experiences out there from REV3 owners ? ( do we all have that device id referring to the AQC113 ?)

kind regards,
Sn0wr!de

So I'm going back and forth with Asus support on CASE NO= N2211026259-0001

The first thing they're suggesting I do is update to driver 3.1.7.0. The rep gave the following link
https://www.asuswebstorage.com/navigate/a/#/s/6A510944D5E246EC9F426AA082C4B3F04

In case that link goes down it looks like it's also on Station Drivers here (appears to be malware free per VirusTotal)
https://www.station-drivers.com/index.php/en/component/remository/func-startdown/5423/lang,en-gb/

Here were the release notes for driver 3.1.7.0 Dated May 19 2022
* Add support at MUP package for Win11
* Added new SVID/SSID
* Remove rev in matching strings
* Disabled WOL when removing check mark “Allow the computer to turn off this device to save power� in the Power Management tab.
* Moved Device ID 0x00C0 AntiguaSample to a lower priority

Interesting it makes note of "Moved Device ID 0x00C0 AntiguaSample to a lower priority." I wonder what's up with the priority thing?

I would have thought this problem was more likely a firmware problem....just given how frequently these cards fail to initialize correctly to even be reported in BIOS. E.G. right at this moment I just cold booted my system for the day and the card wasn't even detected by BIOS so it's not possible for it to show up in Windows and do any driver stuff when that happens. Chances are it won't detect again unless I drain the flea power on the PC like I've had to do so many times with all five of these Asus XG-C100C v2 rev 3

Thanks for all the feedback and input.

I'm wondering if all of us just had bad luck and been getting some bad batches or something? Note that mine took ages to come as they were out of stock everywhere..

At the moment, the card is back in its box for me as I have a v1 that works like a charm. I'm hoping we finally get some help/answers from Asus to make these v2 useable..

@zbugrkx

What I suspect is that they suffered from chip shortages like many others and hence they went with the AQC113CS chipset instead.

It explains the long wait times to get a card.

and indeed I have Two older XG-C100C card which work flawlessly but these are AQ107 based.

@life_aquatic

Thanks for posting the driver update link, appreciated !

let's see if that driver update improves anything, else we'll have to wait until there is a clx firmware image available.

The release notes indicate that it was a hurry job ...if they indicate a "lower priority" it suggest they changed their code in regards with waiting for a return id from the card so either they wait longer now or they changed the " assumption" algorythm wich would indicate a "engineering sample".

kind regards,
Sn0wr!de

Sn0wr!de wrote:
@zbugrkx

What I suspect is that they suffered from chip shortages like many others and hence they went with the AQC113CS chipset instead.

It explains the long wait times to get a card.

and indeed I have Two older XG-C100C card which work flawlessly but these are AQ107 based.


Wow. It's just now hitting me like a ton of bricks the significance of what you said, and how Marvel hasn't posted anything on their site for AQC113 as of yet.

As for what happened with my ticket...I've never seen a company send so many "We are currently working with our Technical Support Department to determine the best next steps for resolution. You will receive a follow up within 24-48 business hours." Despite my asking 10+ times at no point did they actually escalate my ticket to a technical staff nor were they willing to call me and remote control one of these PCs.

I submitted it to the Better Business Bureau on Dec 8th. Even then, the person that followed up did the very same thing over and over all the way up until two weeks ago when they finally processed a cross shipment sending the exact same revision cards. I'm cutting my losses and selling them on eBay. I just ordered a TP-Link 107 cards (TX401) which I couldn't find any example of users observing this disappearance or engineering sample problem. I also haven't heard of TP-Link switching to the AQC113 chip.

Has anyone heard anything or found any solution?

I have two of these and they are literaly paper weights. No matter what tweaking I do, they'll randomly work (no packets at all) and when they do, show awful throughput (4/6gbs at best) compared to a v1 in the exact same machine.

I'm desperatly trying to buy a spare v1 in case mine ever die 😄 but was really hoping we would have had a fix by then... I can't believe that asus isn't aware of this and is ignoring everyone but just keep selling it?

Hello, 

Yes for sure it just hitting me too when you said they've gone with 'AQC113CS chipset' regarding the chip shortage.

Also, i've done a report regarding all the information i could gather from my 'ASUS XG C100C V2' aka 'AQC113CS'.

To push a little bit further i've found on the https://github.com/Aquantia (Marvell Semiconductors (ex Aquantia Corp) 😥), that our revision, the 94C0-88121043 is unfortunatly not being a part of the game... aq_main.c

Also, the code wasn't updated since Oct 4, 2022, nor the https://github.com/Aquantia/AQtion repo also. The DELL driver that can be found there https://www.dell.com/support/home/en-uk/drivers/driversdetails?driverid=g5t0f&lwp=rt wasn't working since we're mostly as you said talking about a firmware update.

To sum up:

  • ASUS XG-C100C V2 90IG0760-MO0B00 == ASUS XG-C100C 10G PCI-E Network Adapter 94C0
  • ASUS XG-C100C V2 isn't using AQN107 but AQC113CS NBase-T/IEEE 802.3bz Ethernet Controller [AQtion] [1d6a:94c0]
  • AQC113CS support PCI Express Gen4, Gen3 or Gen2, while AQN107 support only PCIe Gen3 x4

AQC113CS ref: https://www.marvell.com/content/dam/marvell/en/public-collateral/ethernet-adaptersandcontrollers/mar...
AQN107 ref: https://www.marvell.com/content/dam/marvell/en/public-collateral/ethernet-adaptersandcontrollers/mar...

We should try to reach Marvell AQtion team member rather than ASUS i guess...

d5aqoep
Level 8

New Firmware available for Windows based PCs (attached below). For cards with AQC113c chipset only. Just run the appx file and let it install via powershell.

Mine on Asus ProArt Creator Z690 motherboard updated successfully (After failing on 1st attempt) lol

If you brick your device then it's your own responsibility. You can even change extension from appx to zip to extract the contents if you want to do it manually.

Thanks a lot ! I'll check it tonight on my: ASRock B550M PG Riptide motherboard

And let you know if it worked, my card chipset is the AQC113CS so i guess it should work.