Showing results for 
Search instead for 
Did you mean: 

ROG AREION 10G stopped working

Level 7

I got my ROG AREION 10G bundled with my Asus ROG Zenith Extreme motherboard, and it worked fine until I installed the drivers and software that came on the USB. Now it shows up with an exclamation mark next to it as an "Ethernet Controller" in Device Manager in Windows 10 Pro.

Further details:

Device type: Other devices
Manufacturer: Unknown
Location: PCI Slot 1 (PCI bus 7, device 0, function 0)

Device status:

The drivers for this device are not installed. (Code 28)
There are no compatible drivers for this device.

To find a driver for this device, click Update Driver.

It says it doesn't have a driver installed and when I try to install it via Aquantia_AQtion_x64_Win_ver1.40.042.0.msi, nothing happens.

What do?

Community Admin
Community Admin
Have you tried uninstalling and then reinstalling the driver?

Check if the driver download completed properly:
Did you arrive at this screen after installation?

Were there any changes in your hardware configuration, such as a sound card or second graphics card?
Have you tried a different PCIe slot?
FPS, Racing & VR Gamer / Tech Enthusiast / ROG Admin

Yes, I have tried most options countless times. Deleting the driver and reinstalling with the card mounted. Unmounting the card, installing the driver and then mounting the card, different drivers and so forth. I haven't tried connecting it to a different PCIe slot, so I'll give that a try too. Which driver do you want me to download? Those are the motherboard drivers, not the ROG AREION 10G drivers AFAIK. When I click on the attachment link I get to a page that says "vBulletin Message: Invalid Attachment specified. If you followed a valid link, please notify the administrator".

Community Admin
Community Admin
I wonder what driver you were using when it worked initially...
When the Areion is installed, typically you'd see this:

Download Areion driver here:
Direct link:

Install driver:

When installation is complete:

Then under Device Manager, you should see this:

If changes were made to your hardware configuration, then try a different PCIe slot or revert back to what you had before to check if the NIC is okay.
FPS, Racing & VR Gamer / Tech Enthusiast / ROG Admin

Level 7
Mine was faulty too.

I fixed it by replacing with a different brand.

Product support for our 10GB NICs has been a little on the poor side.

Austerror wrote:
Mine was faulty too.

I fixed it by replacing with a different brand.

Product support for our 10GB NICs has been a little on the poor side.

I upgraded my internet to 1gb (comcast) and tried testing speeds. I noticed when testing with this card it freezing my pc when speeds go above 400mb/s. I tried intel built in one and get 940mb/s.

Can some one help me with this issue?

I have a similar problem. Received the 10GB card with Zenith Extreme mother board, installed it today, and with the provided drivers from Asus' web page only the card got installed I still have hanging device in the device manager.

Any idea how to fix this, please?