cancel
Showing results for 
Search instead for 
Did you mean: 

z790 Maximus Hero USB 3.0 port failure

aNGERY1337
Level 8

I've had this thing for like 2 weeks.

Got home from work, turned it on and got a "no keyboard detected" error. Weird.     

 

 I tried the keyboard in my laptop, and it worked totally fine.    

 I'm even more confused now. I unplugged everything from the computer, did a few power cycles, and nothing. Rebooted, checked BIOS settings, everything is in order.  

Tried the "Red" usb ports (SS), and everything works fine. Tried other USB devices in the "blue" ports and got nothing. It only powers the devices (keyboard and mouse light up, USB drive illuminates, phone charges etc... i tried a lot of stuff because I don't want this thing to be dead already 😞 )    

I reset the BIOS, reinstalled 1501 and got nothing. I'm dealing with their support but I really don't want this thing to be torn apart for the rest of the year. Does anyone have any ideas?

It's brand new and I'm relying on my desktop to game on because my work schedule is insane right now and I don't have time to do much else after.

 

610 Views
11 REPLIES 11

bayfront_benny
Level 9

Do you get any indicators or warnings in Device Manager? IOW do all the drivers appear configured there? I have the same board and once in a long while I boot into Windows (11 pro) and my Corsair keyboard does not work although my mouse (logi) does. I reboot and all is normal after that (even though it is annoying).

Everything LOOKS normal, but I have nothing to compare it against right now. However I feel like USB devices in the BIOS not working rule out a driver issue.

Jiaszzz_ROG
Customer Service Agent

Hello, @aNGERY1337 

May I inquire whether the "keyboard not detected" prompt appears within the system or during the POST?
Are the USB devices installed on the USB ports on the chassis, or are they connected to the rear panel of the motherboard? Does the port configuration for the cross-test include USB ports 2 and 4?


We recommend that you clear the CMOS and boot the system with the default BIOS settings. 
Please verify if the keyboard and relevant drivers are correctly installed and check for any abnormal prompts in the Device Manager.
If possible, kindly conduct cross-testing with different USB devices or keyboards.

Thank you.

It was just 2 and it randomly started working normally.

Jiaszzz_ROG
Customer Service Agent

Hello, @aNGERY1337 

May I ask if the situation you described happened after any changes were made? For example, updating the BIOS or connecting an external device
We suggest cross-testing different ports, clearing CMOS, or booting up with all external devices removed. 
Please verify if you are using an extension cord for power, ensure the correct PSU connections, or try cross-testing with a different PSU.
If possible, please provide relevant hardware specifications, the troubleshooting methods you've attempted so far, and the results of your tests, enabling us to better understand your situation.

Thank you.

Screenshot 2024-01-13 165758.pngusb.pngusb.pngusb3.png

It's plugged directly into the wall. A corsair HX1000i.

I've unplugged all extra devices from the motherboard (corsair fan controller, front USB ports). All USB devices. Uninstalled and reinstalled the hardware.

This time these ports seem to be staying off.

aNGERY1337
Level 8

no input?

Amc
Level 7

1e7db5c8-2f99-4165-9692-3cc8dbced652.default.png

I think I have the same problem as the OP.
These 4 USBs do not work. I had problems with the USB since day one.

I have an i9 13900KS and my PSU is a Corsair hx12000.
Tried a few things but never got rid of the problem. Right now, when I need to connect something, like a pen drive, I need to disconnect some of my already connected devices, like my Mic, or Webcam.

Would love to have this fixed, it's a little bit annoying buying my entire setup with the "Republic" and then getting all kinds of errors. Already suffered with my previous CPU, an I9 13900k that I swapped for my current one, since I was having problems with the Dimm slots.

Do you have an extender on your power supply?