Showing results for 
Search instead for 
Did you mean: 

Z790 Hero: Q-Code D7 and video signal and no boot.

Level 8

Hi all, I just finished putting together a new build but I have a big problem and I've been freaking out all day.
I9 13900K
Asus Z790 Hero
Gskill Trident Z5 DDR5 CL-34 Ram
Strix 4090 OC

When I turn on the PC it does not give a video signal and the Q-Codes appear:

Q7- No console input device are found

and sometimes even 98 - Console input devices connect

but it doesn't give me video signal.

I only managed to get it to start a few times (and even installing windows) but as soon as I turn off the pc and turn it on again the problem returns. I also updated the bios to the latest version but to no avail.

It seems to be a problem with the keyboard and mouse, but trying other USB ports as well doesn't change just starts when it wants (very few times).



I am attaching photos and videos to this address


I ask for your help because I don't know what to do anymore.

Uploaded by Francesco Viscardi on 2023-04-11.

Hello Nate, thanks a lot for your reply! As my intentions was never to hijack this thread, would you mind checking out the thread that I created?

It has a detailed post of what has been happening and what my setup consists of. 

Level 7

I was having the same issue, came here and had no success with anything listed and was ready to give up hope until my friend suggested trying the DisplayPort cable directly into the motherboard. Fixed the whole thing, even making the HDMI in my GPU work again. 

Made an account to save a soul like mine with the info. 

Level 8

I have exactly the same problem with the following components:

  • ROG Maximus Z790 Hero
  • Intel i9-13900KS
  • Corsair Vengeance 2 x 16GB, 7200 MHz, DDR5-RAM

Various tests with 1 or 2 RAM, different i9-13900KS and also i9-13900KF, with or without graphics card RTX4090 or a RTX3090 lead to the following Q-code:

  1. HDMI cable directly to motherboard: d6
  2. HDMI cable to one of the two HDMI ports on the graphics card or via adapter to one of the DP ports: 98

The screen remains without signal at all times. If I connect the HDMI cable to a laptop, I get signal immediately. The motherboard has already been replaced.

Does anyone have any other ideas for a solution?

I solved this way. Just set "Launch CSM" to "Enabled" in the bios.


 Then Secure boot/os type/ and put "Uefi Mode". Once this was done, the problem was resolved immediately. Then you can put it back on disabled and everything continues to work. I don't know why this fixes it, but it was recommended to me on another forum...and it worked. Let me know if it solved for you too.

I would like to do this, but without a monitor signal I can't get into the BIOS...

you have to insist...turn it on and off several times like I will see that first I will then enter and you can change those settings.

Exactly what was happening to me. Plug a DisplayPort cable into the motherboard and see if that works.

For no discernable reason, doing that made the HDMI on my GPU start working too.

Level 8

I have this same issue with my Z690 with a 4080 (worked fine before same setup with a 3090) what fixed it for me is I put an older video card in slot 3, and when my comp boots it switches back and forth.  So if it boots off the other card (via HDMI to my 2nd monitor) i have to go into the bios and randomly change something save and restart then boom it boots to my main card

but do you think such crap is possible on an $800 card? Asus bios really stupid...

Level 8

Solved! Thank you guys very much for your input. The variant with the 3090 graphics card and a DP cable (HDMI does not actually work) helped. I was then able to enter the Bios and make the settings according to theotorm. I then installed the 4090 and it runs as usual. What an (unnecessary) odyssey...