cancel
Showing results for 
Search instead for 
Did you mean: 

z790 hero pcie SATA card not detected

lavathief
Level 7

I have a new maximus z790 hero board that is not detecting a SATA expansion card in PCIEX16(G4).

The card (6P6G-PCIE-SATA CARD with an ASM1166) works with no issues on an older system (z390 auros ultra). 

I have an RTX4090 in PCIEX(G5)_1.  I also have a Samsung 990 pro nvme in M2_2. No hypercard installed. I don't see evidence of the drives in bios, windows, or the card via lspci or siv on the z790.

I have tried removal of the Samsung SSD and various bios settings (including disabling the onboard ASM1061 controller, etc), no dice.  I do see in bios that it detects PCIEX(G4) as present at x2 but do not see the card in any OS and bios does not detect any drives. I have not tried moving the 4090 out of PCIEX(G5)_1 yet but it is not clear to me if that would be a useful step.

Any advice?

 

 

846 Views
8 REPLIES 8

Jiaszzz_ROG
Customer Service Agent

Hello, @lavathief 

May I know the current version and build of the OS you are using?
What is your BIOS version, and have you updated the Intel ME to the corresponding version in the BIOS? 
For example, the latest BIOS version 0904 requires updating the Intel ME to 16.1.25.2124.
Meanwhile, have you cleared CMOS after the BIOS update?
Please try connecting the SATA hard drive directly to the SATA ports on the motherboard and verifying if the hard drive can be detected in the system.
Alternatively, we recommend performing cross-testing with another SATA expansion card.

Thank you.

I am using Win 11 22H2 (10.0.22621) and Arch Linux 2023.05.01 (install boot disk). Neither show the drives or the card when listing the PCI bus via lspci or siv.

Bios is 0904, the release notes state in the changes that it includes ME 16.1.25.2124, but I did it independently as well.  I did clear CMOS as well yes. Just ran the updater again

The drives themselves work properly in the onboard ports, unfortunately the port placement on the board doesn't allow for the large video card.

As stated in the earlier post, the SATA card itself I can put in another system and works properly. Tested again today. I am not in possession of an additional SATA card.

Listing the PCI bus on the z790 never shows the ASM1160 controller, popping it in the other board it and its drive come up no problem.  The only evidence of the board that I see is that the G4 ports shows as 'x2' vs. 'not present' in BIOS if it is plugged in.

I have exactly the same problem with a PCI-E 3.0 4X SATA card. It work flawlessly on my ASUS ROG STRIX Z490-E GAMING motherboard , but it won't work with ASUS ProArt Z790 Créateur Wi-Fi and with Asrock Z690 Extreme.
The card is also detected at 2X in the bios, but it doesn't appear in Windows 10 or 11 device manager.
I tried changing some settings in the bios but i didn't find any solution yet 😞

PS: Here is the model of my SATA card:
https://www.amazon.fr/dp/B09F2KB143?ref=ppx_yo2ov_dt_b_product_details&th=1

Were you able to figure this out? I have the exact board and I'm attempting to install an expansion card in the PCIEX16(G4) and the same deal. It's almost like the slot is disabled by default but I cannot find any settings that explicitly say it is.

The_Madhatter
Level 7

Z790 Hero here. I have the exact same problem, I have a SATA addon card that is not recognized not even in BIOS. It's like the whole slot is disabled. The card works on my old Z490 Hero board. In the BIOS settings the operating mode is set to "addon card" for this slot.

Mattybobo
Level 7

I ended up figuring it out. It was a red herring for me in the device manager and what was actually happening was the Thunderbolt driver being pushed by Armory Crate is actually out of date/not current. Somehow it was popping up whenever I would put the add-on card in. Once I figured out (googling the hardware ID within the properties of the faulty USB controller icon in device manager) that is was the Thunderbolt driver, I went to ASUS support page for my card and downloaded the current thunderbolt driver manually and installed and voila no yellow exclamation point in device manager and my add-on card works. I'm always going to check my drivers now since it appears Armory Crate sometimes pushes outdated drivers (isn't that the whole point of it?!).

pcgamersz
Level 8

i have hero z790 and i noticed the latest bios made my card x16 3.0 to x8 3.0 even with that its still not right before it should x16 4.0 

i have 4090

and 13900kf i have completely removed ssd and tried external one to see if it steal any pci lanes...any bios update? to fix this isssue?

Jiaszzz_ROG
Customer Service Agent

Hello, @pcgamersz 

As we have observed, you have started a discussion in this thread:
13900kf rtx 4090 strix oc pcie X8 3.0 problem asus maximus hero z790
If you have any updates or discussions related to this matter, please update that thread to avoid confusion or information gaps.

Thank you.