Showing results for 
Search instead for 
Did you mean: 

Z790-F new bios update but ME version not updated

Level 8

yesterday came new Bios update, it told me to update intel me to latest version.

but asus did not update ME update tool to latest version.

So how can I update it?


Oh, wrong. The Intel ME device is shown anyway without clicking on "Show hidden devices". My bad.

Level 8

That's odd. For me I had to click on "Show Hidden Devices" and if I do so.

You can see in the image it is greyed out. When I click on it.

It says in Dutch that the driver has no connection and it ends with an error code 45Schermafbeelding 2023-06-19 080545.pngSchermafbeelding 2023-06-19 080559.png

Yes, that's indeed pretty strange.

This is how it looks on my system:

Screenshot 2023-06-19 083042.pngScreenshot 2023-06-19 083110.png

Yes, that's how it should be.

Also when I try to update ME FW trough PowerShell it says Error 20: Cannot locate ME device.

Management Engine is not being detected at all.

I am now rolling back bios version.

Try to disable Secure Boot.


Since you can see your current Intel ME Firmware version displayed in your BIOS (, your Intel ME firmware is not corrupted (you would have seen as Intel ME Firmware version in your BIOS if your Intel ME Firmware was corrupted), so the root cause of your issue (Intel MEI Device missing from your Device Manager) seems to be located in Windows side (something has screws up your system drivers install).

- Follow this process to cleanup Intel Chipset Drivers, Intel MEI Drivers & Intel Serial IO Drivers :

- Uninstall your current Intel Chipset Drivers, Intel Management Engine Drivers & Intel Serial IO Drivers if you have any installed (via Start > Settings > Apps).
- Launch Driver Store Explorer (Right click on "Rapr.exe" > Run as administrator) :
- Check the boxes of all versions of these drivers .inf (if you find them) : heci.inf | dal.inf | dal_wc.inf | iclsclient.inf | lms.inf | mesrl.inf | mewmiprov.inf | wiman.inf | wiman_wlan_extension.inf
- Check the boxes of all versions Intel drivers which .inf contains system word or start with ialpss2 word in the System device category (if you find them)
- Check the box "Force Deletion" then click on the "Delete Driver" button then restart your PC.
- Install the last Intel Chipset Drivers & Intel MEI Drivers from the first post of this thread : [DRIVERS] Intel Chipset/MEI/VMD (6xx/7xx).
- Install the last Intel Serial IO Drivers (6xx/7xx) from the first post of this thread : [DRIVERS] Intel Serial IO (3xx/4xx/5xx/6xx/7xx).
- Install the last Intel ME Firmware from the first post of this thread : [FIRMWARE] Intel ME (B660/H670/Z690/B760/H770/Z790).
- Install your last BIOS from your motherboard support page.


I am so happy I made a system image copy before I went to clean install Windows 11.

After I saw your reply, I immediately restored the system image copy with the known issue.

I did what you told me to do.

Everything is working now! Intel ME is working.

I am so grateful. Thank you very much.👍


Level 7

Maybe a BIOS reset helps to solve the problem. Dunno.

Level 8

No, already tried. Maybe new windows installation.

Ya, you can give it a try.

I fixed it. I think what happened was I installed Windows 11 with Secure Boot disabled. That's why Intel ME did not work properly.

This time I enabled Secure Boot and did clean install Windows 11.

Everything works just fine now. Also updated to latest ME FW version.👍

Thank you for your help!