cancel
Showing results for 
Search instead for 
Did you mean: 

Z690 Maximus Formula Issues

Meistar
Level 8

Hello ,

i got an Z690 Formula since 11.11.21  it worked well in the last 2 Years  .

i used an 12900k and 13900k Cpu on it  . with 64 GB Gkill Trident Z 6400 . Bios 2802

but since almost 2 weeks i ran from one issue into another.

it started with a BSOD , after Restart i got an "unmountable boot device error . in Bios my Primary SSD an 980 Pro m2 , wasnt shown anymore . well i ordered a new ( i thought the 980 was dead) 990 Pro installed a fresh Win11. wich worked for 1 day . then after start next day i got into a booloop ( memory Detect ) i resettet Bios and removed 2 Sticks of Ram Testing one stick by another with memtest86 no errors were found . with 2 Sticks of memory at stock settings (no XMP chosen everthging on AUTO) the system starts and loaded windows.BUT 2 Hours later ,  maybe less or more , i got the unmountable Bootdevice Error after a BSOD again  , that was enuff for me , i mailed  the Dealer were i bought the MB , they sended me a Ticket for RMA  (gladly 3 years Warranty)

when i removed the MB out of my Tower i noticed Green metallic Particles in my CPU block (whole cooling system is made of EK parts )  and the drained Destilled Water with EK additive . i googled about corrosion with Z690 Formula and found some Threads and Vids  . 

I also noticed corrosion in the VRM Coolblock trough the g1/4 moountings .

does anyone know how long the RMA wil ltake  ?

greetings

195 Views
1 REPLY 1

Jiaszzz_ROG
Customer Service Agent

Hello, @Meistar 

Regarding the situation you describe, kindly check the upper right corner of the PM inbox section to share with us your personal details, as it is not ideal for verification in public.

Thank you.