Showing results for 
Search instead for 
Did you mean: 

X670E RAID Stability / Volume Crashing/Disappearing / NVME/SATA RAID / Error 153 Windows Log

Level 7

So I've run across this and a separate thread discussing issues with raid stability in Windows and I've seen some odd comments about having to run the raidxpert software in the background.  After having gone through this I wanted to share my findings in case others experience issues with X670E raid stability or crashing or error code 153 in the Windows event log.

Other threads discussing similar things (some of them can't be replied to):

Here is my experience:

I have an Asus TUF Gaming X670E Plus WiFi board but it seems it has the same issues as other similarly configured boards.

When I configured the bios to fit with my hardware and how I've had it previously configured I chose the following:

I have:
1x PCIE Gen 5 Crucial SSD
2x PCIE Gen 4 Sabrent Rocket SSDs
1x SATA m.2 SSD
4x SATA standard HDDs

In all previous configurations I've always enabled RAID for both NVME and SATA and never experienced any issues, so when I went to set this machine up, I did the same.  I don't "fundamentally" think this is impossible, I strongly believe this is a driver problem.

I experienced the problem in 2 flavors.  First, I had originally installed Windows 10 without the use of the RAID drivers and Windows automatically installed the base nVME drivers that Windows uses.  I then went to install the RaidXpert2 application and drivers and followed the information in the manual where it says you must install rcbottom > rcraid > rccfg in that order

Windows did not automatically replace the nVME drivers with the RAID drivers so I had to update that in the device manager myself

Almost immediately I started experiencing stability issues with both the standalone nVME drive and the 2 RAIDed nVME drives (error 153 in the event viewer, drives falling offline, etc).  I rolled back my install of Windows to before the driver was installed and everything stabilized, but I didn't have access to my array.

THIS time I only installed the RAID drivers onto the two nVME drives in RAID 0 (the sabrent drives) leaving the Crucial using the defaultr nVME driver and while Windows stayed stable since it was installed on the Crucial drive, the access to the sabrent drivers was sporadic at best, they would fall offline, cut constant 153 errors and become inaccessible repeatedly.

So, thinking my installation of Windows might have some sort of problem since I didn't install the drivers with the install, I started over, this time installing the drivers during set up (same order: rcbottom > rcraid > rccfg).  While I could see the drives, raid and not, as soon as I would select a drive the install would hang and I would eventually get an inaccessible storage device message, so essentially I was experiencing the same problem in the install as I was in Windows.  I tried many things including removing the SATA M.2 drive and other things, but it didn't help.

I sent the board back to the retailer and replaced it with the same board, then went through the same set up and no surprise, it acted EXACTLY the same.

So then I had a wise idea to turn off SATA RAID (switched SATA to AHCI mode) and leave nVME RAID enabled (since my configuration actually uses Windows Storage Spaces for my HDDs so I dont actually need SATA RAID enabled).  Went through the install and everything is perfect.

So my speculation is this:  There is a compatibility problem with NVME RAID and SATA RAID drivers.  The manual and AMD's own release notes say to install NVME_DID in the order of rcbottom > rcraid > rccfg and to only install one of them even if you have multiple controllers.  It is clear there is a problem with that driver running the SATA RAID however.

A few other thoughts:  If you require both SATA RAID and NVME raid, it might be worth starting with the NVME_DID raid to get yourself installed with SATA set to AHCI (just be careful with your data if you're trying to preserve something, back things up, all that good stuff) and get into Windows, then enable SATA RAID in the bios and MANUALLY  install the SATA_RAID driver over top of the SATA controller in Windows.  I cannot promise this will work as I've not tried it and I'm not really wanting to now that everything is working, but it may be the ticket.

Bottom line is that the NVME RAID DRIVER and the SATA RAID CONTROLLER are not playing nice with one another and that AMD's documentation is NOT CORRECT.  You CANNOT use the NVME RAID driver to run both the NVME RAID and the SATA RAID together or you will have severe instability issues.

Pages from AMD's RAIDXPERT manual discussing installation of the driver, starting on page 54:

Bear in mind that the raid controller driver names whether SATA or NVME are named identically in AMD's infinite wisdom.

The idea of running the raidxpert2 software in the background to alleviate this may work as a stopgap for some, but to me this is a completely invalid way to do this and should be fixed by AMD.

I hope this helps people experiencing the same issue I did.  Let me know if there are any questions.