Showing results for 
Search instead for 
Did you mean: 

x670e hero nvme raid problem

Level 7

I have 2 ssd nvme firecuda 530 (1tb) today i try for install into raid 0 for put windows 11.

When i create array the bios crash and not work.

The ssd working fine, i use everyday. 

I try with more asus guide, but the problem persist.

I try with reinstall last bios 1709 and clear cmos but not work.

I put the ssd on nvme 2_1 and nvme  2_2 slot.


Customer Service Agent

Hello, @sandrino71 

Please note that setting up a RAID configuration will result in the loss of all data on the disks.
Therefore, we recommend backing up your data before creating or deleting a RAID set.
If you are currently experiencing difficulties in creating RAID, we suggest formatting the hard drive or cross-testing with a new hard drive for setup.
For detailed steps, please refer to [Motherboard] How to create Intel 600 series MB RAID in BIOS Setup.
Could you kindly specify which step in the setup process you are encountering difficulties with? Please provide relevant images and context.

Thank you.

Due to the ongoing regional holidays, my responses may be slightly delayed.
Thank you in advance for your patience.‌‌‌‌ 🙂

Thanks for the reply. As I wrote, I have an x670e hero card so the link you sent is not good since it refers to an Intel motherboard. I tried using this guide:
I get to the point where I have to create the raid (create array) and the bios stops, freezes and doesn't let me do anything, I've tried dozens of times but to no avail. It's as if the bios was corrupt, as written I also tried several times to reset the bios.

Level 7

I m experiencing exactly the same problem, i m trying to setup in BIOS a raid array with AMD raidexpert (9.3.2) on 2 NVME drives, as soon as i select the create array option, the screen freezes in the bios and i can only reboot, problems occurs on a new ROG STRIX X670E-E, latest bios (1709)

I thought I had become stupid all together. as far as I can see they are not. I'm sorry you have the same problem as me. Let's hope they solve it because honestly I don't expect certain problems from a card of this type given the price paid. Since it came out there have been several, we're acting as guinea pigs it seems 😄

Customer Service Agent

Hello, @sandrino71 

To further validate your issue, could you kindly provide the following information?
- images of the BIOS main page and BIOS settings, or confirmation if it's the default setting
- the brand and model names of the installed CPU, GPU, DRAM (including part number), SSD/HDD, and PSU
- are there any extensions or adapters used to connect devices, such as GPU or SSD?
- the OS build
- a comprehensive video recording of the problem, capturing all the setup steps and the troubleshooting methods you've employed after the issue occurs

Thank you.


Hello, @InDebtWeTrust 

Please also help provide the above information to help us further validate potential issues.

Thank you.

Due to the ongoing regional holidays, my responses may be slightly delayed.
Thank you in advance for your patience.‌‌‌‌ 🙂

dear Jiaszzz_ROG, unfortunately I had to overcome the problem by using the two SSDs individually. Unfortunately, not all of us have months to spare to set up a PC. I'm just telling you that I'm 52 years old and I haven't mounted PX for a day and used Asus products. Imagine if I don't do the necessary tests before writing on an official forum.
Unfortunately and I'm not the only one saying this, just google this card has problems creating raids via nvme ssd and I think you know it.
However, I leave you the list of material mounted on my PC in the hope that it will be useful, I don't take photos or videos because I have absolutely no intention of reinstalling everything from scratch. I'm fine with separate SSDs without raids.

Ryzen 7950X

Crosshair X670E bios 1709

DDR5 CMH32GX5M2X7200C34 (2*16 GB)



WINDOWS 11 Pro 23H2 build 22631.2861



I managed to make things work and install win 11 OS on a 1 NVME JBOD raid array and a second raid 0 using 2 nvme drives. I first installed windows on the first drive WITHOUT creating a JBOD array in BIOS. install works works but when you go in BIOS to create your raid 0 array on my second 2 drives, it just crash the bios raid utility because i guess it cannot recognize the partition created by windows.. so you NEED to delete all raid arrays in bios, and install windows on a raid partition i think. make sure you load the correct raid nvme driver (not the ssd one) when you install windows 11 or you will also encounter issues.  have 'fun'...