Showing results for 
Search instead for 
Did you mean: 

Why can I not register my motherboard on my profile page?

Level 7
Hello ASUS ROG community, I've assembled a budget gaming PC nearly three months ago and I just found out that I can register my ASUS H410M-K R2.0 motherboard on ASUS' official site for an extended warranty and for why nots. The serial number is on my box as well as my receipt from the online retail store where I've bought the board.

The issue is that the submit button remains greyed out after I fill out the forms. I cannot submit my product. And yes, I've tried clicking on the submit button. 🙂
Let me also highlight the fact that I've tried clicking on the button in order to submit it, but that did not submit my product, and in fact, did not do anything at all.
I've contacted support regarding this issue, but they avoid reading what I write so I gave up on them. They always seem to give me dumb questions I've already given them the answers to. I've happily answered them again and overexaggerated my issue so that they can understand, despite the issue being pretty straightforward. "Clicking on the button after successfully filling in the forms did nothing." I don't know in how many ways I was supposed to word that...

This is the product registration page, where I enter my serial code and purchase date. The purchase date is found on my receipt, but I've tried all the days in the same months I've purchased to no avail. Obviously, I'm not gonna show you my serial number, but the empty fields in the screenshot are filled with the serial number and purchase date before I want to submit it, click on the button to submit it. Nothing happens after doing so.

I have checked if there are any unwanted characters, I have got a couple of 0 characters I'm not sure whether they are 0 or Os, I've tried different combinations, but the button won't work. Clicking on it does nothing. There is also no popup or message like "Serial code invalid", or "Purchase date invalid", simply nothing.
I'm using Chrome with the latest version and no AdBlock nor any other extension. I've also tried on different browsers like Brave and Firefox, but they all give the same results... What is the issue here?

Level 9
Try it both ways. In my case the o's were zeros. If you're having issues with the website, try a different browser, like Firefox or something, but I used Edge with zero problems, but had to enter my serial number a few times to figure out the o's were zeros. And Asus doesn't really have a support team, they're really just like dealing with a customer service department. I know, because I've talked to a few of them, and their way of solving problems are the hard way. They wanted me to RMA a motherboard that wouldn't post, but all it was was the fact that I couldn't short-circuit the board, to release it, because my screwdriver was made of a weird metal and wouldn't short it, so they told me to RMA the board, so I tried some scissors and it short-circuited it, and I got it back up, finally, so I called to ask if they were having issues with the short-circuiting, and they told me no, but in their manual it says use a screwdriver, but if it's made of a different material, it won't short it, so you have to figure something else out, and I've never had to short-circuit a board, so this was my first time, but it was an interesting experience, and no their technical team was of no assistance, so I know what you mean. I had a short with my wires on my keyboard. I use a lab desk, and it's metal, and I routed the mouse and keyboard wires through it, and it cut into the insulation and was causing a short, so that's what happened, and it went on for a while, and I finally figured it out, but I was troubleshooting, reinstalled everything and still couldn't figure it out, and then found out I had that short rebooting my system, so that's what caused it, ended up making my board not post too, so I was having all kinds of problems, and I built and designed this system from scratch and this is my second build. I use the Rog Strix B550-F Gaming, so I don't have your board, but I understand your frustrations.

Your mobo is under warranty regardless of you entering the number, and all you have to do to get your RMA is call them. The warranty on mine is three years, but I will never use it. My last board lasted me eleven years and it's still good but has been retired. It was an MSI mobo, but boards don't die very often, or quickly. Both were gaming edition motherboards. About all I use. My early days on computers were on old office hardware, just to learn the ropes, but I try not to go over $200.00 a part, because it's worth it, so my stuff is built cheap, but I have good hardware, and a good amount of it was under that, but for a GPU I might spend more, but it depends on what is available. I have a good backlog of video cards that'll last me a while too.

Level 7

also same problem, not working. tried various OS-es, all possible browsers with no any extensions attached to them. Nothing. This is really lame.

Same problem than you. I suggest you try to use Microsoft Edge specifically. Neither Chrome nor Firefox worked for me but once I tried with Edge everything solved at the first try. Certainly Asus should design their registration site for more than one browser.  We users waste a lot of time and problems like this give a lousy first impression after buying an expensive product.

I tried with Chrome and Edge, no dice. Tried on my mobile, still won't work. I downloaded a barcode scanner and pasted the S/N to my password app so I could see letters and numbers, still would not work. I opened a case with Support and the agent was good, but disconnected so ****** fast after giving me my case number, I had no chance to copy it or screen cap it.

Still unable to register my motherboard.

Customer Service Agent

Hello, @zeke009x .

It is not advised to talk about the serial number and other registration-related personal information in a public comment.
Please check the top right corner of the screen and kindly share the details requested in the PM inbox.

Thank you!

Level 7

I am having the same problem. Tried in couple of browsers (Edge and Chrom). I purchased a ProArt motherboard last week and I cannot download latest Bios without registering the product. Then the registration page doesn't work. Supper frustrating.

I don't know what's going on with registration, but you should be able to download drivers and BIOS updates without registering.  Just use the boxes above the product registration thing to search for your board:

Customer Service Agent

Hello, @winslowf .

Registering the product serial number and updating the BIOS are not related.
For the BIOS update, please refer to [Motherboard] How to update BIOS of the motherboard ?
Regarding registering the product serial number, I have PM you.
Please check your top right corner of the screen for more details.

Thank you.

Level 7

i have the same issue reg  my b660-g motherboard