cancel
Showing results for 
Search instead for 
Did you mean: 

Weird USB problem on X670E

Spit78
Level 7

Hi all.

 

I recently updated my GPU driver, and suddenly I lost the connection to my Logitech G502 mouse and my Wacom Intuos tablet.
Both were connected to the front ports of my Corsair iCUE 7000X RGB Big Tower, the Wacom via cabel, the mouse via USB bluetooth.
The front ports are 4x USB3.0 and 1x USB-C 3.1. All five ports deliver power, and I can connect external drives without problem, but pointers just wont be recognized... I can charge and access my Samsung S22 Ultra on the USB-C just fine. The problem is just affecting pointers, and only on the front panel. On the back panel, everything works fine! I can connect both Wacom and mouse, both running smoothly. Why is this happening? Why can I no longer connect these two devices to my front panel the way I want?

Like I said, this happened when I updated my graphics driver to 552.22 and restarted my computer. I suddenly had no more mouse.
I've tried to roll back to an earlier version but that did not help.
I tried to ask help at r/PCHelp on reddit but no answers at all.
I've tried to google, and to uninstall USB drivers, un-enable them and re-enable (something that caused me to un-enable the USB controller my mouse was on, so that I had to kill my computer to do a restart so the controller loaded again...). Also, there are so many enteries there that I have no clue to whats what...
I've tried to update and re-install the ASUS chipset.
I've tried to do a clean un-install of my graphics driver, and do a custom install of the newest driver 552.44 without the bundled USB-C driver, as someone tip'ed me that could cause problems if you are not running a monitor through USB-C, which I'm not, but there was no option to do this during the install, and the update did not help.

I am completely out of ideas here, and could really need some help.
Setup is:
Corsair iCUE 7000X RGB Big Tower with 1 x USB-C 3.1, 4 x USB 3.0 (these are the ones that are acting up)
ASUS Crosshair X670E Hero MoBo
ASUS ROG Strix GeForce RTX 4070 Ti OC
AMD Ryzen 9 7900X CPU
Corsair Vengeance DDR5 RGB 32GB
Corsair RM850x 850W PSU
Windows 11

123 Views
1 REPLY 1

Silent_Scone
Super Moderator

Hi @Spit78 

Did you try a Windows restore point before the issue occurred?

1. Use the Clear CMOS button on the rear IO Panel

2. Remove AC from the board and wait for all power to drain

3. Plug AC back in and retest

13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090