cancel
Showing results for 
Search instead for 
Did you mean: 

VGA Light Problems

Macivelli
Level 8

So I've been having this issue that is very inconsistent and only happens once and a while. It started happening a little after I put my new Strix 4070ti OC card in my system.

Sometime when I go to turn on or restart the system, it wont display an image on my monitor and my motherboard (ROG B550-F-Wifi) will show the white VGA light just stuck there and I can't really do anything to get it to show an image so I always end up just pressing the power button to turn it off and once I turn it back on it works perfectly and boots into windows everytime. I've tried using a different display port cables and trying to use an hdmi cable to see if that would change anything and it didn't. I've used my cablemod cable as well as the stock adaptor with my psu cables and it does the same thing on both. I've reseated the gpu, cleared cmos, you name it. Starting to think it might be the gpu itself but I wanted to get some other thoughts on what it might be. Anyone have this issue before or have any idea what it could be? Any advice would be appreciated, Thank you very much!

945 Views
18 REPLIES 18

pepbest
Level 7

i was thinking of many solutions, but u alr did all of em. i think it might be the gpu too, but before going to a rog store try another pcie slot

assembly
Level 9

This GPU has a BUG. If you do not obtain a special VBIOS from ASUS customer service, this BUG may easily occur.

Asus also confirmed the problem with the 4070TI when I reported it to them. At first it was said that VBIOS would be uploaded to the official website, but later it was only given privately to users with questions.

Oh really? They should really make that a public download on the support page for the 4070, I tried updating the vbios yesterday from the one on the support page and it was already up to date. I guess I’ll contact customer service and see if I can get it. Thank you for your info!

 VBIOS VER : 95.04.3c.08.83

I actually just looked that version up on google and it says that that vbios is the most up to date one on the asus website. Thats the one I tried updating to and it wouldn't let me because it said it was already up to date.

It is recommended to provide a full set of device information for ASUS' reference.

They told me they tuned the strix 4070ti's vbios for the ROG Z790 Hero, but I paired it with a different motherboard and apparently it worked just fine, so this GPU VBIOS does work, but ask them to do it for you B550-f to verify whether it can be used universally.

This phenomenon has also begun to appear in this forum. The q-code 97 and VGA lights are both Strix 4070ti. Enter the system and operate normally

What is your current version?  95.04.3C.80.79 ?

In the nvidia control panel it says my current video bios version is 95.04.3c.40.7e

It's different from the version before I updated it.

The version information I provide may require asking customer service to confirm that the version is for private use only.

I purchased a 4070ti using VBIOS 95.04.3C.80.79 but it's stuck on q code 97 and the vga light. ASUS provided me with a special VBIOS which is 95.04.3c.08.83