cancel
Showing results for 
Search instead for 
Did you mean: 

Updated MB support package

Baggus
Level 8

I have the ROG Z790 Maximus Dark Hero board, and all components to the PC case itself and even my mouse pad are ROG products.

The motherboard came with a ROG flash drive containing the manual, drivers, and some software. The issue is that anything that is software is outdated or near to being outdated. I would like to get a new revision of this package to update the flash drive, but I can't seem to find it offered anywhere.

I tried to put it together manually, but even on the Asus website, or in the support section for my devices/hardware, the drivers and software available is STILL outdated. For some of them, I'm able to go to Intels website to get certain drivers, although I'm not sure how they might compare to any customized versions or possible changes Asus could have made to the driver for its own hardware.

When I first start up the PC, it's laggy as can be, no audio, wrong aspect ratio, poor resolution, and not very stable. So I can run the included setup on the flash drive, and it fixes some of it get me going, but I then need to get some additional stuff from Nvidia. That gets me a start can go and RE-update all these drivers AGAIN, and then get some more through windows update. THEN, I need to install Armoury Crate, which often fails or corrupts due to some compatability issue or conflict with my hardware/outdated drivers. Then I have to uninstall AC with tool, change some settings, disable security, turn of memory integrity, use a third party patcher, and FINALLY reinstall a working Armoury Crate. At THAT point, I can use Armoury Crate to pull and install current drivers for the THIRD TIME, and my system is finally up to date and performing great.

I'd like to just cut out all the BS, and keep this neat little ROG drive I recieved current and up to date. It takes all day running setups, and multiple driver updates for the same hardware, and having conflicts because of driver incompatibility, and changing settings, tweaking things, etc. That flash drive has enough space to keep all the software/firmware/drivers I need to go from a fresh install to a current system, while avoiding the massive hassle and headache otherwise.

I get the flash drive cant always be current, and they cant pull all the boards from the shelves every time a mew driver releases. BUT... If Asus would just update their ****** site and support section with ACTUALLY up to date stuff, and proper drivers/firmware, this wouldn't really be an issue. If still like to keep an update offline copy for ease of setup, but they should offer an online or available to download page with the same contents available of the flash drive. So people can just set up their PC from the site, or download the files to do it offline.

193 Views
3 REPLIES 3

Silent_Scone
Super Moderator

Hi @Baggus 

Can you provide one example where driver revisions listed on the support site or provided on the USB for the Dark Hero have caused a problem?

I have the same platform here and have experienced zero issues, including Armoury Crate. Is there a driver on the included USB that's caused you grief? It honestly sounds like your post could simply be condensed into a request for a stream of verified updates, which MyASUS service already provides.

13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

I just want to be able to keep a complete set of files and drivers for setup, packaged and kept on an external USB drive. Basically, exactly what came with my motherboard. The stuff on the included flash drive is mostly outdated. The website offers some newer stuff, but it is also outdated for some things. Not all of my drivers updates get pushed through windows updates.

Technically, I WAS able to get the latest driver revisions from Armory Crate, but it was NOT a simple process. I had to go into hidden files, temp files, and view log files to figure out where Armory Crate was putting all the installers when downloading the program, and using the update tab to get new updated. It took quite a while to actually find a current version of everything. However, that was only half of it...

Actually being able to properly INSTALL Armory Crate without any issues proved troublesome on its own. During installation I would get errors, because armory crate wasn't properly able to interface with hardware, and installation would fail or Armory Crate wouldn't properly due to being denied access. Tried disabling defender, disabling UAC, disabling memory integrity/core isolation, didn't help. I tried using dism/sfc commands, and scanning/fixing any corruption, no difference. I tried formatting SSD and doing clean windows install, nothing. I even tried using a completely new never used SSD, downloading a fresh W11 ISO, and even using different software to mount to a bootable USB. I tried using MS account, local account, doing AC install first, running windows updates first, etc. Literally nothing I did solved the errors.

I finally looked into the errors a little more and did some digging into config files/logs in Asus and system folders, and checking what processes and services my PC was running, and checking what every service was, and what all specific drivers and processes/services all the Asus software suite requires. It turned out that my issue was from lacking certain Asus drivers for the Armory crate software to properly interface with my hardware and run. I'm not sure if the proper drivers should have been downloaded from windows update, or had been included in the driver setup program on the flash drive. I was missing or had incorrect versions of drivers relating to Asus Certification Service and Asus COM Service. I managed to track down some drivers and files, and was able to essentially put together a compatibility patch to fix the installation issues with some AsIO/AXSP .dll files. I was FINALLY able to install AC error free, getting the latest software updates from the app, which I now knew where they'd be stored after downloading. So I was able to create an updated software/driver USB and replace the outdated originals, and add the extras to prevent the issues.

So, I'm all good NOW, but it SHOULDN'T be like this. I don't know if it was Armory crate that's not functioning properly, and it was supposed to download all compatibility files and drivers before continuing installation, if stuff was missing from the factory setup USB, or my motherboard should have injected the specific files for compatibility with Asus hardware/peripherals. I WAS missing necessary files, though, however it happened. There was also no reasonable way of fixing the issue, without having a good bit of determination and knowledge to troubleshoot the issue and be able sort through all the obscure files/folders, reading .cfg files and scanning through thousands of lines in logs, and understanding the functions of different services. Just Google Asus AsIO errors/armory crate installation errors/broken armory crate, or any other combination of those keywords. You'll see TONS of posts and comments from people who are all getting similar errors relating to framework and hardware abstraction layers for Asus stuff. Could be getting errors for AacAIOFanSetup.exe, lsASUSMB.exe, and/or asus_framework.exe, but the common thread is that nearly all of these errors relate to issues from AsIO3.sys. All these posts unanswered, and going back 8 years or so that I've seen. So, its obviously something that most people have issues fixing.

I can understand some. Im sure it can be a pain developing hardware and software for something like PCs where there is such a diverse mixture of stuff out there. There will obviously be unforseen issues and incompatability, etc. However, my entire PC is built EXCLUSIVELY from only the very latest ROG flagship hardware, on the newest firmware, and running on the latest build and updates for Windows 11 Pro, on a new SSD with clean Windows install. My setup should basically be the "standard" for total compatibility, and be the best case scenario for this software to "just work".

I looked into the issue and others experiences a bit more, and I ended putting together a little unofficial patch of sorts. It has all the Asus software suite uninstallers, and an installer with the latest version of some dependencies/.dll files which relate to issues I've seen on like 90% of Armory crate error posts. So, next time i see someone having the same issues with no resolution, I'll offer them the fix because i understand the frustration.

There REALLY needs to be some type of OFFICIAL package on the website, that is maintained with the latest drivers and such that Asus software requires to function. Just some .dll files or installer, which doesn't rely on ANY Asus software already being installed. Or at least a tool you can download and run which checks your system and downloads anything missing/out of date, similar to something like Intel's driver scan tool.

It shouldn’t be like that, no. And it isn’t. 

A clean copy of W11 shouldn’t have any permissions issues with AC. Once again, a lot of text to say but a few things. Makes it more difficult to ascertain what is actually happening. Are you sure the system stable? XMP disabled?

Same platform here, and all the verified drivers are available through MYASUS or AC and the application installs without error. If you’re experiencing permissions issues and you’ve ensured the system isn’t overclocked, you can fill in the bug report form available in the thread in the software section.

 

13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090