Showing results for 
Search instead for 
Did you mean: 

Unable to play DirectX 12 native games (ROG MAXIMUS Z790 HERO)

Level 7

Hello. This winter I built a new gaming PC (parts below) and since putting it together, every DX12 title will crash with some combination of an our of memory error, or unable to read a memory address. (E_OUTOFMEMORY PipelineDx12Graphics.cpp)


I've tested different video cards, clean installs of both windows 10 and 11, updated the bios, and many more troubleshooting steps with no working fix. Here's a list of things I've tried:

Reinstall windows 11
Install Windows 10
Update and roll back video drivers with DDU
SFC scan
BIOS update (currently on 0816)
Generating new cryptography reg key for machine UUID
Tested with different video card
Disabled all game overlays
Modified pagefile settings (up to 100GB!)
Installed .Net framework/repair
Installed/repaired C++ redistributable
XMP enable/disable.
The system is not overclocked at all.

Asus ROG Maximus Z790 Hero - BIOS 0816
Intel i9 139000K
64GB G.Skill Trident Z5 F5-6000J3238F16GX2-TZ5RK
WD_BLACK SN850X 2TB (Latest firmware)
RTX 3090 (531.29)

I'm starting to think the CPU or MB is a lemon... but if anyone has any idea or tips that would be great. Really at a loss.






Level 7

Launched and crashed a game while recording motherboard QCODE... a lot of problems:

54 Unspecified memory initialization error
55 Memory not installed
56 Invalid CPU type or Speed
53 Memory initialization error. Invalid memory type or incompatible memory speed
58 CPU self test failed or possible CPU cache error
59 CPU micro-code is not found or micro-code update is failed

So bummed out. Anything I can try? The processor and memory are supported... maybe this board is toast?

The Q code display doesn't indicate problems once the OS is running.  It indicates where the system is during POST, and what it's currently stuck on (if it stops on a number for a while or fails completely).  After control is handed to the OS, it displays your CPU temperature (if the BIOS setting for it is in Auto, or the final code from POST otherwise).


Hello, @msalisbu .

According to the error message you provided regarding the DirectX error, have you tried installing the latest DirectX, disabling the game recording function, or reinstalling the game or DirectX?
Please confirm that you also updated the Intel ME to the version before updating the BIOS, try installing two memory in DIMM_A2 and B2 slot, and default the BIOS to test if the problem persists.

If the above steps unable to solve, please share the info below for us to better understand the scenario.
- the content of the setting in BIOS (or whether it is the default)
- the brand and model name of the PSU currently installed
- the current OS version and OS build

Thank you.

It's not possible to re-install directX on windows 10/11, it's managed entirely by windows update. Trying to install via the web installer won't do anything since it detects it's installed already.

ME was updated to the version supplied by asus.

BIOS was reset to defaults, same issue. Tried with DIMM A2/B2 only, same issue. 

Operating System: Windows 10 Pro 64-bit (10.0, Build 19045) (19041.vb_release.191206-1406) - failed
Operating System: Windows 11 Pro 64-bit (10.0, Build 22621) (22621.ni_release.220506-1250) - failed

PSU is EVGA SuperNOVA G5 1000w

Level 18


Please try with only 2 sticks from the same kit (the serial numbers should follow each other) on A2 & B2.

Refer to this post from Silent_Scone :

I've tried, no change. Memtest86 shows all 4 DIMMs are OK, in different configurations.



Hello, @msalisbu .

May I ask if you have downloaded the DirectX End-User Runtime Web Installer from the Microsoft official website to install the appropriate version of DirectX for your system?
It will automatically detect your operating system and hardware configuration to help you install the appropriate version.

Thank you.

It's not possible to update DirectX via web installer for windows 10/11, it's managed entirely by windows update. Running the web installer will just exit saying it's already installed. There are no available windows updates.