Showing results for 
Search instead for 
Did you mean: 

ThunderboltEX4 not working with Rog Strix Z690-F Mainboard

Level 8


I read through another thread here with a similar problem I guess, but I cannot comment on that topic. 

The ThunderboldEX4 doesn't work for me, the Thunderbold Control Center shows 'N.A', the device-manager shows an exclamation mark next to the thunderbolt driver. I already updated all drivers using Armory Crate and Windows Updates, reinstalled the Thunderbolt driver multiple times. 

At one time i could see the TB version in thee Thunderbolt Control panel, but after some short time it was gone again (also I didnt see the connected thunderbolt device). 

More annoying: I'm getting bluescreens after some minutes (driver_power_state_failure) if thunderbolt support is enabled in BIOS.

I have the latest BIOS version installed. (2703)

I've read that this issue may be related to the outdated ThunderboltEX4 firmware, so I tried updating it using "Launch EFI shell from filesystem" as statet in the Readme, but this button always shows a message, that I need to disable Secure Boot, which is already disabled ("other OS" and I also cleared the keys). I did a CMOS reset also and tried to boot the EFI file regularly by moving it to "/EFI/BOOT/BOOTX64.EFI" and booting it from USB, but this method shows "isolinux.bin is missing"

How can I update the firmware of the ThunderboltEX4 to NVM36? (I think I'm on version 22) 


It's pretty annoying that there are many people having these issues with this extension, but Asus is not willing to provide working guides. Especially because mainboard and the extension are both from ASUS I expected it to work properly without lots of troubleshooting.

ASUS: You're loosing fans with this kind of support


Accepted Solutions

I ordered a replacement card, which is working now. It's already on version 1.1. I didn't even had to reinstall the driver.

View solution in original post


Customer Service Agent

Hello, @Haschtl 
Based on your description, have you attempted to visit the ThunderboltEX4 official website's support page, navigate to "Driver & Tools," and download the "TB & PD Firmware Update" and then update it to version 36 as per the instructions?

After completing the update, we recommend powering off for a few minutes before restarting.
If you continue to experience issues after the update, it would be helpful if you could provide more detailed information, such as the devices connected via Thunderbolt, the slot location where ThunderboltEX4 is installed on the ROG STRIX Z690-F GAMING WIFI, and screenshots of any error messages.
This additional information will help us better understand your scenario.

Thank you.

Sure, I first followed the instructions from there using the "Launch EFI shell from filesystem" button from BIOS. As I stated above, it just shows a warning, that I need to disable secure boot (which is already disabled), and then I cannot proceed with the update.

Can't you provide another method how I can update the firmware of the TB-EX4 without using the "Launch EFI shell from filesystem" button? I also wonder how this update should be possible for mainboards from other manufacturers, where this button is not available...

There is no device connected to the ThunderboltEX4. The extension itself is connected to the lowest PCIe x16 slot (number 3 in the quick-start guide). The first x16 port is used by my graphics card and the second one is just PCIe x1, which is not suitable for the ThunderboltEx4.

Here are my driver versions and the output of the thunderbolt control center (sometimes it shows the controller after boot, but after some time or when i connect some device to it, it switches to "N/A")

Screenshot 2023-10-04 132556.png

Screenshot 2023-10-04 132508.pngimage_2023-10-04_13-24-42.jpg

Ok, I now somehow managed to update the firmware of the ThunderboltEx4 to NVM version 36 using the provided method. I don't know, why the "Launch EFI shell from filesystem" button worked now, but anyways....


After the update, i reinstalled the latest windows-driver from the ASUS website and rebooted twice.

The Thunderbolt control-panel showed that the current NVM version is 36. The windows device manager showed no exclamation mark next to the Thunderbolt driver, but as soon as I connected my thunderbolt4 device (Dell WD22TB4 docking station), the thunderbolt driver completely dissapeared from the windows device-manager and the Thunderbolt Control-Panel shows "N/A" again.

Also there is an exclamation mark next to an USB 3.10 eXtensible-Hostcontroller in the windows device manager. I don't know, if that's related


I finally managed to get the dock working mostly. I uninstalled the driver multiple times. Finally I installed the driver from Intel, which works now!

But there is still one remaining problem. I'm still getting the "driver_power_state_failure" bluescreen after some time. This error also occurs, when I try to shutdown/reboot the system. It always get's stuck during reboot/shutdown and finally the "driver_power_state_failure" bluescreen appears.

What causes these bluescreens? Btw. there is no bluescreen, if I disable discrete thunderbolt support (but obviously the ThunderboltEX4 doesn't work with this setting disabled)

Here are my thunderbolt BIOS settings:


I've just updated the BIOS to the new version 2802. 

Now everything (BIOS, Firmware, Drivers) is up-to-date, I've reinstalled the drivers multiple times, but still the same issues:

I'm getting "driver_power_state_failure" after some minutes after boot. It doesn't matter If I have a driver installed or not. As soon as I enable "Discrete Thunderbolt Support" in BIOS, the bluescreen issue is there. (no bluescreens if "Discrete Thunderbolt Support" is off)

Here are again my versions reported by the BIOS:


Please provide some guidelines to fix these issues or at least continue communication.

For sure my last ASUS hardware if the support will stay on this level (no support). I own an ASUS motherboard, the ThunderboltEX4, an ASUS RTX3070 and a Asus ZenFone 8. Continuously having problems with 3 (!) devices:

- Mainboard: Armory Crate is a sh***y tool, mostly not working at all - Aura creator same thing, I can only control the internal LEDs of the RTX3070

- ZenFone 8: Some year old smartphone sold with USB2.0, which is a no-go for middle/highend smartphones. No problem with only USB2.0? Then try to connect your phone to an external screen (using Android desktop) - simply doesn't work.

- ThunderboltEX4: Doesn't run at all, just causing bluescreens.


Here is the error message of the Thunderbolt driver:

Beim Start des Geräts PCI\VEN_8086&DEV_1137&SUBSYS_87F61043&REV_00\EB07A0D021C9A00000 ist ein Problem aufgetreten.

Treibername: oem60.inf
Klassen-GUID: {4d36e97d-e325-11ce-bfc1-08002be10318}
Dienst: nhi
Untere Filter:
Obere Filter: WUDFRd
Problem: 0x0
Problemstatus: 0xC00000E5

There is also a warning about some failed device-setting migration:

Die Geräte Einstellungen für PCI\VEN_8086&DEV_1137&SUBSYS_87F61043&REV_00\EB07A0D021C9A00000 wurden aufgrund einer partiellen-oder nicht eindeutigen Geräte Übereinstimmung nicht von der vorherigen Betriebs System Installation migriert.

ID der letzten Geräte Instanz: PCI\VEN_8086&DEV_464D&SUBSYS_86941043&REV_02\3&11583659&0&30
Klassen-GUID: {4d36e97d-e325-11ce-bfc1-08002be10318}
Positions Pfad:
Migrations Rang: 0xF000FFFFFBC1F132
vorhanden: false
Status: 0xC0000719


Please note, that this the Thunderbold driver (in device-manager) shows the yellow exclamation mark only if I enable "Discrete Thunderbolt Support" in BIOS. If it's enabled, the "Thunderbolt Controlcenter" does not show any information. If it's disabled, I can see the Controller (NVM version 36), but the ports of ThunderboltEX4 work as a regular USB-Hub. Also the control-center shows "PCIe-Tunneling: disabled" correctly, if "Discrete Thunderbolt support" is disabled.

I ordered a replacement card, which is working now. It's already on version 1.1. I didn't even had to reinstall the driver.

Thunderbolt stopped working after latest Motherboard BIOS update i need roll back bios to the older version but i can't becauz my actuel bios version does NOT allow rolling back to the previous versions..

Modèle (Model): - rog strix z690-i gaming wifi


Version du BIOS : 2802

Système d’exploitation(OS) : Windows 10 Professionnel 22H2 ( 19045.2846)


Update: I was wrong. Only the bluescreens were gone. Thunderbolt connection did not work. It sometimes worked for less then a second and then the screen disconnected again.

I've just returned it. No TB4 for my computer. And no more ASUS hardware anymore, too. Thanks for your "support".

I really don't get it, how ASUS can continue to sell this hardware.