Showing results for 
Search instead for 
Did you mean: 

Thunderbolt stopped working after latest Motherboard BIOS update (2204)

Level 9
Hello everyone.

I have an ASUS ROG Strix Z690-A Gaming WIFI D4 motherboard and an ASUS ThunderboltEX 4 connected to it on the last PCIe slot.

I am running Windows 11 and use this device for music production which is my work (I require thunderbolt for my studio).

My build had been working perfectly fine with thunderbolt when I had BIOS version 1304. I did however have a different issue at the time where my machine would not post if I set any XMP (I or II) on. I was working with the BIOS load defaults and had to work with my RAM at 2666MHz despite it having a capacity of 4000MHz.

I noticed I was very behind on the BIOS updates so I thought perhaps this XMP issue would be fixed if I did the update. I updated to the latest BIOS version 2204 and it fixed the XMP problem. However, thunderbolt functionality completely stopped - which is even worse because now I can't really work. And for the record, I updated Intel ME before updating the BIOS.

Under "Device Manager" I see "Thunderbolt(TM) Controller - 1137" has a yellow triangle on it and when I see it's properties it shows an error message saying "Windows has stopped this device because it has reported problems (Code 43)". Also, if I go to the Thunderbolt Control Center app and click on "About" it shows the correct application version but the "controller driver version" has a weird "N/A". No devices get recognized when connecting via thunderbolt. I can tell it is passing electricity since my CalDigit thunderbolt hub's led lights up when connected but Windows does not recognize the device and it does not work. No thunderbolt devices work with different cables and everything so the the issue is clearly related to whatever changed in thunderbolt when updating the BIOS.


I tried looking for more info on the "Event Viewer" but all I see is an Error stating the device "had a problem starting" with problem status 0xC00000E5. Which after doing some research does not really help me pin down a solution.


I tried uninstalling and reinstalling the thunderbolt drivers and thunderbolt control center, updated all other drivers, completed all Windows updates and optional updates, removed the ThunderboltEX from the PCIe slot and then placed it back in... but it made no difference. Finally, I found that ThunderboltEX 4 had a TB & PD firmware update I could try. I followed the instructions and when launching the Shell.efi from BIOS I got a weird message for "Thunderbolt Nvm" which says "No support update ,Please check Thunderbolt installed correctly and try again, or contact Asus customer service". For the "Cypress PD" part of the firmware update, it completed with no issues and is now version 129. I don't understand why it does not want to update the firmware of TB though and I don't understand what it means by "No support update".


I wish I could easily just go back to BIOS 1304 so I can have thunderbolt back but I'm scared to try since after BIOS version 2004 there are notes stating that rolling back to earlier versions is not supported. My only hope right now is that rolling back to BIOS 2103 or 2004 will resolve this. I'll report on that here but I was hoping someone had any ideas on what I can do to fix this. I really can't reinstall a fresh Windows OS since that would delete all my studio settings, configurations, plugins, programs which took years of putting together.

Customer Service Agent

Hello, @raugam111 .

Please check the PM inbox in the top right corner. Thank you!

Level 8

Same issue with the Thunderboltex 4 card and an ASUS Z790P-Wifi board.

It's really unfortunate that there hasn't been a solution provided yet. The only thing that was able to help another user with a similar issue was that customized bridge BIOS version but I have not been able to get a hold of it rom ASUS yet.

Level 8

I'm fortunate that my motherboard & thunderboltex 4 card are still under warranty and as such I have a outstanding support case with ASUS to help resolve this issue. I heard from them today saying that all the info I have submitted to them was forwarded to a "higher level of support" for them to do some further research into the issue. I spent over two hours on the phone with their tech support a couple days ago going through all the possible troubleshooting steps they could think of, which was pretty much everything in this forum post.

I pointed them to this forum post, the post about the customized bridge BIOS version and a reddit thread I found in which others are having similar or the same issues as well so that they understand this is not a localized issue but that this is an issue facing multiple users.

I'll let you know what I hear back from this "higher level of support".

That would be great! Please do keep us updated here if you can, it would be very helpful to know what solution the higher level of support can provide you. I will do the same with any answer I get from ASUS support. I am currently still waiting for a response to my requests for this customized bridge BIOS version.

Level 8

I had a very similar issue with the installed BIOS 2305 in a ProArt Z-690 Creator WiFi board, but before that had Intel ME Firmware v16.1.25.2020 applied.

Computer booted to Windows and I lost my Thunderbolt 4 connections. Thunderbolt dock and a Thunderbolt SSD drive were all gone. Went into the BIOS assured I had the latest v2305 BIOS, latest Intel ME FW (above) and Thunderbolt section was Enabled and on. Booted back into Windows and still didn't work.

What did work was installing Intel Chipset Driver v10.1.19444.8378 by user MoKiChU:

Rebooted. Thunderbolt 4 works now and hoping it remains that way.

Thats very interesting! Thanks so much for sharing. I actually just tried this on 2204 BIOS and it did not work. I'll try again after updating BIOS to 2305.

For the record. After I shut down the PC for the night. This morning, when i restarted, my Thunderbolt connections were gone again.
So this time, I updated the Intel ME Firmware to: v16.1.25.2124 (from v16.1.25.2020) and that didn't correct the issue.

Then I updated to Intel Management Engine Interface v2251.4.2.0. Restarted and now my Thunderbolt connections are back. Not sure what is going on but I suspect the Asus bios needs tweaking.

Go here for the latest drivers and firmwares:

Just curious - are your Thunderbolt devices all TB4? I have the ROG Strix Z690-I Gaming WiFi and have been using a MOTU 828ES via an Apple TB3->TB2 adapter for a year. Starting with the 2204 update, I can't get any of my TB devices to show up. The TB controller looks fine in Device Manager, Thunderbolt Control Center recognizes both ports, Event Viewer has no errors, only the NHI event saying the hardware is connected and active.

I've tried every BIOS setting related to Thunderbolt, updated to all the latest firmware and drivers listed above as well as BIOS 2305. 

I saw your posts and tried those things too, hoping that I could just get it to show up once.  Nothing. USB-C devices work, but no Thunderbolt devices.

It is enormously frustrating and makes it difficult to the audio post-production work I need to do since I can't connect to the audio interface. The MOTU interface worked on Thunderbolt until BIOS 2204. It works fine on my Dell Precision 7750 that I use for on-site recording, also via Thunderbolt. Now it's broken and I can't roll back to the BIOS where it worked.


I'm using TB3 Pro Dock by OWC in one TB4 port and a TB3 G-Drive SSD 2TB in the other TB4 port on my ProCreator Z-690 board.

When I was on BIOS 1304, all was good. After applying the 2020 Intel Me update and the then BIOS 2305, my Thunderbolt stopped working.

Then with the steps I outlined above I got it to work.

PC is shut off now so I can't check if all is still good as I'm away from the house but I will report back when I get back in.

All of this should be addressed with Asus. And not sure why the new firmwares and device drivers that I grabbed are not listed on Intel's site.