cancel
Showing results for 
Search instead for 
Did you mean: 

Thunderbolt stopped working after latest Motherboard BIOS update (2204)

raugam111
Level 9
Hello everyone.

I have an ASUS ROG Strix Z690-A Gaming WIFI D4 motherboard and an ASUS ThunderboltEX 4 connected to it on the last PCIe slot.

I am running Windows 11 and use this device for music production which is my work (I require thunderbolt for my studio).

My build had been working perfectly fine with thunderbolt when I had BIOS version 1304. I did however have a different issue at the time where my machine would not post if I set any XMP (I or II) on. I was working with the BIOS load defaults and had to work with my RAM at 2666MHz despite it having a capacity of 4000MHz.

I noticed I was very behind on the BIOS updates so I thought perhaps this XMP issue would be fixed if I did the update. I updated to the latest BIOS version 2204 and it fixed the XMP problem. However, thunderbolt functionality completely stopped - which is even worse because now I can't really work. And for the record, I updated Intel ME before updating the BIOS.

Under "Device Manager" I see "Thunderbolt(TM) Controller - 1137" has a yellow triangle on it and when I see it's properties it shows an error message saying "Windows has stopped this device because it has reported problems (Code 43)". Also, if I go to the Thunderbolt Control Center app and click on "About" it shows the correct application version but the "controller driver version" has a weird "N/A". No devices get recognized when connecting via thunderbolt. I can tell it is passing electricity since my CalDigit thunderbolt hub's led lights up when connected but Windows does not recognize the device and it does not work. No thunderbolt devices work with different cables and everything so the the issue is clearly related to whatever changed in thunderbolt when updating the BIOS.

97312

I tried looking for more info on the "Event Viewer" but all I see is an Error stating the device "had a problem starting" with problem status 0xC00000E5. Which after doing some research does not really help me pin down a solution.

97313

I tried uninstalling and reinstalling the thunderbolt drivers and thunderbolt control center, updated all other drivers, completed all Windows updates and optional updates, removed the ThunderboltEX from the PCIe slot and then placed it back in... but it made no difference. Finally, I found that ThunderboltEX 4 had a TB & PD firmware update I could try. I followed the instructions and when launching the Shell.efi from BIOS I got a weird message for "Thunderbolt Nvm" which says "No support update ,Please check Thunderbolt installed correctly and try again, or contact Asus customer service". For the "Cypress PD" part of the firmware update, it completed with no issues and is now version 129. I don't understand why it does not want to update the firmware of TB though and I don't understand what it means by "No support update".

97314

I wish I could easily just go back to BIOS 1304 so I can have thunderbolt back but I'm scared to try since after BIOS version 2004 there are notes stating that rolling back to earlier versions is not supported. My only hope right now is that rolling back to BIOS 2103 or 2004 will resolve this. I'll report on that here but I was hoping someone had any ideas on what I can do to fix this. I really can't reinstall a fresh Windows OS since that would delete all my studio settings, configurations, plugins, programs which took years of putting together.
8,582 Views
54 REPLIES 54

ronfucci
Level 8

Two items re: the ASUS EX4 AIC I learned:

1. the 'firmware' update provided by ASUS for this card updates the Cypress chip but not the TB firmware

2. look at the serial number on the card; SN that starts with 'N' has correct firmware, SN that starts with '

M' never worked for me

3. If  you have an EX4 card with SN that starts with 'M' I would see if I could return it to the store you bought it from; if not RMA the card back to ASUS

raugam111
Level 9

I hope this helps others. After multiple months waiting for ASUS to provide me with a solution, I tried something new. I figured I am most likely not getting this "custom bridge" BIOS version (and if I do it is going to take very very long).  Thanks to some of the folks on this thread commenting on the ThunderboltEX 4 firmware possibly being incompatible with the new BIOS versions. I had firmware version 24 and I decided to just buy a new ThunderboltEX 4 with hopefully a higher firmware version. I was lucky and the one I purchased was firmware version 31. I'm not entirely sure if this was the sole reason for this but this new ThunderboltEX that had a higher firmware works on BIOS version 2004. I'm not planning on updating the BIOS from now on unless I really need to and something is not working. This serves asa lesson lol.

I hope this helps any of you in a similar position. I can finally get back to work.

I think the firmware level is the reason.

I would bet that the prior FW24 has the letter 'M' at the start of the Serial Number.

The card with FW32 has the letter 'N'.

I worked thru this issue with Asus quite a bit, one, the let them know what I found regarding SN correlation to FW.  Also to let them know that what they have for download on the EX4 is labeled a FW update but that is only for the Cypress chip, not the Thunderbolt FW.

It seems Asus is not able to produce a TB FW update to take a FW24 to FW32.

drwho351
Level 7

Hello - Did you get anywhere with this?  I ask - because I'm having issues with a Maximus XIII Hero board.  Technical Support is working on a new BIOS firmware. However the version 1801 just release changed nothing for me.  Curious to hear what experiences others are having. 

 

The Firmware on the card itself is the issue, not the MB BIOS.

Look at the SN of the card on the box and see what I wrote above.

If you can, the real solution would be to obtain the updated firmware on the card by getting on labeled with the correct SN prefix (that is the letter 'N' is FW 31 and 'M' is FW 24 which doesn't work)

Hope this helps