Showing results for 
Search instead for 
Did you mean: 

Strix z790-e Realtek USB2.0 Audio driver overwriting Realtek USB Audio

Level 7

Recently (Windows 11) I tried updating to the latest z790-e audio drivers from the ASUS support website and now in the device manager I see a default Microsoft driver Realtek USB2.0 Audio and not the usual Realtek USB Audio driver entry? And I can't run or install the Windows App Store Realtek control panel, it gets an error while trying to download.  Plus, the DTS control panel app shows that I'm not licensed anymore.  I have jumped through all kinds of hoops trying to figure this out.  Uninstalling everything related to the Realtek drivers and starting over... same result, the Realtek USB2.0 Audio Microsoft driver shows up.  I even turned off audio driver updates in Windows 11.

Has anyone else experienced this?  Very frustrating.  The audio works with the Microsoft driver, but I don't have access to all the different control settings / speaker / headphone impedance settings etc.  mg



Customer Service Agent

Hello, @Defilercb 

May I ask if you are currently using the same ROG STRIX Z790-E GAMING WIFI or a different model, such as the ROG STRIX Z590-E GAMING WIFI?
Are you experiencing an audio issue while using speakers or headsets?
If the problem persists, have you tried reconnecting or cross-testing with different ports or another audio device?
We recommend checking for any relevant driver updates, verifying if there is a BIOS update requirement, and referring to below related FAQs for troubleshooting.
[Motherboard]Troubleshooting-Audio with no sound
[Windows 11/10] Troubleshooting - Sound (Speakers/Microphones) problems

Thank you.

sharing complete hardware info & software config details will help us better understand the issue 🙂

Level 11

Install the audio driver via Armory Crate. Then everything should be there, including Sonic Studio 3.

I also had problems with the installation at first, but was able to fix it by installing via Armory Crate.

The fact that the SPDIF interface (optical Toslink connection) appears is good because then the sound card with all connections is recognized correctly.
But if nothing is connected to the SPDIF, you won't hear anything.
Check in the Windows sound settings what is set as "standard audio" and set it according to your connected speakers.

A notice:
As long as Realtek USB 2.0 Audio is in the device manager, an old driver that comes through Windows 11 is installed.
After installing the Realtek USB Audio Driver VB6.3.9600.2342 or later, the display will be renamed to "Realtek USB Audio".

Intel Core i7 13700K / AiO Fractal Design Lumen S36 v2 RGB / Asus Rog Strix Z790-F Gaming WIFI / Corsair Dominator Platinum DDR5-5600 64GB (4x 16GB) / Asus TUF RTX 4070 ti OC / 4x Samsung 980 pro 1TB / Seasonic Prime GX 850 W Gold / Fractal Design Meshify 2 Lite RGB Black TG Light Tint / Monitor AOC Q27G2S/EU (WQHD)


Not correct , its no different loading realtek etc from Aroury Crate !

Level 8

Im using Z3900E Wifi II and Sonic studio 3 as part of sound setup is now disabled by Asus adjusted  updates !! Reatlek usb audio ( not Realtek usb 2.0 audio) will appear as an entry in device manager  if you use driver  6.3.9600.2369 from Windows 11 forums  and Realtek audio console should then load from Microsoft store  ( )    ,otherwise search Mokichu on Windows 11 Forums, who is the no 1 expert on Asus related drivers)