cancel
Showing results for 
Search instead for 
Did you mean: 

Strix z790-e Realtek USB2.0 Audio driver overwriting Realtek USB Audio

Matthew_George
Level 7

Recently (Windows 11) I tried updating to the latest z790-e audio drivers from the ASUS support website and now in the device manager I see a default Microsoft driver Realtek USB2.0 Audio and not the usual Realtek USB Audio driver entry? And I can't run or install the Windows App Store Realtek control panel, it gets an error while trying to download.  Plus, the DTS control panel app shows that I'm not licensed anymore.  I have jumped through all kinds of hoops trying to figure this out.  Uninstalling everything related to the Realtek drivers and starting over... same result, the Realtek USB2.0 Audio Microsoft driver shows up.  I even turned off audio driver updates in Windows 11.

Has anyone else experienced this?  Very frustrating.  The audio works with the Microsoft driver, but I don't have access to all the different control settings / speaker / headphone impedance settings etc.  mg

 

2,053 Views
13 REPLIES 13

Tweakfiend
Level 8

Hi

I have managed to load Realtek Audio Console but not Sonic Studio 3 , therefore the sound for Z790-E Wifi II lacks any volume / adjustment .

The no 1 authority  for Windows sound is"Mokichu", currently on Windows 11 forums. However for the first time in 2/ 3 years even he did not get the correct driver or perhaps Sonic studio updates are just crap.

This mobo cost nearly £600 and so sound should just work !!

Hi, yes, (thanks for responding) the issue all started when I tried to install Mokichu's latest bundled drivers which were updated recently.   Before posting here I reached out to Mokichu. He was good to respond but was quick to say I should reach out to ASUS to resolve the issue.  He can't keep up with every z790 chipset motherboard of course.  The issue is a real pain.  I hope his next set of drivers resolves the issue.  And yes, for the price of this MB, it should just work.  You would think that cleaning up the drivers and reinstalling the latest package from ASUS would at least get me back square one, but no luck. 😞  mg

Koutport
Level 7

Hello I have the strix z790 gaming wifi and today I start new instalation but the realtek driver didnt install .

Μobo:ROG STRIX Z790-F GAMING WIFI-CPU:Intel Core i9-14900K-Cooler:EKW-EK-KIT RGB 360-RAM:G.SKILL Trident Z5 DDR5-6400 CL32 64GB(4 x 16 GB)-GPU:ASUS GeForce® ASUS ROG STRIX GAMING RTX-3080Ti-#43; EKW-EK-KIT 480 RGB -PSU:Corsair HX1200i:HDD:Samsung M2 980 PRO with heatsink 2TB+Samsung 990 PRO 2 TB RAID-0 +Asus RAIDR Express 240GB- Case:Thermaltake View 91 Tempered Glass RGB Editionx

Jiaszzz_ROG
Customer Service Agent

Hello, @Matthew_George 

Could you please confirm if your current motherboard model is the ROG STRIX Z790-E GAMING WIFI or the ROG STRIX Z790-E GAMING WIFI II?
The Realtek Audio Driver versions released for these two models on the official website are different.


We advise against installing unofficial drivers, therefore, please try uninstalling the current driver and installing the one provided on the official website to reevaluate the situation.
If you encounter any abnormalities using the official version, please provide relevant screenshots to help us better understand your issue.

Thank you

Hello, @Koutport
For guidance on installing audio drivers, please refer to [Motherboard] How to install motherboard drivers and utilities?

Thank you. 

sharing complete hardware info & software config details will help us better understand the issue 🙂

I have the ROG STRIX Z790-E GAMING WIFI original version that came out last year.  I'll try the driver link you supplied for the non-WIFI II version. mg

Hello and thank you for quik reply. My motherboard is the Asus ROG z790 -Gaming -F- wifi .I try the way from Armoury Crate.

Thanx.

Μobo:ROG STRIX Z790-F GAMING WIFI-CPU:Intel Core i9-14900K-Cooler:EKW-EK-KIT RGB 360-RAM:G.SKILL Trident Z5 DDR5-6400 CL32 64GB(4 x 16 GB)-GPU:ASUS GeForce® ASUS ROG STRIX GAMING RTX-3080Ti-#43; EKW-EK-KIT 480 RGB -PSU:Corsair HX1200i:HDD:Samsung M2 980 PRO with heatsink 2TB+Samsung 990 PRO 2 TB RAID-0 +Asus RAIDR Express 240GB- Case:Thermaltake View 91 Tempered Glass RGB Editionx

Jiaszzz_ROG
Customer Service Agent

Hello, @Koutport  Thank you for confirming.

Did you encounter any difficulties during the driver installation?
If so, could you please provide screenshots of the latest Armoury Crate update center and details of the issue you are facing?
Please also try installing the driver by following the guidance in the FAQ I shared earlier, if needed.

Thank you.

sharing complete hardware info & software config details will help us better understand the issue 🙂

Hi

I always install correct drivers . Its likely that their interactivity with Windows 11 is the problem, ie not enough research into the interaction.

Defilercb
Level 7

Hello everyone,

i am using asus rog strix e-gaming wifi motherboard and today my sound completely disappeared. It was working just fine yesterday before i shut down the computer. In the settings i see that the device for the audio that i was using is not listed anymore, instead i have a device called spdif interface(realtek usb 2.0 audio) device in it's place, which obviously doesn't produce any sound.

Is my motherboard malfunctioning or this is some sort of driver issue that i read above and i don't know how to fix.