Showing results for 
Search instead for 
Did you mean: 

Strix B650E-F struggling with RAM

Level 7

RAM (problematic): 6000J3636F16GX2-TZ5NR (G.SKILL Trident Z5) 16x2 kit
CPU: AMD Ryzen 7 7800X3D

Current status: Successful boot on BIOS version 0821 with single RAM stick in slot A2. Cannot POST with that RAM stick's mate, in any configuration (or if it does work, it takes over the 30 minutes I gave it).

How we got here: Everything behaved normally from 2023 October to 2024 May; a couple days ago, I had a crash. Afterward, the system failed to post. There was one initial yellow Q-LED (DRAM), then red (CPU) from then on. I checked the CPU (no damage, obviously, since it worked later), replaced the cooler, etc., and used the Clear CMOS header. Still failed to post, but was now yielding yellow (DRAM) light consistently. After several trials (moving them to A1/B1, swapping their positions in A2/B2, and then several trials of each in A2 solo), I got the results mentioned above. I can boot if, and only if, I have the single RAM stick in slot A2. Heading off the inevitable question: Yes, they're from the same kit.

The Actual Question: I would rather like to go back to having all of my RAM available. Assuming I only have this build and can't casually exchange parts with another build, is there a way to safely test whether the problem is coming from the mobo or the apparently problematic RAM stick without going so far as "RMA the ram kit" here? I would prefer to get the sticks I have working rather than wait for a replacement kit.


Super Moderator

Hi @CDA-2A 
If both modules post successfully in A2 but neither in B2 then this could indicate a few things.

However, can you confirm if both modules post successfully in A2?

1. Inspect the CPU and motherboard pin pad for any damage or debris

2. Ensure the stand-off screws for the motherboard are not over-torqued.

3. Ensure the CPU cooler is correctly mounted ensuring even mounting pressure as per the cooling vendor's instructions#

4. Test both modules individually in the UEFI via Memtest86+

13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

Level 7

Ah, sorry if I wasn't clear.

- CPU and Motherboard are free of damage and debris
- Stand-off screws and CPU cooler were carefully reseated while resolving the CPU error.

- I have two modules in the kit, we'll call them P and Q. Original configuration was A2:P + B2:Q. The following configurations had these results after resolving the CPU post failures:

  • A2:P, B2:Q - fails
  • A1:P, B1:Q - fails
  • A2:Q, B2:P - fails
  • A1:Q, B1:P - fails
  • A2:P - succeeds
  • A2:Q - fails

When I have an opportunity, I'll perform the memtest86+ scans and see if Module P posts in other slots. I'll also run Module Q in the other slots solo to see if I can get a post and memtest that one, too.

Thanks for clarifying. From that I would consider that the module (Q) is potentially faulty assuming this is at Optimised Defaults and you're not attempting to enable EXPO.

13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

Level 7

Sorry for taking ages to follow up on this! Update:

- Using the module that posted, I updated BIOS to 2613 and ran memtest86+
- BIOS updated without incident
- Memtest86+ yielded no errors on the module that would post.
- Using the RAM module that posted in B2, I changed the RAM speed in the BIOS from "Auto" to "EXPO 1" preset
- After doing all of this, I added the previously misbehaving RAM module to slot A2. It now posted when added to slot A2.
- Ran memtest86+ on both sticks, yielded no errors on either of them.
- No problems since then.

I can't say if any particular step between the BIOS and the EXPO setting is what fixed it, since I didn't test between them, but it all seems to be functioning now.