Showing results for 
Search instead for 
Did you mean: 

Strix B650e-e Wifi card and SATA drives randomly disconnect while playing games

Level 8

I've been dealing with an extremely frustrating problem since I upgraded to AM5 recently. Before I explain the issue, here are my specs:

  • Asus Strix B650e-e
  • AMD 7950X3D
  • G-Skill 32GB 6000MHz CL30
  • RTX 4090
  • Thermaltake 1200W PSU
  • Windows 10

The issue is that within 10-30 minutes of playing any game that puts load on the cpu, all (two) of my SATA SSDs will disconnect and the Wifi network card will also eventually disconnect (not necessarily all at the same time). They just completely disappear from task manager like they don't exist. This isn't a matter of my network connection cutting out, this is the network adapter disappearing from task manager and the PC acting like there is no wireless adapter installed at all. 

Luckily, Windows and most of the games I play are on Nvme drives. (There is no problem with the Nvme disconnecting). Nevertheless, the network adapter and SATA devices should not be disconnecting randomly while playing games. The only way to get them reconnected is by either restarting the PC or by going into device manager and manually restarting the Asmedia SATA driver and the MediaTek network adapter driver. 

I'm really at a loss on what to try next. I've been troubleshooting this issue for a while now to no avail. Here is everything I have already tried with no success:

  • Updated and reinstalled all Chipset, SATA, Wifi, etc. drivers with the latest versions (below) from the Asus sites
    • Asmedia 106x SATA Controller [6/24/2020]
    • MediaTek WiFi [3/28/2023]
    • AMD B650E Chipset [5/23/2023]
  • Updated BIOS multiple times. Tried latest BIOS released today (1636), issue still persist. 
  • Cleared CMOS and ran BIOS at stock settings (No Expo or overclocking) and issue still persist
  • Updated all firmware for SATA drives and confirmed health of all SATA drives with CrystalDiskInfo
  • Swapped out all SATA cables with new ones and tried all the SATA ports on the board
  • Adjusted power settings to ensure the SATA drives and network adapter don't go into any sleep states
  • Performed a network reset in Windows settings
  • Finally, I did a complete clean reinstall of Windows 10 just a few days ago and that still didn't fix anything

Event viewer does throw events when the SATA drives and network adapter disconnect seemingly randomly during gameplay. When the two SATA SSDs disconnect, event 157 "Disk has been surprise removed" is thrown:


When the network adapter disconnects, event 5002 is thrown:


Finally, here is my device manager. If anything here looks out of the ordinary, please let me know.


Any advice on how to proceed would be greatly appreciated. Please let me know if there is a troubleshooting step I missed or a driver I forgot to try updating or anything you think could potentially solve the problem. Thanks!


Customer Service Agent

Hello, @ixvst01 
Thank you for providing the relevant information, including the troubleshooting steps you have already attempted.

However, the following questions still require your assistance in order to clarify the situation:

Could you please clarify whether the problem with both SATA SSDs disconnecting and Wi-Fi dropping during gaming occurred following any specific changes?
For example, did it arise after a BIOS update or after connecting an external device?
May I ask if it is your usual practice to resolve this issue by rebooting or manually installing the relevant drivers?
Kindly specify all the games that are affected by this issue. 
Apart from playing games for 10–30 minutes, are there any other circumstances that trigger this problem?
Additionally, please share the brand and model of the two SATA hard drives that are currently installed, whether they are connected to the SATA6G_E12 and SATA6G_E34 ports on the motherboard, and which hard drive you are utilizing as the system drive.
Furthermore, do you have any other M.2 SSDs or HDDs installed apart from the SATA hard drives?
If you do, could you kindly confirm their brands, models, and the slots in which they are currently installed?
Please also clarify whether the memory you are presently using is in a single or dual configuration and provide the complete part number, such as F5-6000J3038F16GX2-TZ5NR.

Thank you.

Thank you for responding. 

I guess it’s possible a bios update may have triggered the issue, but I've been keeping up and installing all the latest non-beta bios on release, so it’s hard to determine if that is the actual cause. I am reluctant to go back and test this by installing an older bios version since a lot of the new bios updates were critical for the X3D chips and their voltage regulation. I did not install any new components or use any new external devices since upgrading to AM5. 

The problem appears to occur in games that are more resource intensive in general. For example, here are games that the problem has occurred during playing:

  • Red Dead Redemption 2
  • Ghostwire Tokyo
  • Cyberpunk 2077
  • Train Sim World 3
  • Microsoft Flight Simulator
  • F1 22
  • FIFA 23
  • No Man's Sky
  • Elden Ring
  • Forza Horizon 5. 

In terms of resolving the problem, I usually try to restart the PC. However, if I'm playing a game that needs wifi to work, I will just pause the game, go into device manager, and restart the driver. I don’t reinstall the driver, I right click and disable. Then I right click again and enable. That brings back the wifi or SATA drives and resolves the issue temporarily. 

I haven’t encountered the problem occurring during any other scenario other than playing games. Then again, I don’t use my PC for any other resource-heavy task, so it’s hard to say if doing something else could also trigger it. 

The two SATA SSDs I have are currently plugged into SATA ports 1 and 2 on the board. Like I said before, I have tried switching which ports they are plugged into and that doesn’t seem to make a difference. I’ve also tried unplugging one of the drives completely and having only 1 of the SSDs plugged in and the issue still occurs. Here’s the information on the SATA drives:

  • Samsung 1TB 870 Evo (Model MZ-77E1T0B/AM)
  • Samsung 500GB 860 Evo (Model MZ-76E500B/AM)

I don’t have any other SATA drives or HDDs. I use the SATA SSDs exclusively for file storage and don’t have any games or the OS on them. When they disconnect during gameplay, the drives aren’t even active or being used. I do have three M.2 NvMe drives on the board. Like I said before, there is no problem with these drives disconnecting or anything. I have Windows 10 and all my games on these drives. Here’s the information about them:

  • Samsung 990 Pro 1TB (OS drive) installed on M.2_1 slot. (Model MZ-V9P1T0B/AM)
  • WD Black 4TB SN850X installed on M.2_2 slot. (Model WDS400T2X0E)
  • WD Black 1TB SN750 installed on M.2_4 slot. (Model WDS100T3X0C)

I have tried removing the M.2 drive from M.2_4 to see if that could be the problem (since that slot runs off the chipset), but the problem still occurs regardless.

Finally, the memory I’m using is the G.Skill Trident Z5 NEO (AMD Expo) 32GB (2 x 16GB) DDR5 6000 CL30-38-38-96 (F5-6000J3038F16GX2-TZ5NR). I have it running in dual channel. I have tried turning off Expo in bios, but the issue still occurs anyways. 

I hope whatever the problem is that it is not hardware related. On the surface, it looks like an obvious driver issue, but I feel like I’ve tried every remedy there is for a potential driver issue. I noticed in the motherboard manual that the chipset and I/O chip sit right below the graphics card. Is there a possibility that the RTX 4090 could be overheating the chipset or I/O chip causing these disconnections? Also, I know there was a problem with SoC voltage regulation for the Ryzen X3D CPUs. Since SoC handles I/O and chipset functions, is it possible that high SoC voltage degraded a part of the CPU and that is causing the problem? Because the issue is occurring on both the Wifi card and the SATA drives (but not on the NvMe drives), I really don’t know what could be causing the problem on the hardware or software level. 

Again, thanks for responding, and I hope I can get this issue resolved. 

Customer Service Agent

Hello, @ixvst01 

Thank you once again for providing detailed specifications and explanations for us to better confirm and further verify the same specifications.
Currently, I have consolidated the information and am in the process of confirming with relevant departments, and I will update you as soon as possible.

However, upon verification, the drivers you are currently using, such as MediaTek WiFi and Chipset, are not from the support page of the ROG STRIX B650E-E GAMING WIFI.

May I ask where you downloaded the current versions from?
If possible, could you try installing the versions from the official website to further confirm the correlation between the driver versions and this issue?

Additionally, based on your description, this issue occurs during gaming for 10–30 minutes and seems to trigger easily.
Could you please assist us in recording a complete video of the issue?
This video should include the gameplay, the occurrence of the issue, your regular troubleshooting steps, and your computer usage environment.

Thank you.

Thanks for responding again.

With regard to the driver version discrepancy, I originally did have the Mediatek and chipset drivers installed from the motherboard support page. The issue was occurring with those driver versions installed and for troubleshooting purposes, I looked online to see if there were newer versions of the drivers available. I found AM5 B650E chipset drivers on AMD's site that were newer, and I found Mediatek drivers on this Asus forum post that were also newer. I tried installing them and the problem persisted, but I can assure you that the problem still occurred with the driver versions from the support page. For testing purposes though, I will reinstall the drivers from the support page. 

I actually did conduct some tests to try and reproduce the issue artificially yesterday while I was waiting for your response. I tried running stress test on the CPU and GPU. I ran the test with no background tasks other than HWInfo64

Idle temperatures:

  • CPU: 47C
  • GPU: 40C
  • Chipset: 74C

30 minutes of Prime95 stress test on CPU with no GPU load:

  • Max CPU temp of 88C
  • Max GPU temp of 43C
  • Max chipset temp of 78C

The issue did not occur during this test.


30 minutes of MSI Kombustor stress test on GPU with no CPU load:

  • Max CPU temp of 51C
  • Max GPU temp of 82C
  • Max chipset temp of 99.1C

The issue did occur during this test. 11 minutes in, event 157 was thrown and both SATA SSDs disconnected. Chipset temperature was 94.3C at this moment. Then, 15 minutes after that, the wifi adapter disconnected and event 5002 was thrown. Chipset temperature was 97.5C at this moment. At the end of the 30 minutes, the chipset was at 99.1 degrees.

So the issue appears to occur under high GPU load, but not CPU. This does align with the types of games the issue occurs in (games that are heavy on the GPU). Is it possible that heat from the GPU is causing the chipset to overheat? And is it possible the chipset reaching those high temperatures could cause SATA drives to disconnect and the wifi adapter to disconnect?

Unfortunately, I didn’t record any of this. I will redo the tests tomorrow as well as some gameplay to show the issue. I will get those recordings to you within the next 24-48 hours.

I completed some videos to show the issue. I was having some problems with OBS affecting GPU usage and FPS, so I wasn't able to get the wifi disconnecting on video with OBS. However, the last video was taken with my phone and shows the WIFI adapter disconnecting during gameplay. Pay attention to task manager and how the devices suddenly disappear. Also, disregard GPU usage showing near zero in task manager. That's a bug when playing games that use DX12. GPU usage is actually near 100% in these videos. 

This video shows both SATA SSDs disconnecting during a stress test with MSI Kombustor: (Check timestamps in description):

This video shows both SATA SSDs disconnecting during gameplay. (Check timestamps in description):

This video shows both SATA SSDs disconnecting AND Wifi disconnecting during gameplay. (Check timestamps in description):

Customer Service Agent

Hello, @ixvst01 

We appreciate you providing the relevant information.
I have consolidated and provided additional details to the relevant department.
Based on your description, this seems to be possibly related to temperature. 
Could you please confirm the current cooling system of your host, including fan connections and the brand and model of your CPU fan?

Thank you.


For cooling, I have an NZXT 240mm AIO. I also have 2 case fans for exhaust. That’s a total of 4 fans in my case. I have the fans hooked up to a Corsair fan controller and use the iCue software to control fan speeds. The 2 AIO intake fans are on a curve based on CPU temperature and the two exhaust fans are on a curve based on GPU temperature.

Here is my setup:


Customer Service Agent

Hello, @ixvst01 

Could you please try removing the two SATA SSDs and entering the system to see if the Wi-Fi issue still persists within 30 minutes of usage?
Alternatively, you could further confirm by testing with only the system drive installed.
Based on your description, we suspect a potential temperature-related connection with the SATA SSD.
Therefore, please monitor the temperature status of the two SATA SSDs (not limited to just CPU, GPU, and chipset temperatures).

Thank you.


I monitored the temperatures of the SSDs while playing some games. The two SATA SSDs reached a max temperature of 43C before they both inevitably disconnected. The NvMe SSDs averaged around 60-65C during gameplay. I unplugged the two SATA SSDs and played some games to see if the wifi would still disconnect. After about 45 minutes the wifi adapter did disconnect, although that is a little longer than it usually takes.