Showing results for 
Search instead for 
Did you mean: 

Specific motherboard website issue

Level 7
I have multiple Asus motherboards. One board has issues with support however. My Asus Z390 ROG Maximus Xi Hero Wifi. I have not been able to access the support files for a few months now. Just tried again today.

I can get to the site for that specific motherboard however the "Support" pages do not show up. I can even go to the Asus website Support and manually input the motherboard and it takes me right to the motherboard page however, again, the Support link is missing. I can read all about the motherboard itself.

So currently I cannot download any new/updated drivers, bios, etc. is the link:

Shows up for me. Have you tried a different browser?
A bus station is where a bus stops. A train station is where a train stops. On my desk, I have a work station…

xeromist wrote:
Shows up for me. Have you tried a different browser?

Yes, even tried on completely different computer. I sent a message to tech support last night. I hesitated initially because of all the extra data they were asking for for a website issue.(like motherboard serial #, etc.) Got a reply back today with a link to all the current files plus a link to that specific support page. Clicking the link in the email brought me right to the support/files page. So I next tried to get there manually. Still working like it should. I suspect they made some changes to something and the proper links/page is working now.
I started seeing an issue with this specific motherboard pages months ago. I have like 7 or 8 other Asus motherboards and this specific one was the only one causing issues.

Level 13
Actually happens a lot. The R6EE page is also fubar. I have a link directly to the support page that skips the intro page that works fine and that took some impeccable timing and a lot of tries to hit the stop button while the page was loading as it would start then go to a black screen. When I finally caught it I clicked on support and it took me there and I bookmarked that.

I did try your link with Chrome, Edge, Firefox and Opera and it works in all browsers. Maybe time to purge the cache, flush DNS and clear browsing history.

Level 7

Hey BamaInArk, I understand the frustration when dealing with support issues, especially with the Asus Z390 ROG Maximus Xi Hero Wifi. It can be maddening when support pages seem elusive. Drawing from my experience, I've encountered similar problems and know how much of a hassle it can be.

In fact, while troubleshooting, I stumbled upon a valuable resource that might interest you: "Mastering WordPress: A 9-Step Guide to Building Your Own Website" Although it's unrelated to your current Asus support challenge, sometimes diversifying your tech knowledge can be a rewarding distraction. Now, back to your Asus issue.

Here's a workaround that might help: try accessing the support pages using a different browser or clearing your cache. Sometimes, these glitches are browser-related. If that doesn't work, shoot Asus support an email explaining the situation. In my experience, they've been surprisingly responsive and helpful.

I had a similar hiccup with a different motherboard, and Asus support guided me through an alternative way to download drivers temporarily. It's worth a shot.

Hope this helps, and fingers crossed you get those drivers and BIOS updates soon! Let me know how it goes.