cancel
Showing results for 
Search instead for 
Did you mean: 

Sonic Studio 3 doesn't do anything

Michaelxv205
Level 8

I have a Z790-H mb and sonic studio EQ doesn't do anything, none of the settings do a single thing. How do I fix it

370 Views
5 REPLIES 5

Jiaszzz_ROG
Customer Service Agent

Hello, @Michaelxv205 

May I ask if the situation you described happened after any changes were made? For example, adjusting the BIOS settings or connecting an external device
What are the current versions of your BIOS, OS, and audio?
If they are not the latest, we recommend updating them and checking again.
Is the equalizer (EQ) adjustment not taking effect, and is this issue occurring with speakers or headsets?
If you remove and reinstall the audio drivers, does it help troubleshoot the problem?
Could you also provide a complete video recording for us to better understand the scenario?

Thank you.

sharing complete hardware info & software config details will help us better understand the issue 🙂

Bios Version 1904

OS : Windows 10 Pro

Audio that I'm currently testing and that has an audio console but SS3 EQ doesn't work so I'm forced to use Equalizer apo + peace as a bad workaround : AUDIO_Realtek_UAD_ASUS_ROG_SS3-DTS_v6.0.9632.1

If you remove and reinstall the audio drivers, does it help troubleshoot the problem - No

Is the equalizer (EQ) adjustment not taking effect, and is this issue occurring with speakers or headsets? - the EQ does not take effect at all regardless if I use headphones or speakers

Could you also provide a complete video recording for us to better understand the scenario? - I would rather you connect to my machine with anydesk or discord or whatever is fine with you so I may show you live 

Jiaszzz_ROG
Customer Service Agent

Hello, @Michaelxv205 

Unfortunately, at the moment, Forum Customer Service Agents are unable to offer remote assistance for troubleshooting. 
Therefore, we rely on you to provide more detailed specifications, scenarios, screenshots of the settings, and scenario videos.

May I ask if you have updated Intel ME to the required version 16.1.30.2307 for BIOS 1904?
The driver version you currently have installed, v6.0.9632.1, seems different from the audio driver version provided on the ROG STRIX Z790-H GAMING WIFI official website for Windows 10. 
We recommend removing it and installing v6.0.9400.1 to check if the issue persists.


If the problem persists, please assist us by providing a comprehensive video recording of the issue, including the connected audio output devices, Sonic Studio 3 settings, scenarios where the equalizer is not working, and the following information:
- the OS build, the images of manually adjuesting items in BIOS, or whether it is the default
- the brand and model name of the GPU, RAM(part number as well), SSD/HDD, and PSU currently installed
Thank you.

sharing complete hardware info & software config details will help us better understand the issue 🙂

The audio driver provided on the Z790-H site doesn't work for SS3 etc. my intelme is up to date. I will provide a video after my eyes stabilize (I got lasik earlier today) I use Windows 10 pro, GPU 4090, Ram 64 GBs, PSU I'm going to replace soon its 1000w plat, SSD is NVME 2tb

Is the Z790-A or H better in terms of audio. I swapped to the MSI Z790 Edge DDR5 and it has issues with loudness equalization and it uses the Alc4080 sound chip. Does the H which I used to have; fix the SS3 Equalizer issue?