Showing results for 
Search instead for 
Did you mean: 


Level 9

So I have an Asus ROG STRIX X670E-E Gaming WIFI Motherboard.
The BIOS updates have been an absolute train wreck.

Current PC Specs:
CPU: Ryzen 9 7950x
RAM: G-Skill Trident Z5 NEO RGB 32GB (2x16GB) (DDR5-6000, F5-6000J3038F16GX2-TZ5NR)(EXPO Compatible)
Motherboard: Asus ROG STRIX X670E-E Gaming WIFI
GPU: Asus RTX 4090 ROG Strix OC

When running the Bios on 0805, Expo works no issues, and computer boots without issue every time.

I attempt to update from Bios 0805 to 0922, no dice.
The computer would refuse to boot and Bios would go into "Safe Mode" whenever EXPO was enabled.
Well, I'm not leaving performance on the table.

I then back date the Bios back to 0805; EXPO works, no issues.

I see Bios 0925 is released, and decide to take the plunge again.
Again, no dice.... Really ASUS! This is getting annoying!
Still the same EXPO issue, when EXPO is enabled, computer refuses to boot, and Bios would go into "Safe Mode".
So again, i backdate the Bios to 0805, enable EXPO, I am stable, and boot every time.

This has happened for every BIOS released up till the day of this forum post. (8/29/2023)

So this is where I URGE for ASUS to get their support together.
You have a great platform and performance, but these BIOS blunders; from RAM that you explicitly say is compatible.


Customer Service Agent

Hello, @Ingbo 

May I ask how you confirmed BIOS version 0922? According to the official website for the ROG STRIX X670E-E GAMING WIFI, the latest version is 1602, and there is no version 0922 listed.

We would recommend updating to the version released on the official website.
After clearing the CMOS and successfully entering the system, proceed to test other custom settings.

Thank you.

The older BIOS numbers that i have listed are from previous BIOSs that "were" listed on ASUSs website but have since been pulled due to reasons...

The list of BIOS's that i have tried and that have failed are as follows:
0705 - EXPO Works -  No longer on ASUS site
0805- EXPO Works -  No longer on ASUS site
0922 - EXPO Doesn't work -  No longer on ASUS site
0925 - EXPO Doesn't work -  No longer on ASUS site
1101 - EXPO Doesn't work -  No longer on ASUS site
1202 - EXPO Doesn't work -  No longer on ASUS site
1416 - EXPO Doesn't work
1516 - EXPO Doesn't work
1602 - EXPO Doesn't work

I have been trying all these BIOSs and still no resolution.
It's very frustrating.
Enabling EXPO is a 1 button press and confirmation on the main UEFI BIOS screen, and nothing else.
But it fails to post every time when enabled.
No, i will not add extra voltage to my ram to try and get a post on a setting that should be enabled from the factory, and set in the EXPO settings.
This platform and setup was advertised to consumers as a quick and easy way to enable an overclock, EXPO.

Something changed after the 0805 BIOS, and ASUS refuses to listen to the other users on the forum.
@Jiaszzz_ROG you even answered some of my comments on other posts in the past, and this went no where.
So to expect a different outcome is not expected at this point. But i'm still trying.

Customer Service Agent

Hello, @Ingbo 

To further address the issue you are encountering, could you please confirm which slot your RAM is installed in?

If you install a single module in the DIMM_A2 slot, does it also result in an inability to boot properly after enabling EXPO?
Could you clarify if the "EXPO" you mentioned refers to EXPO I or EXPO II?
Does the system boot correctly into the default settings?
Please also confirm the following questions:
- the images of the setting in BIOS
- the brand and model name of the PSU currently installed
- the OS version and OS build

Thank you.

Hello @Jiaszzz_ROG 

Here is the answers to the questions you asked for.
Ram is installed in A2 and B2, as shown in the middle photo you provided.

I did test installing a single DIMM into slot A2 to test, and got very inconsistent POST results when EXPO was enabled on BIOS 1602. This was the same result for the second DIMM i have for this RAM kit.

Photo for reference for the testing.
23-09-05 12-39-14 1893.jpg

Images of BIOS settings:
23-09-05 12-34-20 1889.jpg23-09-05 12-34-32 1890.jpg23-09-05 12-34-48 1891.jpg
This is where i would change from EXPO I to EXPO II or EXPO Tweaked.

The PSU is a Corsair HX1200

The Windows Version is:
Windows 10
Version 22H2 (OS Build 19045.3324)

Here is my memory kit for reference:
23-09-05 13-19-36 1894.jpg

P.S. I also called G Skill Technical Support today, and they stated over the phone that if everything works fine in the 0805 BIOS, then the motherboard BIOS is to blame, not the RAM.


Customer Service Agent

Hello, @Ingbo 

We appreciate the detailed information you provided. However, based on the information in this thread, it seems that we haven't confirmed which setting of the Ai Overclock tuner resulted in the boot issue.
Please assist us in confirming the results for EXPO I, EXPO II, and EXPO Tweaked settings, especially verifying if the system can successfully boot into the OS under the EXPO I setting.

Thank you.

Hi @Jiaszzz_ROG 

All 3 settings failed to boot with EXPO I, EXPO II, and EXPO Tweaked.

The system can not boot with any EXPO settings on any BIOS newer than 0805.

P.S. I also had a ticket open with ASUS support on this exact issue months ago, but it was closed due to no progress, and lack of support on my issue. Asus Service no=N2304002291


Level 8

Can confirm everything OP wrote.

All BIOS versions since 0805 are pure trash. Don’t even know why Support calls out on that. Forums have 100s of threads, Reddit is full of pure hate for that and Asus as a company, exactly cause Asus isn’t transparent with that topic.
Why are Asus support employees still trying to trivialize that topic or asking repetitive the same old questions?

Everyone knows this is Asus‘ major fault, it is proven. Facts. 

Yeah, thanks for that.
No response only hurts them more.
Last time i will buy any ASUS product, and i'm still a young customer. They may have lost me for life, and future friends builds.

Also, i had a ticket open with support, but it was closed, because it was "Validated on ASUS's end, that it worked...."

The ASUS ticket number, ASUS Service No=N2304002291

@Jiaszzz_ROG  This ticket has all the same information.
This is an ASUS problem... Not a customer or hardware problem.
Your customers spent a lot of money on this issue, to get shrugged off, and ignored.

At one point during the conversation on the ASUS ticket, I even asked for a refund, to which i was told all they could do was an RMA, and i would have to wait 3-4 weeks for the repair shop to look and diagnose the board.
That's unacceptable.

Super Moderator


EXPO I and EXPO Tweaked. Replication was tried with 0922 and 1602 fully memtest stable
(DDR5-6000, F5-6000J3038F16GX2-TZ5NR)


@Ingbo please be sure to try the CMO file I've sent you, too.

13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090