cancel
Showing results for 
Search instead for 
Did you mean: 

ROG STRIX X670E-E GAMING LAN Port Issue

reypele
Level 8

I have a 2GB internet connection (fiber). My PC (ROG STRIX X670E-E GAMING WIFI MB) is connected to my router's 10 GB port (ROG Rapture GT-AXE16000). When doing speed testing, the download speed is 1GB, but the upload speed is 2GB. if I do the speed test from the router using the phone app, I get 2 and 2. This is telling me there is no issue on the ISP side.

Windows 11 reports the Link Speed (Rx/TX) as 2500/2500 Mbps. This indicates that the LAN port negotiated with the router the maximum speed the port can achieve.  The driver version is 2.1.3.3, and I am using the driver provided by ASUS. 
I have uninstalled the drivers and re-installed it, but no joy.

BIOS is the latest , 1807.

ROG STRIX X670E-E GAMING
32 GB RAM
AMD Ryzen 9 7900X
AMD Radeon RX 6000

 

 

371 Views
5 REPLIES 5

Jiaszzz_ROG
Customer Service Agent

Hello, @reypele 

May I ask if the situation you described happened after any changes were made? For example, updating the BIOS or connecting an external device
How did you confirm the link speed, and could you provide relevant screenshots?
Have you tested with other wired devices or different LAN cables?
When checking the network speed, what color are the LED indications on your Intel 2.5Gb Ethernet port?


We recommend referring to [Motherboard] How to fix the cable network problems of Motherboard for troubleshooting steps.

Thank you.

sharing complete hardware info & software config details will help us better understand the issue 🙂

@Jiaszzz_ROG, thanks for the reply. Here are the answers to your questions.

I don't have any connectivity issues. The computer connects to the internet without any issues. The problem is the speed. When I had 1GB symmetrical, I could download and upload 1GB without issues. Three weeks ago, I upgraded my service to 2GB symmetrical. After the speed testing, I got a 1GB download and a 2GB upload.
The article you posted does not apply to my problem since I have internet connectivity.

(1) Windows is reporting the link speed as 2500/2500 (first screenshot)
(2) The router speed utility is reporting 1.8G/2GB (Download/Upload)
(3) The speed LED is green, which means it is a 2.5 Gbps connection.
(4) Speed test reports 1GB download, 2GB upload. Any other utility reports about the same.
I change the setting for the NIC from Auto to 2.5 GB speed. The same result was when running the speed test.
At this moment, I don't know if it is a hardware issue, a driver issue, or an application issue. I doubt it is an application because all the utilities show the same result. Possibly, it is a driver issue, and I need to set up the NIC in a special way, but I get the right upload speed. Hardware  issue, may be.
Screenshot 2024-01-23 230500.png

Screenshot_20240123_225427_ASUS Router.jpg

1000022913.jpg

Screenshot 2024-01-23 231209.png

Jiaszzz_ROG
Customer Service Agent

Hello, @reypele 

The speed (Mbps) and data volume (GB) are different metrics and cannot be directly converted.
Network speed typically represents the transfer rate per second, while data volume indicates the total amount of data transferred.
May I inquire if connecting the LAN directly to the modem can achieve the full 2.5Gbps?
If needed, we recommend attempting cross-testing with other higher-spec LAN cables, as it can also impact the transmission speed.

Thank you.

sharing complete hardware info & software config details will help us better understand the issue 🙂

I should have said Gbps, but I believe you understood that. My cable is CAT 7. I connected my computer directly to the router and got the same result.  But I think you are missing that the upload speed is 2 Gbps, which tells me there is nothing wrong with the cable or router since it is achieving the speed the ISP gives me.
I would need to check how to test my PC directly connected to the modem since they are not too close to each other.

Finally, I was able to test with a Live Linux distro. I wanted to rule out a hardware issue. I created a USB with a Linux Distro and ran Speedtest. The speed was 2 Gbps download/upload !!! So, the NIC is OK. There is a problem with either Windows or the NIC drivers. I have the latest drivers from Asus. 

20240130_230731.jpg