Showing results for 
Search instead for 
Did you mean: 

ROG STRIX X670E-A GAMING WIFI - EXPO not working on newer bioses after 0805

Level 8

I know there are plenty of posts around this topic, mostly focused on non Strix motherboards but the chipset is the same. After upgrading from 0805 to 0922, 0925, 1003 beta and 1004 (with some other betas in the middle), EXPO does NOT work. It won't boot and will go into failsafe mode. Literally, flash bios, load optimized defaults, boot to windows, all good. Reboot, enable EXPO 1 or 2 or "Tweaked", nothing else, won't post and will go into bios "recovery mode" or whatever it's called.

Tried both Gskill 6000 and Kingston 6000 memories with different timings.

When is this going to be fixed? None of my colleagues with MSI nor Gigabyte boards experience such issues (besides some minor things when tweaking curves and whatnot).

Maybe too much time is being spent on writing "ROG ROG ROG ROG " and "for those who dare for those who dare for those who dare " on the motherboards instead of issuing working UEFI firmwares.

Thank you for your attention.


Customer Service Agent

Hello, @kennycoder .

Please make sure your memory, including the Gskill 6000 and Kingston 6000, is listed on the QVL list and installed in DIMM_A2 and B2 slots.
It is not recommended that you use memory from different kits, and please install a single memory module in the DIMM_A2 slot for testing.
Please refer to [Motherboard]How to optimize the Memory performance by setting EXPO in BIOS? for details.

If the above still fails to set EXPO successfully, please confirm the question below.
- the current BIOS version and the image of the content of the setting in BIOS (or whether it is the default)
- the serial numbers of your motherboard and GPU via pm
- the brand and model name of the CPU, DRAM (and memory part number as in the QVL list), GPU, and PSU currently installed
- the OS version and OS build

Thank you.

Level 8

Hi Jiaszzz_ROG. Appreciate your answer.

Current UEFI that is working without issues is 0805. Every other version after it do not want to work with expo enabled. By lurking this forum together with and reddit, it's a common issue across many customers of x670e motherboards from Asus.

Kingston memory is not on QVL, but G-Skill is. QVL doesn't really matter to be honest, just because someone from your side tested it for 10 minutes and put it on the list, doesn't invaidate other modules as non-working with EXPO/XMP since the dies are coming from the same manufacturers, same goes for ddr5 controllers. This is precisely why I'm writing that even G-skill that is on QVL is not working.

Regarding mixing memory, obviously I do not do that, I mean I tried various kits separately, not mixing them at all, and yes, they are in A2/B2 slots.

CPU in question is Ryzen 7900X. This particuklar cpu and both ddr5 modules I mentioned work fine on MSI Carbon X670e on all available firmwares with EXPO enabled fyi.

OS and OS build don't matter, please read the original message. BIOS doesn't post with EXPO enabled, it's not a stability issue.

S/N will be provided via PM.

I'm having the same issue. I've tried two different kits of the same Gskill 6000 ram and no luck with either set running at expo I/II or tweaked. I've done all the "have you tried" too and it's getting quite frustrating.

Level 8

Aight, after countless hours I found a solution for my problem. EXPO is not working, however I loaded the SK hynix profile for ddr5-6200 (2x32gb) @ 1.4v. It's in the advanced memory settings. This put the factory timings for the die that I have (or at least close to that).

After that I set memory manually to 5600, tested, worked, then 6000, tested, worked and even pushed higher than my official expo/xmp spec to 6200. All stable with better timing (32-38-38).

The memory in question is Kingston Fury 2x32GB (KF560C36BBEK2-64).

Hope this helps someone.

I have a B650 E-E Gaming WiFi with ryzen 7 7700x and 1x 32Gb Kingston Fury 6000mhz (KF560C36BBE-32)

Can only get to autodetect 4800mhz and not 6000mhz.

Im godnat try your solution and see if it works.

Level 7

EXPO working with X670E-A !! 

I’ve been trying to get my EXPO working for many months on and off everytime a new bios release is set to the public. Even tried replacing RAM, tried diff RAM vendors, read endless threads and posts with settings to try with no success. My setup is Asus X670e-a 1007a , EVGA 3080ti, 7700X, Nvme980, and with numerous trips to MicroCenter testing out many RAM kits on the tested approved list to find it did not work. The only post from the system was at the RAM 4800.

I found a post on a German forum that I couldn’t really read but understood the setting FCLK and variations under 2000-2033 mhz. I thought sure, nothing to loose trying this setting.

Reset my bios once again,

I manually changed FLCK to 1600 mhz and changed the memory frequency to DDR5-5200 mhz save - reboot and I couldn’t believe my system posted boot!

The BIOS registered 5200 MHZ RAM - no way!!

Then I went back into the bios settings and changed FLCK to 1800 & DDR5 5800 save and reboot and it posted again! I was in disbelief it had never posted at any point higher than DDR5-4800mhz or using the Auto settings.

Finally went for the 6000mhz by

FLCK 2000mhz -DDR 6000 but the system did NOT post boot.

I reversed engineered from here by reset the bios again.

Tried FLCK 1900 mhz and DDR5-6000 and it posted! finally

Went back into the bios and tried FCLK 1933 MHz 

It posted again!

Went back into the bios once again and tried the next number higher than the previous example FCLK 1967 mhz and it did NOT post.

I reset the bios and left it at FCLK 1933 mhz with Memory Frequency manually set to DDR5-6000 and wala it finally boots after months and months of expo failure testing out RAM found on the compatibility list. 

The WIN 10 OS boots ran tm5 Ram testing and passes also Win10 displays 6000mhz for RAM.

I even went back into the bios and tried Expo, expo II, and expo tweaked and they work! The key was manually setting the FLCK instead of depending on the "Auto" setting. It was my issue the entire time over trying all the bios versions out there for this ASUS motherboard. BTW my bios is the latest 1415 and did go back into the bios and set fastboot disabled, integrated graphics to disabled, and even turned on AI OC and everything is working.

At the very end,  I reinstalled my original DD5 GSkill f5-6000-J3636F16GX2-FX5 (not on the compatibility list) and it too booted as well. Even tested the 6000J302X32Z5NR and those posted boot as well.

Hope this helps someone out there.