Showing results for 
Search instead for 
Did you mean: 

ROG STRIX B650E-E USB 3.2 Gen 2 Ports Not Working "Unknown USB Device (Port Reset Failed)" Code 43

Level 8


Well Like Many Others with the 7800x3d My ROG STRIX B650E-E USB 3.2 Gen 2 Ports are Not Working "Unknown USB Device (Port Reset Failed)" Code 43 appears when any Device is Plugged into the ports in this picture

USB 3.2 Ports Not WorkingUSB 3.2 Ports Not Working

So Motherboard Purchased on 21st November 2023 -  Updated to Bios ROG STRIX B650E-E GAMING WIFI BIOS 1813 when I Built Computer and all up and running correctly on Windows 11. All Ports Worked

Then around 6th January the Stopped Working.

I have tried all the things mentioned - Uninstalled all USB Drivers Etc etc Reset Bios to Default Cleared CMOS etc etc and also Upgraded the New 4th Jan 2024 Bios "ROG STRIX B650E-E GAMING WIFI BIOS 2214" But I am at a loss now as if anything plugs into those ports nothing happens then on reboot I will get the "Unknown USB Device (Port Reset Failed)" Code 43 in Device Manager.

Yes I do have 2 x USB 3.2 Ports working and the 2 x USB C ports work but with such an expensive motherboard we expect everything to work.

I take it as Amazon have asked to Contact Support any replacement request will have to go through ASUS Support Direct?


Customer Service Agent

Hello, @Richie91 

May I ask if there have been any sudden power outages or short circuits since the issue occurred?
Is it only during a reboot that the four USB 3.2 Gen 2 Type-A slots are unable to recognize USB devices?
If you adjust the setting for USB power delivery in the Soft Off state to [Enabled] in BIOS under Advanced Mode > Advanced > Onboard Devices Configuration, can this potentially resolve the issue?

Additionally, have you contacted the original place of purchase (Amazon) to arrange for further repairs?
If so, we recommend relying on the assistance provided by the dealer.

Thank you.

sharing complete hardware info & software config details will help us better understand the issue 🙂

Hi There, sadly not solved, It was in the (Enabled) State and tried ON/OFF a few days ago and did so again with Soft of State disabled then back enabled again. The 4 x USB 3.2 ports do not work with anything - Usb Drives/mice/controllers. The "Unknown USB Device (Port Reset Failed)" Code 43 comes up then I uninstall then happens every time.

So will now have to try and get replacement and will try Amazon 1st before ASUS.

Thank You.

Level 8

So Went and Returned the 1st ROG STRIX B650E-E GAMING WIFI as Amazon agreed to do so and replaced it with exact same model but is 7 months newer manufacter date and was really easy to just transplant out and put new one in without reinstalling windows and all USB's have been working perfectly as expected. Amazon have processed refund for me now so all has ended well although lots of time and energy spent on it. New Mobo been working perfectly Since 25th January.