Showing results for 
Search instead for 
Did you mean: 

ROG Maximus Z790 Hero - DDR5 128GB Memory Qcode 53 after restart (BIOS? 0904)

Level 7


I'm using 4x32 DDR5 6000mhz GSKILL memory (5400mhz without problems in xmp mode) with my Asus z790 maximus hero motherboard. I sometimes get QCODE 53 after resetting the computer. This does not happen on every restart. I also tried many of the XMP options, but without success. There are no errors when running in Windows.

Have you encountered a similar problem? Is there anyone from Asus executives who can help on the issue? Should I completely change the brand of ram?

Asus has a product line that is really a headache even at the highest level.
Thanks for your help.

Here's what I've tried to fix this issue.
1. Turning off fast boot
2. XMP on and off (no memtest issues in both cases. 0 errors)
3. Increasing the memory voltage from 1.4 to 1.43
4. Replacing with ram with different latency (I changed from 30 to 32)
5. CMOS reset and return to default settings.

ROG Maximus z790 Hero (0904 bios)
i9-13900ks stock settings + Corsair H150 water cooling
4 x 32GB DDR5 6000mhz F5-6000J3238G32GX2-TZ5RK Gskill (available in QVL list)
1 x Samsung 990 Pro 2TB


Level 9

They blocked me in the other publication, it doesn't let me write anymore, I don't know why.

These are my components:

I9 12900K

3090 EVGA

1200W Corsair Shift

4TB M.2 Samsung 980

32 RAM G.Skill 6400

Bios  (0904 bios)

Asus Z790 Hero

Level 9

Did you update the problem?

Super Moderator



Mixing and combining memory kits is not recommended. Kits are binned by the vendors in the density in which they are sold. Your best option is to return one or both of the kits and purchase a signal kit at the desired density and speed from the motherboards memory QVL. Alternatively you can try to tune manually, however, there are no assurances on which timings, voltage and frequency you will find stability.

13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

Level 7

Hi AlSa, I think I found the problem. I replaced new memory with Kingston Fury Beast RGB KF552C40BBAK2/64 64GB. (4x32gb) The problem has not recurred in the last 2 days. I had previously replaced Gskill with another Gskill with a different latency and it did not fix it.

Silent_Scone, thank you for your answer. I tried what you said. The problem persists as 2x32gb from the same series.  2x32 F5-6000J3238G32GX2-TZ5RK Gskill available in QVL list.

After Kingston I realized that Gskill was getting too hot. For those who have the same problem, a small fan may be good for testing. I will never buy Gskill again.

If there is no problem in Kingston for a few more days, I will make sure that Asus has a problem with Gskill compatibilities.

4x32 ARE 128 not 64 I already got confused.

The good thing is that the problem was solved, I bought some new ones in the Hot Sale now I don't have money but keep me posted to find out if the problem was the ram thanks.

I bought 2 kit (2x32gb) 🙂

If there is a problem again, I will definitely write here.

How often are the new ones you bought? 5200? 

I bought it 2 days ago and I've been testing it non-stop.

Hello, good morning, any update, everything continues to work perfectly for today, buy some new ram..