Showing results for 
Search instead for 
Did you mean: 

ROG Maximus Z790 Hero code 99 intermittently over this year, and constantly recently

Level 7

Hi all,

I've seen a few threads on this exact issue but none have come to a conclusion other than some people's randolmly working and the thread stops in its tracks. So starting another for my particular circumstances.

This system was newly bought and put together at the start of 2023. It worked for a few months and then when I went to change power points due to moving my desk, the code 99 started. At first it took a full BIOS reset to come right and I also reinstalled Windows 11 at the same time for good measure. After that it was stable for a few weeks, then randomly it would do the same code 99 first thing in the morning after being turned off for the night. It has continued to do this intermittently throughout the year, and it has taken multiple CMOS clears and reboots to get it working. Sometimes it takes 2 CMOS clears and reboot cycles to come good, others it takes 30+, completely random and I have no idea what is causing it.

Finally took the whole thing apart today as it is now not getting past the code 99 no matter what I do. Disconnecting individual hardware components to see if I can pinpoint the issue. I also recorded most attempts.

1 - No GPU, monitor plugged in to MB via HDMI - Worked first thing. POSTed and I could enter the BIOS
2 - Moved PSU power to another plug in the room via extension cord. Same setup as above - Success and I could enter BIOS
3 - Same setup now with GPU pluged in. HDMI plugged in to GPU - Code 99
4 - Same setup with GPU plugged in, but moved the HDMI to the MB - Code 99
5 - Removed GPU, left power cables in PSU, HDMI in MB - Code 99
6 - Removed GPU PSU cables, HDMI in MB, Same setup as attempt 1 - Code 99
7 - Same setup as previous step but removed the USB passthrough from my keyboard cable. only keyboard and mouse USB plugged in - Code 99
8 - Kept the system on and tried clearing CMOS via the MB IO button, unplugged PSU power, plugged back in and powered on - Code 99
9 - Tried the same steps again clearing CMOS as this has worked in the past - Code 99
10 - Removed all but 1 stick of RAM - Code 99
11 - Switched between all 4 sticks that I use (64GB total) and all resulted in code 99 individually


I also tried the GPU in another PCI slot. Same result. 

The monitor, keyboard and mouse I used in the above tests are different to my normal setup, so the same results with different peripherals.

As I can't get the system to POST most of the time I have not managed to do memory testing of the sticks recently. I did when I fist bought them and all was fine.

I'm going absolutely nuts with this setup. Most expensive build I've ever done and is the most troublesome by far. Any help would be greatly appreciated.

- Fractal Design Define 7 XL Black
- ASUS ROG Maximus Z790 Hero Motherboard
- Intel Core i9 13900K CPU
- Corsair iCUE H170i Elite 420mm LCD Display Liquid CPU Cooler
- Corsair Vengeance RGB 64GB (4x16GB) 6600MHz CL32 DDR5
- Samsung 990 PRO M.2 NVMe SSD 2TB (x2)
- Corsair AX1600i Titanium Modular 1600W Power Supply
- Gigabyte GeForce RTX 4090 Aorus Xtreme Waterforce 24GB
- ASUS ROG Swift PG42UQ 4K UHD 138Hz OLED 41.5in Monitor
- Microsoft Windows 11 Home
- Logitech G915 Lightspeed RGB Mechanical Keyboard GL Linear
- Logitech G903 Hero Lightspeed Wireless Gaming Mouse

Setup taken apart on desk:


Level 7

I was going to keep this thread up for a while to see if there are any recommendations that could help, but in my troubleshooting the AIO CPU cooler screw snapped clean off while replacing thermal paste xD so now have requested for warranty claim on both the CPU cooler and motherboard, so going back to PCCG. Will update here how it goes I guess...

Customer Service Agent

Hello, @Roggernator 

May I inquire about your BIOS version?
If you haven't updated to the latest BIOS version 1501 yet, we would recommend considering an update and clearing CMOS afterward to reevaluate.
In the troubleshooting process you've described, have you attempted cross-testing with a different GPU? Were SSDs installed in all the scenarios mentioned?
Additionally, could you confirm whether you have initiated a repair process?

Thank you.

Hi Jiaszzz,

I did have the 1501 BIOS yes, and the issue persisted across version I want to say 130X (maybe 1303) which it shipped with, to 140X and also 1501 just before I made this thread. Saying X there as I can't remember exactly what version, but it was across all of those builds.

I did try clearing CMOS multiple times, and this was often the only way to get around the issue, at least initially.

I did not have a spare GPU to test with however the issue occurred with or without a the 4090 plugged in.

I did not try and alternative SSD.

I did apply for PCCG warranty, so it is now on it's way to them along with the CPU cooler which had a screw fail.

Customer Service Agent

Hello, @Roggernator 

Thank you for your response.
Since you have already submitted it for repair, we recommend that you wait for the repair center's subsequent diagnosis or further assistance.
If you encounter any difficulties or concerns, please feel free to send me a PM with the RMA number or detailed context at any time.

Thank you.