Showing results for 
Search instead for 
Did you mean: 

ROG Maximus Z690 Formula

Level 8

Hello all, need some help with my son's new computer.  He purchased some very high-end parts but we can not get this thing to post. 

  • Mobo: ROG Maximus Z690 Formula (BIOS 2305)
  • CPU: i7-13700K
  • Heatpump: NZXT Kraken Z73
  • Memory: Corsair Dominator 32GB (2x16) DDR5 5600MHz
  • Video Card: ROG Strix RTX3090 24G
  • Power Supply: Phanteks AMP 1000
  • Drive: NVMe Samsung 980 Pro (1TB)

When we power on the computer the LCD scrolls through multiple codes but ends up with Memory Code: 00 and CPU code: 00, which tells me they should be good, at least from what I am reading.  However we never get signal to the connected monitor. I have tried the following troubleshooting steps:

  • moved video card to secondary PCIe slot
  • swapped memory between slots in pairs and single
  • tried 3 other videocards
  • CMOS reset
  • Flashback update of BIOS
  • reseated CPU and heatpump with new thermal paste.
  • moved the NVMe drive between slots.
  • Tried different monitor

We never got the monitor to respond.  I would appreciate all suggestions anyone could provide.  I would provide a video of the q-code LCD is that would be useful.




Level 8

Upon further reading I have now changed out the CMOS Battery and removed all M.2 drives and still no post.

Customer Service Agent

Hello, @PLBarton 

Based on your description, we are quite uncertain about after "LCD scrolls through multiple codes" but "we never get signal."
Could you please clarify if there is no display after the power-on self-test process?
Are you able to enter the BIOS after booting?
Additionally, may I know if you have already installed Windows on your system?

Thank you.

The system never completed POST.  It never even powered up the attached monitor.  Since I posted this I have worked with Asus support and actually purchased a replacement CPU and Memory and still the Q-Code LCD showed CPU code: 00 which the tech told me means the motherboard does not detect the CPU.  I have initiated an RMA and have already shipped the board off.  I will post a follow-up once I get the replacement board and let you know if that fixed my issue.