cancel
Showing results for 
Search instead for 
Did you mean: 

ROG Crosshair X670E Hero - Bios Fiasco

Akninja2432
Level 7

TIA,

I have an X670E that I recently made the mistake of upgrading to the latest bios (2007 rel 4/12/2024).  I have attached some pics of the specs, but I have a 4080 Nvidia GPU.  Directly after the bios update, I could barely boot into windows, and it would almost immediately crash with a video schedular error.  I couldn't even get it stable in safe mode.  Messed around for a couple of days with bios, then decided to do a clean install.  Everything booted up and ran fine until I started installing drivers.  Once I installed the latest GPU drivers, my troubles started again with crashing, stuttering, BOD on boot into windows.   Tried to use DDU but it wasn't stable enough, so I did another fresh install.  I installed an older version of GPU drivers (537.58) without GeforceExperience.  System is stable and doesn't crash, however GPU performance is absolute garbage.  Scored a 309 on 3dmark.  Can't game at all, get 10fps.  Something is still very wrong.  Running latest chipset drivers from armory.IMG_0590.jpgIMG_0591.jpgIMG_0592.jpgIMG_0593.jpgIMG_0595.jpgIMG_0596.jpgIMG_0597.jpgIMG_0598.jpgIMG_0599.jpgIMG_0600.jpg

I have tried D.O.C.P off and on.  Currently on Auto - No change

Fast boot is disabled in bios and windows - No change

Power saver is set to high performance and PCIE power management is off in windows - no change

Intergrated graphics is disable in bios - no change

Ram frequency is set to 5200 - no change

188 Views
1 REPLY 1

Jiaszzz_ROG
Customer Service Agent

Hello, @Akninja2432 

Could you please clarify the BIOS version you were using before updating to BIOS 2007, and whether the described issues didn't occur with that version?
If you update version 2007 once again, which was released on April 18, 2024, and clear CMOS, do the instability and BSOD issues still occur when booting into the system with default BIOS settings?

According to your description, it seems that the problem occurred after installing the GPU driver.
Could you please specify the model of ASUS RTX4080 GPU you are using and whether you installed the driver version from the official website?
Also, which slot is the GPU installed in, and is it connected through an adapter or extension cable?
Have you cross-tested other slots to see if the problem persists?

Thank you.

sharing complete hardware info & software config details will help us better understand the issue 🙂