cancel
Showing results for 
Search instead for 
Did you mean: 

ROG Crosshair Hero x760e dual raid array, can't install windows

d4har
Level 7

Hey all,

First off, I've opened a ticket with Asus on this in parallel.

I have the x670e and I have 4 m.2 drives, each 2tb.  The first set are gen 5 and are installed on m2_1 and m2_2, the second set are gen4 and installed on m2_3 and m2_4.  

I'm running bios 1807 (though I'm just about to roll back the bios to 1709 in an attempt at troubleshooting) and I have 64 gigs installed running at the default speed (will adjust this later once the raid is working)

I want to dual boot two versions of windows (one for gaming and one for work).  

So, I've tried to create two Raid 0 Arrays.  The creation of the arrays is fine and works.  I then proceed to install windows on the Gen5 array, I load in the drivers on install (rcbottom, rcraid, and rcconfig).  I can see both arrays in the windows install.

I then proceed to install windows on the Gen 5 array and it works.  I then repeat the process to install windows on the Gen 4 array and it takes an extraordinarily long time to setup the directories (automated by win 11) and then starts copying files.  It hits anything between 1 - 5% completion in copying and then triggers a failure to copy files and the install fails.

I have tried the following to troubleshoot:

1) reversing the install order (Gen 4 and then Gen 5) and I get the same error except now on the Gen 5 drives.

2) removing one of the Gen 4 drives and making it "Raidable", same error

3) making the Gen 4 drive a JBOD, same error

4) set the PCIE_X1 to PCIE Raid mode, same error

5) set the PCIE_X2 to PCIE Raid mode, same error

6) changed the gen 4 drivers to a new set and repeated the above steps, same error

7) turned off all raid and gone back to just normal install, I can install on all the drives (including the drives from step (6)

I cant see any further options to try -- hence my reach out... anyone have any ideas or have run into a similar problem?

I'm starting to think that either the raid driver is defective, you can't dual boot this board using raid, or my motherboard is defective...

What do you think ??

Thanks (and Happy Holidays!)

D

300 Views
8 REPLIES 8

d4har
Level 7

bios 1709 - same issue persists

d4har
Level 7

have tried installing with two JBODs (gen 5 set and gen 4 set) and no luck.  It seems that the raid can only have one windows installation for some reason.  Will now wait for official Asus answer to decide if there is a fix or if I just return the board.

I must say -- super disappointed with the whole AMD and x670e experience  .... unfortunately I'm locked in and can only return the board... so lets see if I stay asus or move to another brand....

Jiaszzz_ROG
Customer Service Agent

Hello, @d4har 

Could you please confirm if the current motherboard model you are using is the ROG CROSSHAIR X670E HERO or ROG Crosshair X670E Extreme?
According to your current situation, you have successfully configured two sets of RAID 0 and installed Windows on the Gen 5 RAID 0, but failed to install Windows on the Gen 4 RAID 0.
We suggest trying to first format the Gen 4 RAID 0, then ghost the Gen 5 RAID 0 system (disk-to-disk copying) to the Gen 4 RAID 0.
After completion, you can activate the header of the Gen 4 RAID 0 disk to achieve a dual-system architecture.

Thank you.

Thanks very much for the help.  Can you advise or drop a link on how to activate the header for gen4 (I presume you mean that I have this added to the UEFI boot record) ?

thanks

D

Jiaszzz_ROG
Customer Service Agent

Hello, @d4har 

May I inquire about the current model, whether you have completed the steps for disk-to-disk copying, and were you able to successfully boot and select the system disk?
Could you please provide photos of the current steps and any issues you encountered?

Thank you.

Hello, @Jiaszzz_ROG 

I tried the process with the disk to disk copy and then to edit the boot setup.  I managed to get the system to boot.  However, after a few minutes the system would slow down and become very sluggish, then freeze, blue screen, and reboot.  I tried a few different methods to setup the boot to see if maybe I had made an error there - but it was all fine and everyone method produced the same outcome.  In the end, I had a confirmation that you can only boot one raid partition; this is directly in AMD's raid instructions -- so ultimately I was asking for something it cannot do.  In the end, I created one large array using my Gen5 and Gen4 drives and I have installed two Windows 11 images on that.  This setup is running fine and I will look at a better drive setup later on.

Thanks for your help and all the best!

Cocomocho
Level 8

Hello good morning, it is a generalized problem due to RAID drivers. If you mount a RAID for Windows boot, it will not boot, but if you install windows on a normal drive, and mount a separate RAID, if you do not run the RaidXpert2 software in the background, all RAID drives you have on motherboard, gives read/write errors even refusing to access the RAID drives. Also at Windows boot time to time you get the blue windows error screen saying that the rcraid.sys file has failed, so you have to do a reset and get past that error. In my case, it happens to me with 4 hard drives connected to the first 2 S-ATA ports of the board which are the ones that have the RAID function and to avoid those errors you have to leave the RaidXpert2 software running in the background. AMD has released updated drivers for the end of 2023, but the problem still exists. These errors are not only from Asus, because it also happens in motherboards from MSI, GigaByte, Asrock... and it is a problem or BUG of the drivers. I was for a while talking to Asus technical service and the only solution they gave me was to manage the warranty of my Crosshair Hero 670E motherboard but I did not do it because I have other X670E motherboards of other brands with the same problem, besides in the community many have the same problem and I'm not the only one. Best regards

Hello, @Cocomocho 

This wasn't the issue that I was having.  I have four NVMe drives and I wanted to have each set (gen5 and gen4) in separate raid arrays.  This isn't possible using AMD's Raid system.  So you can make either a single big array or not use it at all, once you enable Raid for NVMe all the drives have to be added.  You get one array which is can have a bootable windows.

Cheers.