cancel
Showing results for 
Search instead for 
Did you mean: 

Rog B550-F Gaming NVMe Issue

Livealoha
Level 8

I have a current installation Win10 Pro, no issue booting from NVMe Samsung 980 Pro.  I just recently purchased a Crucial P3 Gen3 NVMe for additional storage.  Installed fine, formatted.  Upon reboot, computer take a long time to go through post, then upon launching Windows it reboots.  Upon restart same issue or screen turns blue (not BSOD) just blue. 

Running current BIOS 3607.  Turned off Fastboot, changed setting for m.1-2 to Gen 3.  Boot device ONLY shows my current Samsung Pro980 which is correct.  So purchased another Crucial P3 (exactly the same one) and same issue.  Then, put in a Intel NVMe Gen 3 and same issue.  Also went back to BIOS ver 3405, no change same issue.

When i remove the Crucial NVMe, reboot, no issue, boots fine.  When i put the Crucial back in again, same issue occurs.  There is no crash dump (is it enabled) file. 

Motherboard is 4yrs old. 

225 Views
6 REPLIES 6

achugh
Level 12

Hi @Livealoha have you tried to disable BOTH Fast Boot and LOGO option? See https://rog-forum.asus.com/t5/gaming-motherboards/z790-dark-hero-bios-1302-logo-patch-bsod-with-mult... post of mine.

I am not sure on your motherboard what options do you have for the Boot Configuration. Maybe you can try disabling both if you have both options and see if that helps.

My understanding of the ASUS BIOS is as follows. This is based on assumptions as I have not scientific data or official article to prove otherwise.

ASUS UEFI BIOS prefers NVMe as the preferred device for Windows Installation. Hence, it looks for a boot loader on NVMe device only if one is found. If there are no NVMe devices then it searches for SATA device. This is proven by the behavior you are reporting here. It is for this order or sequence I have installed my Windows 11 on NVMe device as my primary Windows and installed my secondary Windows for testing on a SATA device. You can read about my multi-boot issues in the post I linked.

My recommendation to you would be to do the following:

  1. Make sure you have your NVMe drive connected to your motherboard.
  2. Now do a fresh installation of Windows on this NVMe drive by doing a proper format and deleting every single partition. You can then select this UNPARTITIONED drive in your Windows Installation to let Windows create all the required partitions.
  3. Once your Windows is installed, follow all the driver installations to get to a working system.
  4. At this point you can format your previous SATA drive and use that drive for anything else you would like to do with it.

Hopefully, this will help resolve your issue. Good luck!

Disclaimer: I am not an ASUS support person so my information may be incomplete. Always follow official documentation and material provided by ASUS representatives.

INTEL i9-14900K / CORSAIR VENGEANCE RGB 192GB (4x48GB) 5200 CAS38 / ROG Z790 DARK HERO / ROG TUF GAMING RTX 4090 OC / ProArt PA-602 Case / SEASONIC PRIME TX-1300 ATX 3.0 / CORSAIR MP700 PRO 2TB PCIe Gen5 / CRUCIAL T500 2TB PCIe Gen4 / EIZO CG2700X

Mahalo (thank you), for responding to my inquiry.  Perhaps i wasn't clear, but in my post, I am using an NVMe Samsung 980 Pro, with a working Win10 installation.  i have no other drives with any other installation of windows.  I do have 2 other SATA hard drives, but it does NOT have any windows installation, plus when troubleshooting the issue, I had already disconnected both drives only leaving my NVMe drive.  Again, when i boot, no issues. 

However when i add an additional NVMe Drive (Crucial P3 gen 3), it takes a lot longer to go through the post, then it just reboots.  Sometimes, it begins to load Windows, and reboots, or no loading screen, but the screen is just blue (not BSOD).  As mentioned in my post, i have disabled FAST Boot, and marked m.2-2 as a gen 3 rather than Auto.  Also, the boot loader only finds one device (my NVMe Samsung 980 Pro) to boot to.  When checking the status via the bios, it confirms the Crucial drive is present.  Also, i did the short and long test via the Bios, and checked okay.  

So, when i removed the Crucial NVMe drive, and reboot, no issues whatsoever.  Also, as mentioned in the post, i tried with another Crucial NVMe P3 and same issue and again with an Intel NVMe drive.  Please note all 3 NVMe drives that i attempted to install in the M.2-2 slot was a GPT disk, formatted NTFS, with no data. 

Also, i did not mention this, but i did clone my NVMe Samsung Drive, wiped it, reinstalled Windows 10, updated it, then attempted to add the additional NVMe drive, and again same issue....

Again, Mahalo for taking the time to respond to my inquiry...i appreciate the assistance!

not sure if you read my last post, but no your suggestion did not work...

@Livealoha I have Z790 DARK HERO board. On my board, I have noticed that anytime BIOS detects a hardware change like adding or removing hard disks, memory, GFX card etc. the BIOS goes into an extended device scan which takes exceptionally long time to finish. For me, this only happens once after any device is added or removed. On my board I have Q-CODE which is a 2 digit display where I am shown cryptic codes as to what the motherboard is doing. In an appendix of the user manual a very high level description of these codes is given to me. This is the way I can see what the motherboard is doing. I also have all my memory DIMM slots filled. During this extended scan a quick memory test is done. In my case I have 48Gb stick in each slot for a total of 192GB of DDR5 memory. So the quick memory test is not very quick for me which I can confirm using the Q-Code and LED lights on my board. Your time will also vary depending upon how much memory you have on your board and how many DIMM slots you are using plus how many things in general are connected to your motherboard as everything is being scanned and tested to finish the pre-check.

Can I suggest that you connect all your drives as needed along with anything else you are going to use? Then clearing CMOS using this FAQ. Now reboot and go into BIOS to setup date and time, set your Samsung in M.2_1 as GEN 4 and your Crucial in M.2_2 as GEN 3.  Set any other things you normally set in your BIOS. Because you cleared your BIOS, you may not see any drive listed as bootable and that is fine. Now install Windows on whatever drive you like M.2_1 or M.2_2. Hopefully everything will get resolved and works properly now.

Disclaimer: I am not an ASUS support person so my information may be incomplete. Always follow official documentation and material provided by ASUS representatives.

INTEL i9-14900K / CORSAIR VENGEANCE RGB 192GB (4x48GB) 5200 CAS38 / ROG Z790 DARK HERO / ROG TUF GAMING RTX 4090 OC / ProArt PA-602 Case / SEASONIC PRIME TX-1300 ATX 3.0 / CORSAIR MP700 PRO 2TB PCIe Gen5 / CRUCIAL T500 2TB PCIe Gen4 / EIZO CG2700X

Jiaszzz_ROG
Customer Service Agent

Hello, @Livealoha 

May I ask if you are still experiencing the same issue?
Could you please verify in which M.2 slots the NVMe Samsung 980 Pro and Crucial P3 Gen3 NVMe SSDs are installed and whether the SATA6G_56 port is occupied when M.2_2 is in use?

If you remove the stable NVMe Samsung 980 Pro and install only the Crucial P3 Gen3 NVMe SSD, cross-testing both M.2 slots, can you boot and identify the SSD in BIOS?
We also recommend checking for any SSD-related firmware updates.

Thank you.

sharing complete hardware info & software config details will help us better understand the issue 🙂

Mahalo for your suggstions.  Both NVMe slots works fine with the Samsung Pro 990.  however, with both drives installed, the same issue persists.  The Samsung Pro 990 was installed on the m.2 _1 Gen 4, with the curcial on the m.2_2 Gen 3.  The Crucial was just a data drive, so no OS installed. The system crashes with both drive installed, regardless of what port was used. 

The issue with the Samsung Pro 990 just kept getting worse to bad.  I attempted to reinstall windows on the Samsung and while I could delete all the partitions, it would not allow windows to install, stating issue with system partition. When testing, no bad sectors found.  So, upon talking with Samsung, they have determined that the system partition was\is corrupted, therefore the issue of the post taking a long time was because of that, along with it not booting with the Crucial installed.  The drive was only 5 months old, still under warranty so RMA was created and they also sent me a prepaid label to mail the item to them (awesome Samsung)!!!

So i just cloned my back up system drive to the Crucial NVMe, and I will wait until i get it back.  I will update this post to let everyone know of the status. 

Again, mahalo for your suggestions.  And to all who also commented and offered their suggestions as well.

Stu