cancel
Showing results for 
Search instead for 
Did you mean: 

ROD STRIX 670E-A - WIFI & Bluetooth Drivers will not install, poor operations for USB.

jslimjeff
Level 7

New construction 

See System information posting below. 

No WIFI or Bluetooth operation on all USB ports. BIOS is recent, Bluetooth and WIFI adapters ON in bios. 

When running the .EXE file from driver download the install screen flashes and disappears. When using Device Manager, I see the following:

jslimjeff_0-1716151150978.png

I have tried to manually direct each one of the problemed devices to the appropriate download folder of drivers. After 5 minutes the install stops, and I receive an error that it did not install the driver due to the "timeout being exceeded" I have tried this with different revisions of the driver also. 

Error notes in Event Manager:

Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">

 <System>

 <Provider Name="Application Hang" Guid="{c631c3dc-c676-59e4-2db3-5c0af00f9675}" />

  <EventID>1002</EventID>

  <Version>0</Version>

  <Level>2</Level>

  <Task>101</Task>

  <Opcode>0</Opcode>

  <Keywords>0x8000000000000000</Keywords>

  <TimeCreated SystemTime="2024-05-19T18:07:39.5527199Z" />

  <EventRecordID>6559</EventRecordID>

  <Correlation />

  <Execution ProcessID="3156" ThreadID="19284" />

  <Channel>Application</Channel>

  <Computer>DESKTOP-B7JNLNI</Computer>

  <Security UserID="S-1-5-18" />

  </System>

- <EventData>

  <Data Name="AppName">drvinst.exe</Data>

  <Data Name="AppVersion">10.0.22621.3527</Data>

  <Data Name="ProcessId">0x7cc</Data>

  <Data Name="StartTime">0x1daaa16dfd9977f</Data>

  <Data Name="TerminationTime">4294967295</Data>

  <Data Name="ExeFileName">C:\Windows\System32\drvinst.exe</Data>

  <Data Name="ReportId">25a486f2-2ec4-469a-8373-e55e17fb96b7</Data>

  <Data Name="PackageFullName" />

  <Data Name="PackageRelativeAppId" />

  <Data Name="HangType">Unknown</Data>

  </EventData>

  </Event>

I reset the BIOS CMOS and this did not affect. 

 

I am also having issues with the USB ports not recognizing any of the devices. Power is available and I modified the bios setting for the USB power. 

I also have issues when installing items such as the Armory Crate. It has hung at the same spot:

jslimjeff_1-1716151386564.png

I have also removed and reseated the memory and processor. 

 

95 Views
1 REPLY 1

Jiaszzz_ROG
Customer Service Agent

Hello, @jslimjeff 

Based on your description, we recommend referring to the steps outlined in Troubleshooting - How to fix yellow exclamation mark in Device Manager.
Additionally, please consult the following FAQs for driver installation and troubleshooting:
[Windows 11/10] How to Install Drivers Downloaded from the ASUS Site
Is there any suggestion procedure to install the drivers?
[Windows 11/10] Troubleshooting - USB Functionality Issues
Regarding Armoury Crate, are you currently unable to complete the installation process?
If so, after following the troubleshooting steps mentioned above, could you successfully install Armoury Crate upon retrying?
For further guidance, please refer to [ASUS Armoury Crate] Armoury Crate FAQ.

Thank you.

Due to the ongoing regional holidays, my responses may be slightly delayed.
Thank you in advance for your patience.‌‌‌‌ 🙂