Showing results for 
Search instead for 
Did you mean: 


Level 12

sorry i cant really help with your issue as i dont know much about audio but i found

"I definitely want to speak with an ASUS representative to address the products I use from the ASUS brand."

extremely funny and karen like.

as the post above states check that those are indeed correct. if your still having issues then i would contact ASUS support directly....that would give you an ASUS representative 


Level 9

Do you know where the right place is?

In Discord I don't think they solve this problem.

Definitely, the more you believe that by having ASUS products you are free of problems, it is the opposite, you have some problems that become annoying because between that is what you use the computer on a daily basis and there are no answers or solutions.

Warryor 3D

Level 9

Hi everyone,

Previously, I used the X570S Dark Hero and Z790 Hero motherboards.

But now I am using the Z790 Dark Hero, and the only way to make myself understood is by demonstrating in this video how the sound is heard.

I use Logitech Z906 with an OPTICAL output (ALWAYS) and you should know that when a video file has high fidelity sound, the Logitech Z906 automatically detects it as DECODE sound.

With the previous motherboards, I never experienced what you hear in the video when playing DECODE sound, but now with the Z790 DARK HERO, I am facing this problem, which disappoints me about the brand. When you get a TOP OF THE LINE product, you believe you won't have headaches. Unfortunately, in this case, I have many headaches due to ASUS products presenting inconsistency, both the motherboard and the video card.

Furthermore, I can no longer enable spatial sound on my headphones. With the previous motherboards, I was able to set the sound to DOLBY or DTS.

Additionally, the audio console was displayed with the previous motherboards, but now it doesn't show up at all with the current one.

I am reaching out to ASUS through this post for help, and if I am posting in the wrong place, please correct me to the right location. If the issue I am experiencing is not resolved, I definitely want to speak with an ASUS representative to address the products I use from the ASUS brand.

Warryor 3D

I gave the original Z790 Hero and your speakers.   Your audio seems to play fine in the first part of your video, but it starts breaking up in the later part.  The speakers seem to be having a problem deciding what type of audio it is.

You are just running the Optical out to the speakers?   Since the speakers will be decoding the audio, any chance something or some setting on the motherboard is causing the output to be altered from what audio is being decoded?

Do you have any unknown devices showing in the Device Manager?

Are you using the virtual mixer?

The optical cable cannot handle the more advanced versions of sound, since it is limited in bandwidth.

My first thought might be you have not installed your audio components completely, but make sure it is not just the source you showed with the problems.

In this forum, we don't usually work for ASUS

Maximus Z790 Hero,
Intel i9-13900k
Intel BE200

In my previous Z790 HERO the ENCODED sound sounded very good, I did not have this problem, but now with the Z790 DARK HERO the sound breaks, I already reinstalled Driver and there is no solution in it, there is nothing in the BIOS that fixes this. The logitech Z906 automatically detects the ENCODED sound and there is no platform that one can interact with, there is only what you see in the video as the PHYSICAL console. In addition, the cable is standard, it is OPTICAL, there is no preference in this.

I REPEAT in the previous BOARDs none of this happened, Z790 DARK HERO now has this problem. use the same Windows 11PRO as the previous ones.

Warryor 3D

Level 9

Can anyone tell me how I can get an ASUS representative to look into this issue?

LOGITECH Z906 ENCODED SOUND USING Z790 DARK HERO - Republic of Gamers Forum - 1019631 (

Warryor 3D

Level 9

@Warryor3D Can you confirm that all the required windows services are running on your machine? Basically, you did not follow some Windows 11 performance guides to turn off non essential services. Sometimes, we all accidentally follow performance tips without understanding the side effects of it.

I believe the following Windows services are needed:

  • Windows Audio
  • Windows Audio Endpoint Builder
  • Realtek Audio Universal Service
  • Remote Procedure Call (RPC)

You can check all these services are running by typing "Services" in the windows Search Bar and going to the Services Control Panel to see what is running.

Hope this helps with your Realtek Audio Console App not working and giving you RPC Error as you have mentioned above so that you can see it work properly. FYI, I have no issues with this app starting or showing me details.


Level 9

@Warryor3D Have you tried to uninstall the Realtek Audio Control App and then tried installing it again, just to see if that fixes your Realtek Audio Control App issue?