Showing results for 
Search instead for 
Did you mean: 

Random crashes with X670E Hero

Level 10


Before i go into the nuts and bolts let me spec out what i have.

X670E Hero - BIOS 1303
G.SKILL Z5 Neo EXPO 32GB 6000MHz F5-6000J3038F16GX2-TZ5NR
CPU and GPU custom watercooled (EKWB parts)

So the other night while attempting to play Jedi Survivor the onboard Bluetooth disappeared (not in device manager etc), odd I thought but not a deal breaker and not worth the 2 months i was quoted i would be without the board, anyway my fault finding was as follows:-

Applied my clonezilla image of my machine in case it was a rogue update, Image is from 2 month ago when the system was built (clean image OS, drivers and AV) but the device was still missing.

Clean build of Windows 11 Pro from freshly downloaded ISO, no device.

Reached out to ASUS who said run the diagnostics in MyASUS app but there are none.

I had some new fans which i was waiting on installing on my Rads and thought no better time than now, they all connect to a fan controller so all i did was unplug 6 and plug in 6 to the same controller (all noctuas) and tidy the cabling, now the bluetooth is showing again but randomly the PC now just shuts down, no BSOD logs but 6008 IDs in event viewer, to power back on I need to either turn off the PSU and turn back on (Seasonic TX1300) or use the onboard ReTry button.

I'm at a loss and kinda out of ideas so any help is welcomed.

332 REPLIES 332

Thanks for the help getting this resolved. I feel like 16xx resolved the issue

Level 8

I now have Corsair Platinum (CMT32GX5M2B6000Z30K) with 32 GB installed. The EXPO template now also works. I should have looked earlier which memories are supported. Thanks for your help. 64GB would have been cooler, but is not supported with the above model. My case has therefore settled.

Level 8

It's a month now since I updated the bios first to 15something and now on far not one shutoff, I guess the problem got solved. I am still interested to learn what the problem was and how it got fixed after waiting so long for my investment to run like intended.


@McDaniel wrote:

It's a month now since I updated the bios first to 15something and now on far not one shutoff, I guess the problem got solved. I am still interested to learn what the problem was and how it got fixed after waiting so long for my investment to run like intended.


****** good point, I bought mine at launch, so it's been a year of hell, and a waste of $600.  I actually gave up on mine, and bought an MSI board a while back - but I have this RMA'd board sitting in a box, maybe now I can sell it on eBay and not feel bad that I am selling a buggy, defective product to someone else !

As the OP who has raised multiple tickets to ASUS over this and been told "It's clearly a problem with your PSU!!" (a TX-1300 that worked fine on an MSI board i might add) only for everything to seemingly be resolved with a BIOS update i think it is safe to say we will never know.

ASUS don't strike me as the organisation that will come out with its hands up saying "Our bad we goofed" even a nod of acceptance would be better than this, but it will be ignored and ASUS will continue down this sub par support route as though nothing happened. I accept that it is what it is because ASUS will at the same time need to accept that I won't install their kit in my PC anymore nor will I recommend their kit and the company i work for won't buy their kit after following this forum thread and the emails i had with support.

Maybe a kidney shot to their bottom line is what it needed to get ASUS back to where they used to be but that is down to them and I for one will speak with my wallet.

Level 7

I will tell you all what asus does not have the guts to tell us.

The problem was compatibility between the ryzen CPU's and the RAMS
Not a special kind of kit, but most of them.

Level 8

I'm still occasionally rebooting with BIOS 16 and everything up to date.  My biggest issue is I still have to Reset the boot process as soon as I see the BIOS messages in order for my SATA Raid 10 Array to become seen/active.  

Customer Service Agent

Hello, @StrangeMind 

The main topic of this discussion thread is automatic shutdowns that require switching the PSU's power to reboot, and based on your description, it appears to be different from this issue.
To avoid any confusion and to ensure we don't miss your question, we recommend that you start a new discussion thread separately and provide detailed hardware specifications (CPU, GPU, RAM, etc.) as well as a comprehensive description of your specific issue.
Additionally, here are some FAQs that you might find helpful:
[Motherboard]How to create RAID in BIOS Setup
[Motherboard] Troubleshooting - Cannot find the hard disk drive or SSD(M.2) after motherboard powers...

Thank you.

sharing complete hardware info & software config details will help us better understand the issue 🙂

No no, I was having the exactly same issue but I refused to believe it was the PSU, psu of 1000W I used in my old AM4 board and had 0 issues. Instead always had problems since i moved to AM5 whenever I was trying to use the OC profile of the rams. 
After last bios update that improved agesa code I have no more problems at all and guess what? I can even OC the ram more then original settings now.

Well I've had over 60 Critical Event 41 Kernel Power "alarms" where my ASUS Crosshair Hero X670E just decides to reset.  It just did it while I was trying to write this response.  And like I said, latest updates everywhere.  I could get into what I have, but let me say I updated my 1000W PSU to a 1300 PSU 'cause it was getting old and I thought it could be.  It's not the PSU.  I've had ASUS Crosshair Motherboards since III, and I have loved them, but like someone said, this has been a year of hell.