cancel
Showing results for 
Search instead for 
Did you mean: 

"The system cannot find any bootable devices"

_jdog_
Level 7

Hi,
I know there are posts that are fairly similar but they don't seem to provide a fix for my issue, so please bear with me...
I've just built a new PC with a ASUS ROG Strix B650E-I Gaming WiFi motherboard. Everything is brand new except the M2 NVMe SSD drive from my previous build. The system starts normally, but Windows never boots up, I always get into the BIOS. My SSD is correctly listed as storage but does not show in the boot menu. The boot menu shows the "The system cannot find any bootable devices." message.
I have tried to enable the CSM mode (as seen as a solution in some forums), but even though I set it to 'Enabled', save and exit, at the next startup the setting is shown as disabled.
I have tried to use a bootable Windows PE USB drive with EaseUS partition manager to check the disk and it looks fine. The partition manager is supposed to be able to fix the MBR but it does not make any difference.
Thanks for your help!


The SSD showing in the BIOSThe SSD showing in the BIOSSSD not showing in boot sectionSSD not showing in boot sectionThe boot menuThe boot menuTrying to enable CSMTrying to enable CSMIn the partition managerIn the partition manager

822 Views
2 REPLIES 2

_jdog_
Level 7

In the end I've had to convert my drive to from a MBR to GPT partition table (using EaseUS partition manager).
Not sure why activating CSM wasn't fixing the issue...

Jiaszzz_ROG
Customer Service Agent

Hello, @_jdog_ 

Thank you for contacting us and for sharing the images of the BIOS settings.
May I ask if the issue has been resolved after converting the partition table format?
Based on the photos you provided, the current BIOS version is 1818.
We recommend considering updating to the latest BIOS version 2413, released on February 7, 2024, to benefit from improved functionality and performance enhancements if needed.

Thank you.

sharing complete hardware info & software config details will help us better understand the issue 🙂