Showing results for 
Search instead for 
Did you mean: 

ProArt Z790 Wifi Creator, Thunderbolt Not Working?

Level 8


I just got my Windows 10 system set up with the ProArt Z790. I pulled the C drive from my previous Asus motherboard based system on which Thunderbolt was working. I updated the BIOS, and downloaded and installed drivers for this motherboard.

On this new motherboard, as best I can tell everything is in place, but I get no communication now to my Blackmagic Multidock. Thunderbolt is Enabled in the BIOS.

The Thunderbolt Control Center shows Port 1 and Port 2 under "Attached Thunderbolt Devices". But under "Approved Devices" it says there are none.

Can anyone solve this?




Customer Service Agent

Hello, @lahatte 

May I inquire if your BIOS version is 1801, and under BIOS settings, is the "PCIE Tunneling over USB4" option enabled?
When you mention the inability to communicate with the Blackmagic Multidock, does it mean that the system cannot recognize the device at all?
Which port are you connecting to, have you used an extension cable, and have you cross-tested with another port?

Could you kindly provide the following information to help us better understand your situation?
- all the images of the setting in BIOS
- the OS version and OS build
- the brand and model name of the CPU, GPU, RAM (part number as well), SSD/HDD, and PSU currently installed
- are there any extensions or adapters used to connect any devices, such as GPU or SSD?
- relevant driver versions, such as Thunderbolt and Blackmagic Multidock
- screenshots of the Thunderbolt Control Center and any error prompts. 
If possible, could you provide a comprehensive video recording of the issue, including confirmation of Thunderbolt device connection, attempts to identify the device after system boot, and any efforts to access the Thunderbolt Control Center or Device Manager?

Thank you.

sharing complete hardware info & software config details will help us better understand the issue 🙂


As per customer support instruction, I have sent the board to ASUS for repair. It's sad that we cannot get actual technical support from knowledgeable people.

Anyway, I had all the latest drivers. BIOS version 1801, and PCIE Tunneling over USB4 was enabled. All the BIOS settings were default.

Like I had said, these devices worked with the Maximus XII board. The Multidock uses Thunderbolt 2 connector, and I have an Apple adapter to change the port to the smaller Thunderbolt port (type C). The computer monitor was connected via a Thunderbolt to HDMI cable. None worked on the ProArt board.


Customer Service Agent

Hello, @lahatte 

Thank you for your response.
Since you have already submitted it for repair, we recommend that you wait for the repair center's subsequent diagnosis or further assistance.
If you encounter any difficulties or concerns, please feel free to DM me with detailed context at any time.

Thank you.

sharing complete hardware info & software config details will help us better understand the issue 🙂

Thanks. 🙂

Well, ASUS repair indicated that there were 4 bent pins in the cpu socket. So I had them send the replacement board.

I got the replacement board installed and running, and still have the exact same problem. My Thunderbolt devices are not showing up.

Does anyone here have the ASUS Z790 ProArt Creator WiFi board, that has the Thunderbolt working?

Level 7

Good morning,

I have the exact same problem with Thunderbolt 4.

At startup the BIOS is so slow that it takes almost 45 seconds to start the OS and often Thunderbolt does not work. For this to work, you must NOT leave the peripherals connected to the Thunderbolt ports, but only plug them in when the PC displays the OS (Windows 11 here).

For the above tip to work, the power must first have been unplugged for 15-20 seconds then plugged back in and once started connect the Thunderbolt devices and then it works.

This Thunderbolt problem appeared after a BIOS update released almost a year ago. Resetting the BIOS to stock fixed the problem.

However, having since installed an Intel 14700K, I was forced to put the latest BIOS and Thunderbolt only works if they are connected once the PC has started.

It seems that my problem was that my devices were less than Thunderbolt 3. Thunderbolt 4 does not support Thunderbolt 1 or 2 devices.