cancel
Showing results for 
Search instead for 
Did you mean: 

Pcie 4.0 SSD (Crucial P3 Plus) not working on Pcie 3.0 board ROG MAXIMUS X FORMULA (Z370)

fr33xta
Level 7

So after reading through the web and seeing posts about backwards compatibility i've decided to get a Crucial P3 Plus 4TB to extend my storage.

I really dont care about speeds that much just wanted to go for the 4TB one which was a good deal.

So this SSD is a Gen4 Pcie nvme and i'm currently using 2 Gen3's in both M2 slots the board provides without issues. I'm aware that my board runs up to Gen3 Pcie max.

And of course it isn't working.

I've literally tried every BIOS setting regarding Pcie/Storage, disconnected all the other drives, seated the new SSD in both M.2 slots and also used a riser card on the pciex4_3 slot, the P3 Plus just isn't working.

Last thing i've tried was cloning my system drive (Crucial P1) via an external USB enclosure onto the new P3 Plus and tried booting from it, but the system just hangs as soon as it's landing on the desktop.

Likewise, no matter where it's seated (M2_1 or M2_2 slots, pcie card), after booting from my usual proven system drive (P1), the new P3 Plus is visible in disk management for a short time after booting up, but suddenly desappears after a few mins. it's not responding at all.

It's working fine via the USB enclosure, which gives me the impression that my BIOS isn't handling this particular SSD correctly.

I've got the most recent BIOS version flashed (2701) and also made sure the chipset drivers are up to date.

Specs:

Win1022H2
Asus ROG MAXIMUS X FORMULA
Intel i9 9900K
RX 6900XT
32GB (2x16) Ram

 

Any idea what i can do / similar experiences?

Is returning it and getting a Gen3, or using it via USB my only option?

I've read some Asrock Gen3 boards got BIOS updates and it worked after updating but there is none newer than 2021 for this one.

Cheers

 

edit: might've posted this in the wrong forum but can't see any option to move it. please feel free to do so.

692 Views
2 REPLIES 2

Jiaszzz_ROG
Customer Service Agent

Hello, @fr33xta 

Based on your description and the specifications found on the official website for the Crucial P3 Plus 4TB, this model operates on a PCIe 4.0 interface.


However, the m.2 sockets on the ROG MAXIMUS X FORMULA are designed to accommodate PCIe 3.0 devices.


Due to this disparity, there may indeed be compatibility issues, as you have described.
Therefore, we recommend that you refer to the specifications of the ROG MAXIMUS X FORMULA when selecting hardware components.

Thank you.

1TM1TM
Level 11

You can get to desktop and to disk manager, so BIOS does recognize P3 it and can read from it.

Although it could be a BIOS issue (submit a request to tech support) - it also could be windows driver issue. Try to boot into safe mode (read / watch how) , get into device manager (press Win key type device) and see if P3 is visible under Disk Drives. If so, right-click-properties - Driver-Update. Windows may find an updated driver for P3.

Alternative - search Asus site for your board, support section - for latest Chipset Drivers - update those (while on P1 drive) then install the P3.