Showing results for 
Search instead for 
Did you mean: 

Pc wont boot rog strix x570-i

Level 7

Everytime I boot up my pc it says "usb device over current status detacted" and turns right back off after displaying the screen shown in the picture below. It does not boot to windows and it doesnt even let me go to the BIOS.

It displays this message even after removing all usb devices and unplugging the case's front usb connectors from the motherboard. I even shorted out the pins for the cmos and gave it a good dusting with some canned air. idk how any circuitry could have shorted out since this thing has exclusively been plugged into an uninterruptable power supply since I built it.

Best guess I have is that either the mother board or power supply is to blame. one weird thing that happened is that when I received my factory sealed psu it didn't have a 24pin cable in the box and I had to contact the manufacturer to get one. When I got  the cable everything worked perfectly for 22 months! Now I'm kinda pissed cuz my pc became a brick 1 month to the day after the motherboard warranty expired...


anybody got any ideas how i should proceed? TY


corsair sf750 80 plus platnum

gtx 3090

gskill DDR4 3600 32gb (2x16)

Corsair Hydro Series H80i V2 cooler

ryzen 5800x








Hello Aileta

It could possibly be your case usb ports or maybe the cable(s) aren't fully seated.

With your pc shut down and psu switch off, disconnect the usb 2.0 and usb 3.1 cables, boot up and see if the message disappears.

usb connectors.png


Sorry, like I said, the case's usb ports are all already unplugged. thank you though Nate. It doesn't care wither or not I reseat them...

Customer Service Agent

Hello, @Aileta 

Could you please clarify if this issue occurred after the PC was first built or after using it for some time and occurred following any recent changes, such as a BIOS update or the connection of an external device?
Have you attempted a bare-board test, installing only the CPU, RAM, GPU, and PSU, and still encountered the same error message?
Based on the image you provided, please consider updating the BIOS to the latest version 5013, released on April 3, 2024, and clearing CMOS before rechecking.
Additionally, as suggested by Nate152, if possible, we recommend cross-testing with another PSU.

Thank you.

sharing complete hardware info & software config details will help us better understand the issue 🙂

omfg i just wrote an essay of a response and the webpage deleted it... here we go again


Thank you guys for the responses!

I have not bumped anything plugged into the back usb ports lately as the machine has not moved for a couple months. I have sprayed down everything on the mobo with canded air with extra effort to anything usb related. No new parts have been added since the inital build in 2022. I am currently unable to access the bios though it seems to know when the keyboard is plugged in.

I'm pretty good (not perfect) about safely removing usb devices when powered on and I only ever really swap out the ones on the front.

A day or two before it bricked i did have my oculus quest 2 plugged into the case usb port to charge while the pc was off. something i did a lot in the past but haven't for a couple months.

I haven't tried a full bare-board test in the way you suggest as removing the m.2 ssd will require me to dismantle my entire machine. but I'll give it a shot. I also never updated the bios because that scares me haha. the out of the box compatibility with ryzen 5000 was a huge reason I chose this motherboard. I'll certainly do that as a last resort!

when I do the bare board test, the only other psu I have is a 650w. While writing this I learned that my 750w psu may not be quite enough even though I've never had an issue until now. those "what psu do i need?" tests say i should have an 850w psu. I'm sure I did one of those before ordering the parts, not sure how that happened. Yikes. I'll certainly be ordering a new psu regardless! I'll remove the gpu and see if at least gets into windows.

Detailed parts list:

Windows 10

ASUS ROG Strix X570-I Gaming, X570 Mini-ITX Gaming Motherboard, AMD Ryzen 3000 with PCIe 4.0, WiFi 6 (802.11ax)

AMD Ryzen 7 5800X - Ryzen 7 5000 Series Vermeer (Zen 3) 8-Core 3.8 GHz Socket AM4 105W

Corsair Hydro Series H80i V2 Water / Liquid CPU Cooler. 120mm CW-9060024-WW

G.SKILL Ripjaws V Series 32GB (2 x 16GB) 288-Pin PC RAM DDR4 3600 (PC4 28800) Desktop Memory Model F4-3600C16D-32GVKC

ASUS TUF Gaming GeForce RTX 3090 24GB GDDR6X PCI Express 4.0 SLI Support Video Card TUF-RTX3090-O24G-GAMING

CORSAIR SF750 CP-9020186-NA 750W SFX 80 PLUS PLATINUM Certified Full Modular Power Supply

XPG GAMMIX S50 Lite Series: 1TB Internal SSD 3D NAND PCIe Gen4x4 M.2 2280 (NVMe)

Western Digital Blue 2.5" 4TB SATA III 3D NAND Internal Solid State Drive (SSD) WDS400T2B0A

LIAN LI TU150 Aluminum ITX Case - Silver Color - TU150A

CyberPower CP1200AVR 1200 VA 720 W UPS


You're welcome

Sorry about that, I see now that you disconnected the case usb ports. So, let's focus on the motherboard usb ports. 

I think it would be pretty hard to damage a usb port unless a usb cable got pulled or yanked the wrong way, did this by chance happen?

Is there any debris in any of the motherboard usb ports, have you tried cleaning them with canned air as well?

Possible power issue.

With your pc shut down, turn off the power supply switch and unplug the cable, press and hold the case power button for 5 seconds to drain any leftover power. Plug in the power supply cable and try booting up. If you're using a power strip, try connecting the power supply cable to a wall socket.

When it's booting up, are you able to enter the bios by continuously tapping the Del key? 





Level 7

I just tried unplugging all the SSDs and swapped the gpu for my older less demanding gtx 1070. still getting the over current message. when i swapped to the 650w psu it wouldn't even turn on. no lights or anything.