cancel
Showing results for 
Search instead for 
Did you mean: 

Not detecting my SSD

Michael572
Level 7

Last week, my computer was running fine while gaming; however, a few hours later, it started running slow and could not operate web browsers. So, I turned off my computer and turned it back on, but it couldn't make it to the BIOS screen. Next, I checked the RAM and GPU, which worked fine in a different PC. The next day, I went to buy a new motherboard, the MSI MAG B650 TOMAHAWK WIFI, and the PC continued to not turn on. I then tried a new CPU with the MSI motherboard, and I was able to boot into Windows without any issues. Next, I tried using the new CPU with my old motherboard, the Asus Strix B650E-E, and now it won't display the SN850X M.2 I have installed with Windows on in my BIOS, but it shows my Ubuntu M.2 (which is the SSD I did not try with the MSI MAG B650 TOMAHAWK). The last thing I haven't tried is using the MSI motherboard with my new CPU, but it doesn't make sense because I could boot into Ubuntu on my old motherboard. I have also tried the SN850X in different slots, such as the SN770 (the m.2 with ubuntu on it) but it still does not show my SN850X. 

What I've tried:

  1. Flashing my bios
  2. Clearing my CMOS (by pressing the button on the motherboard)

What happens:
I get this message: "Please enter setup to recover Bios setting. When Raid configuration was built, ensure to set SATA configuration to Raid mode."
But it does not detect the SN850X on this screen.

125 Views
1 REPLY 1

Jiaszzz_ROG
Customer Service Agent

Hello, @Michael572 

Based on your description, you've tested various slots in the ROG STRIX B650E-E GAMING WIFI, and it can correctly recognize the Ubuntu SN770 M.2 in the BIOS, but the SN850X M.2 for installing the Windows system is not recognized.
Could you confirm if, during the cross-testing of different slots, only one M.2 SSD was installed at the same time? Did you use an extension connection?
What is the current BIOS version for the ROG STRIX B650E-E GAMING WIFI, and after clearing the CMOS, have you enabled the CSM option?
We recommend referring to the troubleshooting guide "[Motherboard] Troubleshooting - Cannot find the hard disk drive or SSD(M.2) after motherboard powers..." to ensure the settings, and please update the BIOS if needed.

Regarding the error message, could you specify if it appeared after operating specific software or hardware changes? Was it during the system startup or the post-process?

Thank you.