cancel
Showing results for 
Search instead for 
Did you mean: 

No ethernet - Intel I226-V - Ethernet adapter not working - Z790 Motherboard

MachoFantastico
Level 7

Hi folks, so I need some help. Basically a week or so ago my ethernet connection suddenly disappeared and I've spent the past week trying to fix the issue without any success. I have an Asus Maximus Z790 Hero motherboard and have had no real issue with it for the past year. However the ethernet connection suddenly dropped and I don't know why. I have tried many fixes that I've come across on the web, here's just a few fixes I've tried:

  • Clean windows 11 install on 5 different occasions to see if it was a Windows 11 issue.

  • Tried 4 different ethernet cables but nothing.

  • Tried a network reset within W11 but nothing.

  • Reset my router three times to see if that was an issue.

  • Updated the BIOS but that didn't fix anything.

  • Tried uninstalling the ethernet adapter via Device Manager but when I do the device itself disappears entirely and when I scan for new hardware changes all I get is Intel Tile Device (which is hidden in the device manager).

I got it working at one point but it switched off after about five minutes. Luckily I have WiFi as backup so I could still use that. Another thing I noticed is usually with a clean install of W11 Armoury Crate will start up and install the LAN drivers, however when I have done one since it doesn't do this and the only way I can get the internet to work is via installing the WiFi drivers via the device manager. One thing I did notice was when I did have the network adapter installed I had an error message informing me (Code 45) 

To fix this problem, reconnect this hardware device to the computer..

At this point I want to give up. Nothing seems to fix this issue and it's either a case of drivers not working right or the network adapter on my motherboard is broken. It's so frustrating, I'm desperately looking for anyone who might have some idea on what's happening here. Thing is it just started happening, I don't think I really did anything to causes the issue to start so I have no idea on how to fix it.

Any help would be greatly appreciated.

172 Views
5 REPLIES 5

achugh
Level 11

Hi @MachoFantastico, I have Z790 DARK HERO board so not exactly the same board as yours. I will share some of my finding even though I have no issues in the hopes that it might help you.

If you are not on the latest version of BIOS (2301), please update your BIOS to the latest version and mention the version you are using here when you respond next time.

After upgrading the BIOS or if you already are on the latest version of BIOS, press F5 to reset the BIOS to ASUS defaults and now use the new INTEL BASELINE PROFILE option to chose PERFORMANCE baseline as your profile. Please DO NOT change anything else at this point just to rule out issues. Once the issue is understood you can start adjusting your BIOS as you normally do. Do NOT even enable XMP profiles for your memory as the goal is not to tune the system for performance but to find out if you have a hardware failure or a software issue.

Now perform a fresh Windows 11 23H2 installation using the official media from Microsoft. You can see some of these details in my issue where I posted yesterday in https://rog-forum.asus.com/t5/gaming-motherboards/can-asus-support-fix-realtek-audio-drivers-with-bo... post regarding where to download and how to prepare your USB device for fresh installation.

Once you have the media downloaded and your USB stick ready, DISCONNECT the network cable physically from your motherboard. You DO NOT want Windows trying to act smart and download drivers via online in case you have software issue and not a hardware issue. You MUST TURN OFF your WiFI ROUTER as well so Windows does not have any way to connect to the internet during installation. If you do not want to turn off WiFi router then make sure you do not have a static IP address using WiFi MAC configured in your router for Windows to get access to internet. Remember the goal is for Windows installation not have internet access.

NOTE: Once Windows installer starts make sure you use CUSTOM / ADVANCED installation and NOT UPGRADE option. Then FORMAT the drive on which you will install Windows and continue with the installation. If you end up formatting, format the SYSTEM PARTION (typically 100MB), the Recovery PARTITION (typically 512 MB) and your actual partition for windows installation. You will not be able to format the 16MB special partition. Or you can DELETE every single partition on the drive and let Windows create them again as part of fresh installation.

Once your file copying is done and Windows Setup REBOOTS your system for the very first time, you will start with the Windows OOBE (Out of the Box Experience) Wizard. Here you will select a region, a keyboard and any optional or additional keyboard. At this time you will be STUCK since Windows cannot connect to Internet. At this point you will need to press SHIFT+F10 key on your keyboard to open Windows Command Prompt. In this Command Prompt type OOBE\BYPASSNRO in all caps and press the ENTER key. This will reboot Windows and your OOBE setup experience will start all over again. This time when you select a region, a keyboard and skip or install an optional keyboard you will now see an option to SKIP INTERNET setup and continue to install with LIMITED SETUP. Use this option and continue to follow the prompts to finish the OOBE Wizard.

NOTE: At this time you will see ASUS Armory Crate window asking you to install the Network Driver as well as Armoury Crate application. You SHOULD chose NO to installing network driver as you DO NOT want to install this version of network driver from your BIOS (the BIOS version is old) and choose NO to install Armoury Crate application. You want to take control over what you are installing and the order of things.

Once you are in the Windows Shell or can see Windows Desktop properly, now Shutdown (not RESTART) Windows. This should complete your fresh windows installation.

Now wait for 1 minute and then press your START button to power on the desktop and log into Windows. At this time, use the installers from ASUS Support Website to download and install them in the following order.

NOTE: Either you should download them before or use another computer to download them and copy them to a drive you can access without network access since you WILL NOT have network access.

Now you can follow the driver installation order given in https://rog-forum.asus.com/t5/gaming-motherboards/can-asus-support-fix-realtek-audio-drivers-with-bo... post i.e.

  1. Intel Chipset Drivers - Intel Chipset driver V10.1.19600.8418 for Windows10 and Windows 11 21H2 64-bit.(WHQL)
  2. Intel Management Engine (ME) Consumer - Intel Management Engine Interface V2306.4.3.0(SW 2319.4.30.0) For Windows 10/11 64-bit
  3. Intel Serial-IO - Intel(R) Serial IO V30.100.2221.20 for Windows 10 64-bit, Windows 11 64-bit.(WHQL)
  4. Intel I226 Gigabit Ethernet - Intel I225 / I226 LAN Driver V2.1.3.3 For Windows 11 64-bit.
  5. Intel WiFi - Intel WiFi Driver V23.10.0.8 For Windows 10/11 64-bit.
  6. Intel Thunderbolt - Intel(R) Thunderbolt Driver V1.41.1335.0 for Windows 10 64-bit, Windows 11 64-bit.(WHQL)
  7. Realtek Audio - Realtek USB Audio Driver VB6.3.9600.2342 For Windows 10/11 64-bit. (SPECIAL VERISON)
  8. Intel Graphics Accelerator - Intel Graphics Accelerator Driver V31.0.101.4091 For Windows 10/11 64-bit
  9. Intel Bluetooth - Intel Bluetooth Driver V23.10.0.2 For Windows 10/11 64-bit
  10. Intel DTT - Intel DTT 9.0.11401.38310 (Ipf driver V1.0.11401.38408) For Windows 10/11 64-bit

At this time your Windows installation should be done and you should be ready to test. Before you do that, open DEVICE MANAGER and see if everything is showing properly and installed i.e. no missing drivers for any devices. If you see any missing drivers, install them for your device which are external to the motherboard's built-in device.

Now SHUTDOWN your desktop. Then connect the network cable. Start your desktop and test.

Hopefully, everything will work for you. If it does, now you go back into BIOS and start adjusting as needed slowly. Finally, install Armoury Crate as needed and continue.

 

Disclaimer: I am not an ASUS support person so my information may be incomplete. Always follow official documentation and material provided by ASUS representatives.

INTEL i9-14900K / CORSAIR VENGEANCE RGB 192GB (4x48GB) 5200 CAS38 / ROG Z790 DARK HERO / ROG TUF GAMING RTX 4090 OC / ProArt PA-602 Case / SEASONIC PRIME TX-1300 ATX 3.0 / CORSAIR MP700 PRO 2TB PCIe Gen5 / CRUCIAL T500 2TB PCIe Gen4 / EIZO CG2700X

Jiaszzz_ROG
Customer Service Agent

Hello, @MachoFantastico 

Thank you for providing detailed context.
Did the issue first occur a week ago after a Windows update or any specific software or hardware changes?
When experiencing wired network connection issues, please confirm if the LAN settings in BIOS are enabled and the LAN port indicator lights on the motherboard's rear panel.


Could you please confirm if the current BIOS version is 2301, and what are the OS version, build version, and LAN driver version?
Clean windows 11 install on 5 different occasions to see if it was a Windows 11 issue.
>>After clean Windows 11 installations, did you notice any changes, such as was the Ethernet recognized during startup but became unrecognized after driver installation?
>>After uninstalling the Ethernet adapter via Device Manager, did the Ethernet reappear in the Device Manager list after restarting?
I got it working at one point but it switched off after about five minutes.
>>What specific actions did you perform, and what actions occurred within those five minutes that led to the disconnection?
We recommend first clearing CMOS, followed by installing drivers using "Method 2: To install drivers and utilities through ASUS Support Site," then rebooting to verify the issue again.
If needed, please refer to the following FAQs:
[Motherboard] How to fix the cable network problems of Motherboard – Troubleshooting
Intel® Ethernet Connection I226-V Connection Issue

Thank you.

sharing complete hardware info & software config details will help us better understand the issue 🙂

JerryAtricks
Level 8

Yeah, I'm experiencing the same thing with a ROG STRIX B650E-F Gaming Wifi Mobo, so it's not just you. I haven't been able to get ethernet to work for about a week now. I updated drivers, bios, reset my router, bought a new ethernet cable, reinstalled windows 10, upgraded to Windows 11, uninstalled and reinstalled LAN drivers, and still nothing. achugh's reply is very thorough, but that's a lot of stuff to have to go through for something that should just ... you know... work. 

Hi @JerryAtricks, I am not sure exactly what is the current state of your system so I will give a quick/short information like a shot in the dark to see if this helps you out.

We all need to understand that the LAN Driver included in the BIOS is meant to support the oldest Windows version your motherboard will support. For all of us this is Windows 10 as it has not yet reached end of like (End of life for Windows 10 is October 14, 2025). Since BIOS does not know which version of Windows anyone is going to install, it assumes the lowest possible value i.e. Windows 10 in the hopes that Microsoft Windows will support backwards compatibility and the same driver will work in next version of Windows i.e. Windows 11. 

The included version does work for some versions of Windows 11 but not every possible combination and specially newer version (like I tested things with Windows 11 23H2). This is where we as the users/customers need to take charge and help.

I am going to refer you to Intel's Official Release Notes for this chip at https://www.intel.com/content/www/us/en/content-details/825696/intel-ethernet-controller-products-re... link. Here you will scroll to PAGE 7 of 17 in the embedded PDF file where you will see the drivers for Windows 10 are version 1.x (column 3) but for Windows 11 are version 2.x (column 2). See below

achugh_0-1719865577400.png

In the above picture read line e2fn as that is the chip we are talking about here under Intel Ethernet 2.5 Gigabit Adapters and Connections category.

The problem we all have is that our motherboard support pages are listing the 1.x version even for Windows 11 OS. This is causing issues and confusion for everyone including me for my Z790 DARK HERO board. Only 2.x version should be listed for Windows 11.

It is because of this confusion is why I suggested a fresh install.

In your case, you can uninstall your driver using the Device Manager with its UNINSTALL DRIVER button. Make sure you show HIDDEN DEVICES and ALSO remove any other older drivers as well till Windows Shows you that it is missing a driver. 

NOTE: Please makes sure you have downloaded the correct driver from ASUS Support Page before starting the uninstall locally and have ALSO DISCONNECTED FROM THE INTERNET so Windows does not install a driver automatically for you.

Once you have done a proper uninstall and REBOOTED to make sure no driver gets automatically installed after a reboot then run the ASUS Driver installer for your motherboard to install the correct version i.e. 1.x for Windows 10 and 2.x for Windows 11. Finally reboot one more time to check in device manager that your device is now properly detected with a driver.

At this time, connect to the internet and I hope everything works out for you. If you still have issues then we all here will need more details and possible screenshots of what is happening to help you out.

Disclaimer: I am not an ASUS support person so my information may be incomplete. Always follow official documentation and material provided by ASUS representatives.

INTEL i9-14900K / CORSAIR VENGEANCE RGB 192GB (4x48GB) 5200 CAS38 / ROG Z790 DARK HERO / ROG TUF GAMING RTX 4090 OC / ProArt PA-602 Case / SEASONIC PRIME TX-1300 ATX 3.0 / CORSAIR MP700 PRO 2TB PCIe Gen5 / CRUCIAL T500 2TB PCIe Gen4 / EIZO CG2700X

Thanks for the reply, achugh. I've made a forum post about my issue here if you'd like to take a look.